High GPU and CPU temps.

Technical Support
High GPU and CPU temps.

I have a Alienware PC , i7-8700 and Nvidia 1070 GPU and usually have CPU and GPU temps around 65. However lately as soon as I launch WOW , my GPU goes to 80 and CPU crosses 75+ and the fans are running full (expected at this temp). The moment I close WOW temps drop back to normal.

Anyone have this issue and how to fix this ?
The temps mentioned really aren't anything to worry about. However, if you're looking to lower the temperatures, you may want to try lowering the graphics settings and setting an FPS limit in-game. It may be worth cleaning out the computer as well if this hasn't been done in awhile.
Is this is Laptop or desktop PC?
11/12/2018 10:46 PMPosted by Hyperspace
my GPU goes to 80 and CPU crosses 75+ and the fans are running full (expected at this temp). The moment I close WOW temps drop back to normal.

Anyone have this issue and how to fix this ?


Since you didn't answer my previous question I will just state some basic things, GPU at 80 is normal but should be less providing there are 2+ fans on it. A Single fan at 80c would be expected for this GPU. My GTX 980 was around the same temp while gaming.

Though your CPU is questionable, why it's getting that hot tells me it's probably a Laptop or if a desktop you might need to clean out the dust/pet dander if it's been running a while (as Zhyxen pointed out)

If it's a laptop you can buy a cooling pad which help a little bit. Non Delided Intel I7 8700/8700k chips can run very warm to begin with. I have 3 and one of them is not delided (Soon though). I play in a very large full tower and a 360MM Rad cooler (Cooler Master ML360R in case you wanted to know) when playing wow it's around 50-55c. The other delided chips are around 40-48c. Are you currently leveraging a High performance power profile? that keeps the CPU from clocking down (power saving mode) so it forces it to into boost mode which is higher clock speeds 4.6GHZ on that chip, or 4.7ghz for 8700k.
This is a desktop , Alienware R7 , it's fairly new ... approx 5 months old and clean inside.

The reason I posted this is that after the last update I started seeing CPU temps at the same setting increase about 10* and not before that.

The CPU and GPU temps rise and fans start spinning the moment I load the battle.net launcher and not even enter the game.
11/13/2018 08:01 AMPosted by Zanidrel
Is this is Laptop or desktop PC?
Sorry for the delayed response.
11/14/2018 10:30 PMPosted by Hyperspace
This is a desktop , Alienware R7 , it's fairly new ... approx 5 months old and clean inside.


The GPU temps for a 1000 series are actually normal. The fan curve for those cards is fairly high.

The CPU temps are a little High. The radiator they use in those are very small. Especial since its a single fan.
11/14/2018 11:07 PMPosted by Northernlite
The CPU temps are a little High. The radiator they use in those are very small. Especial since its a single fan.


Why am I not surprised?

Join the Conversation

Return to Forum