I can't log in to any server....

Technical Support
Prev 1 4 5 6 7 Next
you want me to call speed connect or blizzard
So Barbary will this issue have a possible fix tonight or will we have to wait untill tomorrow?
SpeedNet/SpeedConnect. It will go to the message service after 10pm EST, but we'll follow up on all calls received tomorrow morning.

If it is on our end (and that's looking likely), the people that are best able to get to the bottom of the issue will be in after 8am tomorrow.
Well thanks Barbary for your help with this issue im not going to sweat over this its bed time anyways, its been along day for me, and to the rest of you good nite and good luck
yea so if i work during day and not get home by 600 est maybe it will be fixed or should i call tomrorow
thanks for the advice barbary
can i expect speednet to not charge me for the month due to 3 years of @@@%ty unreliable service?
i am logging hopefully wow and speed net can get it fixed have to work in am wanted to see how it was to play at home instead of going to byf work to play it lol
I don't think it's a Local thing, Since I have the same problem and i'm in Australia.

Was working fine last night, I jump on today and all the screens hang, and no server loads.

Tracing route to over a maximum of 30 hops

1 25 ms 55 ms 24 ms 24-237-132-2.anc.clearwire-dns.net [
2 29 ms 31 ms 27 ms 169-60-74-65.static.gci.net []
3 39 ms 30 ms 27 ms 161-60-74-65.static.gci.net []
4 115 ms 61 ms 68 ms 88-250-223-66.gci.net []
5 66 ms 72 ms * 32-129-165-209.gci.net []
6 95 ms 68 ms 56 ms 106-129-165-209.gci.net []
7 61 ms 79 ms 62 ms GigabitEthernet5-2.GW7.SEA1.ALTER.NET [157.130.1
8 75 ms 61 ms 62 ms 0.so-3-1-0.XL1.SEA1.ALTER.NET []
9 69 ms 75 ms 61 ms POS6-0.BR1.SEA1.ALTER.NET []
10 59 ms 58 ms 61 ms

Area: Anchorage, Alaska
server: Ghostlands
ISP: Clearwire
i wish i was computer literate dont understand what timebandit is saying
I just want help D: stuck on loading screens, saw a blue post saying bout trace route so i did one to ghostlands server, can connect fine, go to character screen fine, just stuck on loading screen and get dc'd after like 5 min
Clockwerkk: Signs point to no... =P

But if you're having an issue with your general service, call us. This isn't the place to get it fixed.
I did the standard delete cache wtf and interface folders then flushed dns and that still didnt fix the issue but then ran the blizzard repair function and all seems good recommend trying this before harassing blizz employees :)
I live in the Saginaw/Hemlock area in Michigan, have Speedconnect, and am having the same problems as of today.
Well I went to bed. Woke up and Now Still the same Damn Problem. I'm going to try the Blizzard repair, I pray it works. If not then Speenconnect has another call coming.
I recommend running the Blizzard Repair tool. Worked for me
looks like the problem was fixed over night lol
If you're a MI SpeedNet/SpeedConnect customer and you're still having this issue, please call us. We're pretty sure we fixed it.
I've still got the issue, after running all the usual fixers including the repair function.

Join the Conversation

Return to Forum