Blizzard raid frames bug

Bug Report
I don't know if anyone else has had this issue, but i've been noticing quite frequently on my alt. disc priest a bug with the raid frames that, when in bg's, sometimes wont let me click on a player to heal them.

It's happened a lot, and makes it really annoying when trying to heal someone to not be able to target them from the raid frames and have to manually search for them.

plz fix if its a bug.
Same problem.
Same class and spec.
Also only happens in BGs as well.
Seems to have started recently (since 4/19 maintenance)
btw. If you do a /reload ui it fixes it. Not a very good fix during a fight, but it works. I also noticed this issue seems to happen when someone leaves a BG and is then replaced. It seems to shift the frames, meaning whoever you click on you'll actually be targeting the person above or below that person. Annoying.
same here

not fixed in 4.1 release a few days ago
still experiencing this problem
having this problem on my 73 shammy - still (post 4.2)
This problem hits me every single time I try to heal in a BG or TB. On average in the large fights I might be able to accurately heal for about 4 or 5 minutes before I must reload the UI which fixes it for the next few minutes. The worst is when I can't even target myself as a resto shaman and can do nothing but die. About 5 minutes ago I had this happen in a TB, I reloaded ui to find I’m dead but naturally I have no release button available, sense you can't steal insignias in TB I had to lay there being laughed at by the opposing team until someone was able to rez me. This has got to be one of the most annoying bugs I’ve experienced in this game, making any PVP healing not an option.
EXACTLY What Simplicitie said, including the no release button after /reloadui [fortunately it was in AV, and someone ganked my insignia after 5 minutes or so, but still.

This has been happening to me CONSTANTLY the past few days. Worse when class colors are displayed [and I also get the "heal last target before current target" as well]

Don't have the issue when using grid, but I've now gotten used to the blizzard raid frames, and it's driving me NUTS.

Figured it can't hurt to log this somewhere ^^
EXACTLY What Simplicitie said, including the no release button after /reloadui [fortunately it was in AV, and someone ganked my insignia after 5 minutes or so, but still.

This has been happening to me CONSTANTLY the past few days. Worse when class colors are displayed [and I also get the "heal last target before current target" as well]

Don't have the issue when using grid, but I've now gotten used to the blizzard raid frames, and it's driving me NUTS.

Figured it can't hurt to log this somewhere ^^


It's a bug whenever someone leaves the BG, disconnects, or is replaced by a new person. I've had it going on for quite a long time -- I want to say ever since the release of Cata.

One thing you can do that MIGHT help (but isn't consistent, as sometimes you have to reaload your UI regardless) is going into your interface and to raid frames and changing from "keep groups together" and "horizontal groups". Class colors also bug out, so I have to check that usually too. Pets used to bug out and give me an error screen whenever I hovered over their unit frames, so it might be in your best interest to not include pets in your raid frames too.

This is extremely annoying, especially when someone disconnects in a rated battleground and suddenly I have to figure which person has switched to where so I can heal them until I can get away to reload my UI or try changing my options.

Also, if you disconnect in a BG, the UI completely disappears and nothing can fix it except reloading your UI. Happened to me in a rated BG last night along with several people disconnecting over and over and I never got the chance to go reload it inside the BG (as it takes forever to complete) so I had to heal people through their nameplates, which I find incredibly annoying. :(
i had the same problem, at first i thought that "keep groups together" was what was bugging it out....afterwards i disabled the addon altoholic and it works fine.
I also have this problem

I'm confused as to why this issue has yet to be addressed.

As much as I don't want to go back to using a unit frame mod, it seems that's the best option.
Same problem here. Resto Druid.
This all started with that patch we got just before cata went live.
Please fix this so I can remove the addon im forced to use now :-/
Since all the forums I've searched haven't gotten any blue acknowledgement for this bug I might put in an in-game ticket as well. This really needs to be fixed. They introduced this feature that I love (raid frames) so I don't have to have an addon, yet now I have to have an addon because that feature is broken.
Looks like I'll be getting Grid because of this, its really annoying in battlegrounds, and tonight even in ICC it was doing that as well.
I'm starting to really have this issue as well. I'll see if disabling class colors fixes it. It seems that class colors don't always update (throughout any entire run sometimes), so hopefully that'll solve the problem.

Definitely needs fixing though. Hard to heal on my Paladin with this bug active.
Experiencing this as well. Several other people I know suffer the same fate, whether they use Clique or simply left-click portraits and heal them regularly (no addons). The Raid Frames bug out randomly, and it becomes impossible to target people via the frames. It's as if the frames shift, but the UI doesn't acknowledge that they did. Sometimes seems to occur if polymorphed or hexed as well.
Noticed the little patch we got today didn't fix this bug.
This is a major bug that needs to be number 1 on the fix it asap list as it is truly game breaking.
This bug has been in game for almost a year now :-/
You can not leave this bug on the back burner like this.
Still having this issue. Months later. please fix
Still happening to me in Patch 4.3

Join the Conversation

Return to Forum