Warrior autoattack not functioning the same.

Bug Report
1 2 3 6 Next
The problem seems intermittent. I start attacking my first mob, it dies. Press my next special attack (usually blood thirst) it targets next closest mob(sometimes), hits him and stops attacking all together. I've tested this on a single mob too, approach mob, use special ability success, then no following autoattack.

I have to manually click on the next mob I want to hit, right click to start my auto attack, and begin my rotation. The frustration of it is that I can't generate enough rage to carry out my rotation. The mob is usually dead before I get to lay into him. The old way was much more fluid: hit bloodthirst or any ability then auto attack starts, mob dies, hit your next ability, it targets mob then keeps attacking.

In pvp it is a nightmare trying to target a running enemy and initiate an auto attack. I tried a start attack macro but i dont think it is very efficient for me.
Go to Interface -> Combat. Do you have Stop Auto Attack checked?
Yes. Unchecked and checked it just to be sure. Same result. The feeling is just like it is unchecked, to sum up what is happening.
When I get home I will run some more tests. This may or may not be part of the problem but I use clique, skada, and quartz. Mainly for my healing pally. I'll turn them off to see if it helps. Also, there was a similar post and problem in the warrior forums about this issue.
03/21/2011 7:21 AMPosted by Singlemom
Yes. Unchecked and checked it just to be sure. Same result. The feeling is just like it is unchecked, to sum up what is happening.

Exactly. I have been having this issue since week one of Cataclysm. It seems to pop up more in certain 5man Heroics than others. Very frustrating (working as intended...hmm?)
Same Problem.
is really frustrating and makes me feel Clunky and Slow. >=|
I'm having the same issue, when i'm attacked I would always auto-attack and when i used an bility like shield slam, i will auto attack after i use the ability.. what is going on?
bump this is annoying
I thought it was just me, thought I was suddenly doing something wrong.

This is VERY annoying issue!!
I have noticed this as well.
yup same here
Just to add my 2¢ worth in.

Same here. I actually only noticed it when I started levelling a warrior.

On all my other alts I can tab target then auto attack kicks in untill I am ready to rend etc (My warrior is still only a baby). Now I have to target, then press T and then start my rotation or else my toon just stands there and beat up.

Is there any possibility a blue could look into this at all please or at least comment on the thread? I was beginning to think it was just me! I would really appreciate any advice or feed back people can offer in the mean time. :)


i don't know how often i have found myself doing absolutely nothing when i thought i was auto attacking!
Yup same here sometimes during a trash pull i find my dude just standing there even after i used rend
This issue just started happening to me today, reset all keybindings, logged out and back in, even re-installed wow, nothing has helped so far..
I got same thing going on . But wait now my casters sometimes get auto targeting could it be that blizz tried to give it to casters and messed up warriors.
I can confirm this bug too, even using the default key binding of T standing point blank to an attack able mob, my toon refuses to start attacking. I haven't noticed it so much because I usually start my rotation with Devastate, then autoattack takes over. Mashing right click in range of an attack-able NPC is not giving me the previous desired result of starting to attack.
It seems intermittent (yay), i was originally testing it in Deepholm, went to Stormwind and whacked a rat and it worked fine.
I've had this same thing happen on my Lv29 Warrior, where I would use a special attack and then no autoattack would follow.

For now, I just use a macro that cast Bloodthirst then casts autoattack.

Join the Conversation

Return to Forum