Latency Issues

General Discussion
1 2 3 11 Next
We’re aware some players are experiencing ongoing latency issues while trying to play World of Warcraft. We’ve taken steps to investigate the cause, and at this time we’re confident that our systems and network are performing properly. We are actively collaborating with our industry contacts to assist in the diagnosis and hopeful resolution of broader internet latency issues, which are suspected to be the cause of degraded performance.
Thanks!
I know I've ran several tracers and the info I've come up with point to ATT.net in the Chicago area. Things do seem to have gotten better in the last week or two, but every time I've had and issue, it always points to that station. (at least when I play on Executus which is 98% of my play time)
If you're dealing with those a-holes, you've got my condolences. ATT sux as an ISP.
Please try hard im dying over here lol......That is all thank you
LOL working as intended
I think its where the companies pass off the connection to ATT
So are we going to be reimbursed for the subscription money we've spent over the last two months that this issue has been ongoing, since it's now clear that it isn't a subscriber computer issue, but a Blizzard / AT&T issue?
03/24/2011 11:36 AMPosted by Illuminus
Please try hard im dying over here lol......That is all thank you


They can't really promise anything if it isn't a problem with their network or equipment, it is up to the ISPs to fix. To make sure it is alleviated quicker, you should call your ISP and lodge a complaint too.
So are we going to be reimbursed for the subscription money we've spent over the last two months that this issue has been ongoing, since it's now clear that it isn't a subscriber computer issue, but a Blizzard / AT&T issue?


Blizzard are doing the above and beyond what is required of them by contacting AT&T to get their issues sorted. They don't owe you a reimbursement.
So are we going to be reimbursed for the subscription money we've spent over the last two months that this issue has been ongoing, since it's now clear that it isn't a subscriber computer issue, but a Blizzard / AT&T issue?


Go read the EULA.
So are we going to be reimbursed for the subscription money we've spent over the last two months that this issue has been ongoing, since it's now clear that it isn't a subscriber computer issue, but a Blizzard / AT&T issue?


Blizzard are doing the above and beyond what is required of them by contacting AT&T to get their issues sorted. They don't owe you a reimbursement.
Blizzard is protecting their own bottom line by contacting AT&T to fix latency issues which are causing subscribers and entire guilds to quit playing WoW due to the unplayable latency.
Verizon FioS here. I get latency at times, but more so on my side account than my mains. I figured the system was trying to figure out if I was a bot or not. Guess that was too much to hope for, oddly enough.

I just switch to cable ISP and I still having latency issue. They told me that my end and their end is working perfectly fine. Before that I had DSL AT&T, the latency working perfectly fine. Thank you Blizz. Now I can do is wait to resolve the problem :0)
I've tried everything i could think of to try and fix this problem. im not sure why its going on but it has been for the passed 4 days. I'm growing tired of this problem and would like a response as to why/how this is happening.

Thanks, Max.

Join the Conversation

Return to Forum