WoW through speakers vent through headset

General Discussion
i just want to know how i can make it so that WoW sounds play through my speakers while my vent sounds play through my headset. my operating system is windows 7.
I do this, but i have an audio card plus onboard audio.

I don't know if you can do this with only onboard audio, if that's your situation.

I don't think that is possible
Go into your game
>Click Esc
>Go to Sound & Voice
>In the hardware section on the top right, pick your speakers/audio output for the Game Sound Output.
>Now when you plug your headphones in, the game will still play on the speakers and your system/vent will play its sounds through the headphones.
USB Headset, Most come with a CD that you can install to make it act like a 2nd sound card. Change your Ventrilo setup to use the headset as your default input/output.

Will try to find a link for you. Give me a few
with windows 7 just click on the speaker icon twice in the lower right, a slider will appear for wow and a slider for the mixer, tell it to (wow) play thru "xbrand headset" and that should do it.
im not at my computer atm so icant double check that but its something like that
@gristlejack/dreadmaus. i used to do it on this same computer with the same setup. just don't remmeber how.

@denarus. i've tried that and just tried again. the sound still plays through my speakers when i select 2 of the options. for the 3rd optino i get no sounds.
@conqueso when i do that i don't have a slidebar for WoW unless i go to mixer and from there i can only change the volume not where it plays from
You can do it if you have a USB headset.
Setup your system (in control panel) so the speakers are your default sound output.
In vent, go into Setup and set the Input/Output devices to your USB headset.
You don't need to change anything in WoW, it will normally output sound on the system default device.

If your headset is not USB, I haven't found a way that it can be easily done...so I always make a point of buying headsets that connect to my system via USB for this reason.


I used to do the same thing with my headphones that used rca jacks. You just have to make sure the headphones are plugged into the video card itself - not the jacks built into the case.
Thanks for this.. I thought it was going to be a pain in the but to do, but found your comment and Presto.. Works like a charm.

Join the Conversation

Return to Forum