Official Camera Stutter, Part 2 (Mac)

Mac Technical Support
1 2 3 6 Next
Hey Mac Community,

So in order to keep this topic on going and alive, I am making a new thread and sticky-ing both for tracking. The cap on the old thread will soon be reached, so please feel free to post on this thread for continuation.

Tony Mac
Mac Tech Support for Baaaaahlizzard Entertainment
Can't find it here? Contact a rep direct: ---- Rate my Baaaaalue Posts. Haala at your Sheep!
I'm one of the four sheep of the apocalypse.
Horses aren't as scary anyways.
Here's the original post from the first thread for reference:

I know Blizzard is well aware of the stutter that occurs when players would turn in the 4.0.1 Mac client, but now it's even worse. Like Omegal, I upgraded my video card to the HD 5870 from my previous 5770, yet I'm now gettinf far worse turn stutter virtually anywhere in the game world than I did on the 5770, which is roughly half as powerful as the 5870. Why is it that while we see improvemente in the FPS department as a whole (when remaining stationary, are indoors, or are moving forward and not turning) there is now a huge drop while turning?

By "huge drop" I mean literally, on a 5870, going from a solid 60 FPS down to two frames per second when turning more than a hair. It's as if all of the textures not in your FoV are instantly dropped and have to be reloaded, apparently as slowly as possible.

I'm not running WoW off a HD either. it has its own dedicated SSD, as does my OS boot drive. Even my emulators, Stepmania, and UT2K4 are on an SSD (secondary games drive). I may be on a 1,1 Mac Pro, but I should be getting far better results than this, especially considering my older 3870 card wasn't having turning issues like this in 3.3.5 (I had to upgrade the card and my OS because 4.x just did not like the 3870 much).

Here are my system specs and setup:

Mac Pro 1,1 (2x2.66 GHz Xeon 5150)
ATI HD 5870
Intel 80 GB SSD (2nd Gen): OS Boot Drive
OWC Mercury Pro 40 GB SSD (SF1200 Controller): Secondary Games Drive
OCZ Summit 60 GB SSD: WoW
WD 1TB Green HD: Downloads and secondary OS boot drive (reversion backup)
External WD 1 TB Green HD in eSATA Dock: Clone of internal 1TB HD, backed up monthly
Pioneer DVR-118A
Pioneer BDC-202
Mac OS 10.6.5

gxApi in use: GLL
Game Settings: All at highest except for Shadows (Good), Multisampling (1x), Texture Filtering (Trilinear, as I don't notice any difference between Trilinear and Anisotropic at my native resolution of 1920x1080, and hardly any difference at 1600x900 which I'm forced to play at due to WoW being unable to detect/use 1920x1080p).

Game settings did not change since last patch other than to reset UI scale to Active.

The bottom line is whenever I turn, I feel like I'm running off of a 4200 RPM laptop drive from ten years ago and not off an SSD.

For additional reference, my framerates being noted as lower are against the framerates (while turning) in the previous patch in which I also had OS X 10.6.5 (5H74), and a 5770, a notably lesser card than my current 5870.

Should Mac users just forego the pretty texture options and use OpenGL instead of GLL? GLL was great in 3.3.5, and it's gotten progressively worse and worse ever since we patched to 4.x.

I want shiny WoW. of course a working 1080p resolution would be great too, but after the email I got from the Mac support dept, I have zero confidence anybody there knows that HDTVs are simply LCD monitors with tuners. They use the same EDID info as "regular" monitors. I wil mostly blame Apple for its rather stupid way of listing resolutions in 10.6.

Here's hoping GLL will stop puking all over itself during turns in a not too distant patch.

Current Status of this issue: Improved slightly (on 4.1 PTR client as of 4/12/11), but not fully resolved.

Note: I have updated my OS version since that post.
Thanks for summarizing this for us Tia. We can keep this thread going, on topic of course. If others have issues other than camera stutter, then please create a new post.
Mac Tech Support for Baaaaahlizzard Entertainment
Can't find it here? Contact a rep direct: ---- Rate my Baaaaalue Posts. Haala at your Sheep!
I'm one of the four sheep of the apocalypse.
Horses aren't as scary anyways.
Very similar configuration and very similar problems - particularly in Stormwind. I can be flying along at 60FPS then I turn down toward the ground and I pause or go down to <10FPS until it finishes doing whatever its doing.

Mac Pro 2008 Octo Core, 16GB RAM, OS 10.6.7, OS & WoW running from 2 Intel 120GB SSDs in RAID0, Radeon 5870 1GB.
To the poster near the end of the previous thread (which is now capped):

04/16/2011 12:04 AMPosted by Stormtides
there are limits set by both Windows and OS X that prevent a single app from using more than 2GB simply to reserve space for caching and other OS-specific functions.

On windows, yes. By default, since 10.3.0 32-bit apps compiled properly (as in no cross platform code) have PAE capability on by default if built against the 10.3.x and later environments. There is likely, however, some code in WoW's client app that specifically prevents PAE from being active, thus we have the 2GB hard wall right now. Gaining PAE would allow up to 4 GB of RAM to be accessible to the app, which would allow for a full 3 GB heap stack plus a 1024 MB texture cache for fast swap to VRAM. We don't even need to go 64-bit for that - just need PAE enabled.
I'm continuing to have these issues on both my 8Gb iMac [ATI Radeon HD 5750] and my 4Gb MacBook Pro [NVIDIA GeForce 9600M GT ]. Both systems have Mac OS 10.6.7 with all current patches.

This problem started with 4.0.1 which went live over 6 months ago. [On October 12, 2010]
I have this problem and it makes gameplay VERY difficult, I've lost several arenas and almost wiped raids because of it. I have a Macbook Pro 15'', using NVIDIA GeForce 9600M GT/NVIDIA GeForce 9400M depending on which setting i use. Most of the time i'm using the 9600m GT though. I've got 4 gigs of ram, 2.4 GHZ Core2Duo and 70/250GB's free. I'm getting a new hybrid hard drive within days, hope it helps.
I did more testing on ptr 4.1 last night. This time i spent moer than just a few min on ptr, i had to run a lot of tests so i was on it for about 3 hours and i changed zones a lot. needless to say after client being open that long, i had to take a trip to zangarmarsh and wow, all i can say is movement crippling stutter, honestly super minor better than 4.0.6 would in that zone. makes me wonder if 4.1's fixes were just superficial to the fact the client was a fresh launch in most of our earlier tests and just hadn't had enough time to fill up it's memory yet. and zangar was NOT streaming either. will find out on live though when more real time testing can be done
I'm gonna have to concur. Zangarmarsh is the pretty much ultimate test for the stutter. It showed negligible gains on my system, meaning that while progress is being made, it isn't anywhere near enough to make using Ultra playable on Macs in the least.

Something's gotta give on the resources the app has available to it. The current texture cache, whatever the PTR uses is too small, and you can't bump it up any further without further exacerbating the issue of the client hitting the 2 GB RAM wall in the new zones on Ultra. You can only eek so much performance out of 2 GB RAM, and sadly with how large the world view is in WoW, on Ultra that just don't cut it.

Until the app gets more resources, the players' hands are tied behind their back.
So Tia, what do you recommend needs to happen?

Because IMO why have an ultra graphics setting if no machine can use the game at ultra without issues.
I've already stated several times across both of these threads what needs to be done, at least as an attempt/test to try and alleviate this issue. We all know part of it is poor video card drivers. Nobody's disputing that fact. There are two other parts: One is the lack (or lack of proper coding for if already implemented in the GLL backend) proper GPU/CPU synchronization, which is enabled in one of the functions for OpenGL 3.2 or 3.3 (can't remember which offhand).

The other part is the lack of available texture cache for palette/texture swaps on the fly that aren't agonizingly slow. On video cards with 1024 MB of VRAM, the OS requires double that in system RAM for the very specific reason that it needs at half of ithe availble (assuming minimum required) RAM for texture mapping. The OS never runs into these kinds of stutter unless the video card driver is really in bad shape (that has happened a few times in the past even on Windows), and this is because it can use as much RAM as the card has for its VRAM in order to facilitate texture swapping en masse (say, on switching users, using Expose, or spaces). WoW currently has, at least as of 4.0.6, a limit of 64 MB of texture cache. That's a paltry 1/16th of the top of the line Mac video card right now in terms of RAM. So while the FoV may use more than that to store textures, only 1/16th of the total VRAM on the top end cards can be swapped out in any given moment. That's a huge bottleneck, especially considering 64 MB generally doesn't even cover the FoV in front of the player fully, thus whenever we turn, we stutter as new textures are reloaded into VRAM from either HD/SSD or system RAM. Thing is, it happens so often that reliably playing just isn't feasible on Ultra. And even if the texture cache were doubled to 128 MB, that's 1/8th the possible VRAM high end cards use right now. So if the area you're in uses say 512 MB of VRAM, in 4.0.6's client, if you spun around a full 360 degrees, you'd have to texture swap eight times (8 x 64 = 512). It'd be at least four full swap cycles even with 128 MB of texture cache.

Then you run into the stack heap (app RAM which includes the texture cache) running dangerously low as it closes in on that magical 2 GB barrier. With a 64 MB cache we were already hitting 2 GB (and crashing from it) on Ultra. Those crashes would happen sooner rather than later if the texture cache were bumped up any. But with the full 4 GB RAM available to the app via PAE, the texture cache could be a full 1 GB (1024 MB) and that'd still leave the app 3 GB of RAM for other uses, which is a full gigabyte more than it can use right now. So that'd be 3 GB RAM (no texture cache) + 1 GB texture cache as opposed to 2 GB on Live, which includes the texture cache in that amount.

I know changes aren't always easy - anybody that's ever done more than a Hello World coding project knows that. But the changes to give WoW the full monty when it comes to resources has to be less painful than trying to kludge a larger texture cache into an already full plate of RAM use. It's like trying to stick bacon and eggs with your english muffin onto that tiny bread plate which normally houses the english muffins only. You can do it, but you'll either sacrifice quality or quantity (or both). Realistically you need a bigger plate. And that's where we sit. Our plate is too small to hold what we're trying to eat.
Yeah usually when i am playing I am at about 1.88 GB used by WoW on my system on Ultra. And I have crashed out due to hitting 2GB on one occasion. Not sure what happened to push it over.

So pretty much we as customers are :expletive: and have to wait on all 3 of the companies to pick up the pace (apple/ATI/Blizz). To make this game playable on Ultra.

Who do you think has the biggest affect on fixing this? Blizzard making the program PAE? Apple updating OpenGL or ATI fixing their drivers?

Substitute NVIDIA for ATI if you have a NVIDIA card.

EDIT: I don't have much faith in Blizzard these days. Especially after breaking my Razer Naga.
I would say Blizzard by far has the largest role in the stuttering issue, since it is their own code limiting them to 32bit and non-PAE. Nothing Apple or ATI/NVIDIA can do will increase the amount of RAM available to the WoW application. Now, if we're talking raw framerates, that's where Apple and ATI/NVIDIA come into play. FWIW, I never found the framerates to be all that unacceptable but the stuttering is really annoying.

I also wonder if I'm not the only one who is considering giving Rift a try, since I have to boot into Windows to run WoW decently anyway...
Yeah for the most part framerates for me are fine, even on Ultra. The stuttering is BY FAR the biggest issue. When it's not stuttering I don't even think it needs any improvement. Framerates are completely playable and everything looks really good.

But the stuttering. OMG. It's by far the single worst problem the WoW client has on the Mac right now.
I notice this issue didn't make it into the 4.1 known issues thread...
It may not be in the notes but it is still stickied. That counts for something. Right now the modifier key isue is the top priority.
Well it is good to know that there are discussions about an issue which is, bottom line, making my game unplayable. Is there any evidence that this problem has any correlation or even causation regarding the hideous targeting bugs? They persist even though there was a fix all it did was push the problem to the opposite extreme. Now many hunters cannot hold targets.
I think I'm having same issue here on my mac pro. Used to set multisampling to 8 and it was quite smooth, but after 4.1 patch, with the same setting, the screen looks like frozen wheneve I move or rotate screen. This got hugely improved if I set multisampling to 1, but even raise the setting to 2 makes it looks like still pictures. My mac pro is the 2.4G Xeon 8 core model, with 10G RAM and Radeon 5770 graphic card. If any additional information would help you guys identify the problem, please let me know.
I get the same issues! Doing solo silly things at 60 FPS. . then I get in a raid or BG i go from 60fps to 2fps. with the lowest graphic settings... experimented with everything. I still get the same outcome 60fps into 2fps BG or raid, was 4.1 a bad turn of event for ALL MAC Pro users?
05/06/2011 01:42 AMPosted by Pogi
I get the same issues! Doing solo silly things at 60 FPS. . then I get in a raid or BG i go from 60fps to 2fps. with the lowest graphic settings... experimented with everything. I still get the same outcome 60fps into 2fps BG or raid, was 4.1 a bad turn of event for ALL MAC Pro users?

If you're fine solo but your FPS tanks in a group/raid, then you have an addon problem, which as much as I hate to say it, is not related to this issue. This particular issue involves all aspects of the game, even solo play.

Please start another thread to ask for assistance with the issue you're having. :)

And check those addons... I smell Omen, Recount, DBM (yes, DBM) and Archy at work here. DBM is mostly OK, but does slow down things when it starts getting spammy.

Join the Conversation

Return to Forum