Remote Guild Chat Feedback and Bugs

Mobile Bug Report
Prev 1 3 4 5 25 Next
This morning, I logged into guild chat through the Armory app then immediately after tried logging into the game (just to test things out). On doing so, my account was locked due to "suspicious activity" - is this just because of the login pattern being different from usual?

I do use an authenticator, so I was logged in on the same BNet (and same WoW acct.) account with and without an authenticator.

So, what's the verdict? Hyperactive security, iPhone haxx, or none of the above?
I purchased the paid app yesterday, and it has worked fine for me for auction house. However I have 3 (so far) character issues:

I have the paid version of WoW Remote on my iPhone. I am having two problems:

Server: The Scryers
Realm: Alliance, Guild: Gray Wolves
Realm: Horde, Guild Gray Wolf Consortium

1. Alliance character Dazzi (who is an officer in Gray Wolves) gets a message "Chat Connection Error This character is not a member of a guild" when trying to log in to guild chat. On the home page, the guild button and the guild chat button show her as a member.

All other Alliance characters are able to log in

2. Horde character Sathura: On the home page, the guild button shows the "stop" (circle with diagonal line) and the message "No Guild" under it. The guild chat button is also shown as the "stop". When accessing her profile from the "show all characters page", I get a message "Armory Error Character not found", and all the equipment boxes are blanked out. She is an officer in The Gray Wolf Consortium and very much exists.

3. Character Raven is displayed twice on the "show all characters" page
Yea I've been using this app like crazy since yesterday, however now I'm getting the Your character is not in a guild error with two characters of the same guild.

Asiq on Argent Dawn in the guild Not Dead Yet

Ticketick on Argent Dawn in the guild Not Dead Yet

However this character Regilhed works fine however he's in a separate guild


Since two other characters seem to be having this issue as well stating they're currently not in a guild.

Regilhed on Argent Dawn in the guild House Stalwart

Duah on Argent Dawn in the guild The Honorable Few

Now the only one that works is my druid.

Is your realm under the list of available realms?

Yes. Three people have logged onto Remote Chat so far, other guildies are able to see them type, but I am not. I'm going to feel incredibly stupid if it's something I'm doing wrong :)
I have noticed one App breaking bug.

Its not available for Android yet. I think before adding new features to apple throw a bone to the now biggest moble OS please.
I'm having a bug issue and I'll try to be as thorough as possible.

First, I'm a guild leader on Frostwolf using an up-to-date Armory app on an iPhone 3GS.

Even though the service was announced as a free trial on 2 realms, I thought that (because of the wording) it was available as a paid service for everyone else. Long story short, I couldn't log on first day for the obvious reason.

Now that frostwolf is available, I'm getting a message that my character Darkorb is not a part of a guild, despite the armory displaying the right info as well as my app. I think it's important to note that I use an authenticator--also, others in guild have been able to use mobile chat.

I've tried logging out; reinstalling the app and of course, restarting the phone. I should also note I'm on the most uptodate iOS version.

Thanks for the assistance!

Edit: I just wanted to add that this is my first forum post since I started the account on launch day. Woot! Finally posting on the forums.
Will the Guild Chat Feature be included in the web browser too?

as at work i only have access to internet on the computer they give us. i can't play games but i can go on this site and talk and forums and waht would be awesome if i could talk to my guild all night long.
Question: Are there any plans in the future to have the choice to allow the chat feature to stay logged in even when the armory app is closed. Basically able to receive a push notification when a whisper is received. This would be something I would like to have the choice to turn on or off of course. This is also something that as a GM of a guild I would find very useful especially if there is something that needs brought to my attention right away, and I only give my cell number to my officers for emergencies.

Comment: Oh man, can't wait for the pictures on damnyouauttocorrect to start showing up from this....could be epic. Also now I don't only have to worry drunk texting....but drunk mobile guild chat :-P
Love it, just add a landscape mode so it's easier to type then it will be perfect!
[BUG] I'm currently trying to get more details on this one, but a guildy (Lightbringer) says they're lagging whenever they try and send me a /whisper, and that it's never reaching me with an error saying that I could not be found. They could communicate with me through /g just fine however.

Upon sending them a /whisper, they appear to not be receiving it. Although the client on my phone says otherwise. This all comes after letting my phone idle for awhile, and the client set me as /afk.


I have yet to encounter the "not a member of a guild" bug again. My hunch says that it's server side though.
"this character is not a member of a guild"

Had this happen with my shaman when I stayed logged in on my phone. I logged on my other character Katilot later that day with no issues, then about 8 hours later it too now has the same error message.
Still waiting on Garrosh to be added so I can try it out.

I went out and made a toon on one of the servers that have been enabled, joined a random guild, then then got the "Not Guilded" error that some posts above are talking about, so I can't even try it on there.

Should be cool when all the bugs get ironed out though, whoever is on the Mobile Guild chat team over Blizzard probably has their heads exploding this week trying to simultaneously launch this thing and then deal with the bugs as they come up, props to you.
[Bug] I've been trying to log in with three of my characters on the Stormrage server and always get a chat connection error: disconnected from chat followed by a second chat connection error: connection timed out
Make it so you can talk to your friends on your friends list and I will purchase it
Just got the paid - app this morning, and everything was working fine. However, now I am unable to connect to chat.

Realm - Shattered Halls
Guild - pain makers

Basically, it says unable to connect, followed by a dozen You have been Disconnected messages.

Join the Conversation

Return to Forum