Razer Naga mouse not registering key modifier

Technical Support
I've got the Wow keyboard fix program running alongside wow, which seems to fix the single modifiers. I'm trying to use double modifiers, as seen in this macro:

#Showtooltip blind
/cast [@mouseover, mod:shift,mod:alt][@focus, mod:alt,mod:ctrl][@arena1, mod:shift][@arena2, mod:alt][@arena3, mod:ctrl][nomod] Blind

and the double modifiers are not registering on the mouse (they work fine on my keyboard).

anyone have any ideas or fixes?
Same issue, I no how to make the macro's the blue post suggested, just a lot of work to do for every ability I want to key bind to 12 buttons, If i wanted to use Alt and shift...that is a lot of text to type into 12 different macro's. Example being ;

/cast [mod:alt] Spirit Link Totem; [mod:shift] Flame Shock; [nomod] Healing Surge

While it wouldn't seem all that time consuming to do just these 12 macro's, its when you have to do it for each toon you play that it'll become boring, fast.

To save time I didn't add #showtooltip text to any of the macro's I made because I didn't name the macro or choose a icon for it, just leave it as the "?" and it will show the correct spell icon as you use shift, alt and/or ctrl. This provide's 3 ability's for one action bar button.

Edit- I ran into a issue where it would just show the "?" icon and cast no spell if I was talking on vent as I use the ctrl key to talk. Quick fix was just to add this to the end ;

/cast [mod:alt] Spirit Link Totem; [mod:shift] Flame Shock; [nomod] Healing Surge; [mod:ctrl] Healing Surge

And of course this is from my Resto Shammy were pressing nothing is my heal spells, shift dps and alt cool down abilitys
My girlfriend had a similar issue this week, the alt key modifier stopped working with anything except the 1 and 2 keys.
OK after writing that whole wall of text last night I went to bed.

I finally get around to screwing around with the shammy and doing a little pvp, annnnnnnd...

the macro system wont fix the issue with the [mod:shift] anyhow. Pretty frustrated. Only one working now is Shift 11, and shift 9 scrolls threw my chat log. ive deleted all shift keybindings in the blizzard ui...not sure what to do at this point
the reason for this mod error is due to the nature of the numpad.
The naga uses these exact keys when u hit these buttons.
but the numpad isn't just numbers....
the shift modifier actually acts like 'num lock' and turns it off whilst ur holding shift down...

the reason this is important to note is now with numlock off 1 2 3 4 6 7 8 9 are not those numbers anymore that are instead things like "Home, down arrow, page down" etc etc... these are NOT shift modifiers of the numpad but actually different keys.
1 VERY MESSY solution is to have ur shift modifier page scroll for you into 12 new buttons with spell macros for ur shift modifier...
this means u will have to have a macro for ur ctrl, alt and normal mod. and a seperate mod for shift and any shift ctrl alt combinations together on the seperatepage..
there is however, a problem with this also i've found... "5 + -" dont have functions when numlock isn't on so they are unusable with a shift modifier...

The solution many have found above is simply to ignore the layout of ur ordinary keyboard and just bind ur naga to keys that all work with shift.
off the top of my head keys that are kinda useless and work with ALL modifiers are things like:
, . / ; ' [ ] \ / *
and a FEW of the numpad keys.
if u bind ur naga to these keys u will have no problem using modifiers.
I am a bit annoyed that razer didn't just set 12 'new' buttons into the system and give u an installable to make them work. already on windows there are 6 usable "mouse buttons" and with the mac's they have there own mouse commands with their new mouse... these are added "buttons" mac has added.... no idea why razer skipped a corner
i am having exactly the same problem as u you guys, alt + num key works and so does ctrl with all other mouse keys, just not shift.. i downloaded the latest driver from razer jsut a few hours ago. would like a link for win 7 2 thx xD
Shift+Numpad1 is End. Shift+Numpad2 is down arrow. Shift+Numpad3 is page down.

I think you can see where I am going with this. Shift Numpad1 doesnt exist. It MAY work as Shift+End but seeing as Shift is the modifier to get End on the numpad I don't think it will. Now if you bind the naga buttons to the Function keys (except F4 for obvious reasons) you will have no modifier limitations.

Only numpad 5 will work with shift
I tried something that might work for some of the PC users. I use bartender so I'm not sure if it will work for any other action bar add ons.I'm not sure if it will work with double modifiers like Shift+alt+number but feel free to give it a shot.

1. Go to the key binding option in the Game Menu.

2. Scroll down to "Bartender4".

3. Set all the key bindings to modifier+number (key1 ="shift+1" so on and so forth until 10, 11 and 12 are 0,-, and =)

4. Open bartender, Select bar 1, and in the State configuration tab click "Enable".

5. Set the modifier key to the number of the bar that has the macros on it. (all of the macros I wanted were on bar 2, and I wanted to use the shift key. So under the tab for the shift key i selected page 2)

6. Send me lots on in game gold (just kidding ^.^)


Join the Conversation

Return to Forum