Naga buttons work, but wont move cursor

Technical Support
Earlier today, my Naga was working fine, then windows pushed some updates for my system, upon reboot, the mouse cursor no longer moves... ive updated the driver software, and of course customer support line closed only but an hour ago...

any ideas?
Don't allow windows to automatically update your system?

I suggest you uninstall and reinstall your device drivers, if that doesn't work you need to kill your USB drivers and let windows reinstall it.
Um, you have a naga?
04/26/2011 06:49 PMPosted by Finité
Um, you have a naga?


I believe it is a type of Razr Mouse.
Well the usb ports seem to be fine, my other periphials work. Also I didnt install them automatically, I read that new Windows 7 updates were available and I installed them, rebooted.

The mouse can click, use the mouse wheel, and use the side buttons. Just the mouse doesnt want to move the cursor. I plugged in my old razer mouse and it moved the cursor just fine, and my trackpad moves the mouse fine (I use a laptop, the mousy thing in the middle for non mouse users). Just my naga doesnt move the cursor
Uninstall the Razr software. Reinstall.
04/26/2011 06:53 PMPosted by Obdigore
Uninstall the Razr software. Reinstall.


that and rebooted
04/26/2011 06:54 PMPosted by Xubera
Uninstall the Razr software. Reinstall.


that and rebooted


Guess you need to wait for Razr support then. I assume you tried a different port?
i got 4 usb ports on my laptop, all 4 work for the other mouse, just not my naga
im going to just go back through and uninstall the updates and then update it later...
Hey man i am having the exact same issue now, did you ever figure out what the issue was?
I am having this issue now. Seems to be a flaw in the Nagas.
Aye, same thing happened to me, was working fine, I plug my headphones in, BAM, naga cursor stops responding.
dude, i had the EXACTLY same problem! my Naga 2012 was working fine until i install the Windows updates and BAM, mouse has stoped work in all computers, I dont know,aparently the internal firmware was corrupted! When i tried to update the firmware via Razer updater, no Razer mice was detected! I send it Back to Razer and got a New one. Now I'm affraid of Razer and affraid od updates! lol

Join the Conversation

Return to Forum