Please revert Horse Mount animation changes

General Discussion
Prev 1 3 4 5 6 Next
The change in movement of the rider on some mounts is the result of a bug introduced with 4.1.

It will be fixed in a future patch.


Oh, no. So we're stuck with this for... what weeks? Months?

Do we know which mounts are affected? I know the horses of all types are. What about the cats? Gods, now I'm going to grinding rep on toons that I never planned on just to get rid of the broken animations.

And yes, I'm going to be snarky and say a very sarcastic "thanks" to the person who was supposed to QA that section of the patch code, and clearly failed to do his job. Bravo, whoever you are.


Months.

Start enjoying your other mounts I guess.

/sigh
Yeah, it does look odd, doesnt it?

:\
I'm just not seeing it. (But then, I love Talbuks...)

Glad it will be fixed, I guess?
I log in today and notice that some of my favorite mounts (Forsaken Warhorses, Argent Warhorse, etc) now run identical to the way Talbuk's run. This running animation isn't natural and is the sole reason I never ride the Talbuk mounts.


The change in movement of the rider on some mounts is the result of a bug introduced with 4.1.

It will be fixed in a future patch.


Will this also address the animations that were broken way back in 3.0? For a more elaborate post on what was broken...
http://us.battle.net/wow/en/forum/topic/2325034399?page=1

Edit: Also, will the issues to Invincible be fixed? And fixed without causing more?
OMG MY HORSE RUNS FUNNY.

END OF THE WORLD.

Even though I can fly over 95% of everything.
OMG MY HORSE RUNS FUNNY.

END OF THE WORLD.

Even though I can fly over 95% of everything.


An issue is an issue. They all need fixed.
I'm always amazed at bugs that affect objects or actions that, at least on the surface, have nothing to do with implemented changes. Do you know what I mean? What did the patch change that resulted in bugged mount animation?
i like how the video you're showing for this, shows off how CTA has made que times so short, you can't even finish your video in time.

Even though I can fly over 95% of everything.


You can't fly in any PVP area. (Tol Barad, BG's, Arenas). For some of us that mainly PVP this is ugly as crap to stare at.
OMG MY HORSE RUNS FUNNY.

END OF THE WORLD.

Even though I can fly over 95% of everything.

Boy, I sure am glad all of my alts start at level 60 now. I'd hate to have to level them for forty levels with this stupid animation while riding.
Can you fix the talbuks while you're at it? I miss my armored talbuks. :(
I miss noises that horses and undead mounts made specially when harrashing other places if you did it right it goes over over. :)
Aww, I like the new animation better. It's much more realistic than the totally smooth unnatural ride of before.

I also like the Talbuks but only the ones without armor. Head armor on Talbuks, Cats, Elekks, and especially the perforated wok on the Amani bear, all look ridiculous.
Can you fix the talbuks while you're at it? I miss my armored talbuks. :(


This!
While you're at it, give all the horses the old Deathcharger animations. Those were seriously the best horse animations in the game - the ridiculous floppy-assed ones we have now just aren't cutting it.

At least give the Deathchargers their animations back. :( My Crimson Deathcharger hasn't been the same since 4.0.
<3 Swift Olive Raptor and thank you Darkspear trolls!
The change in movement of the rider on some mounts is the result of a bug introduced with 4.1.

It will be fixed in a future patch.


Thanks for letting us know.

Don't shoot the messenger, guys. It's not like he can control when it's fixed.
04/27/2011 12:05 PMPosted by Kaivax
I log in today and notice that some of my favorite mounts (Forsaken Warhorses, Argent Warhorse, etc) now run identical to the way Talbuk's run. This running animation isn't natural and is the sole reason I never ride the Talbuk mounts.


The change in movement of the rider on some mounts is the result of a bug introduced with 4.1.

It will be fixed in a future patch.


On a similar matter, I got my hands on a Swift Spectral Tiger a few weeks back and was highly disappointed when I mounted up on my kilt wearing Shaman. The kilt basically goes right through the mount rather than sit on top of it. This obviously wouldnt be noticable on normal "solid" mounts, however it is clearly visible since this mount is translucent. I really hope this is a bug and not intended design for one of the rarest mounts in game.
04/27/2011 12:13 PMPosted by Aedeus


The change in movement of the rider on some mounts is the result of a bug introduced with 4.1.

It will be fixed in a future patch.


... Why not a hotfix?


This, and with a new patch means even MORE bugs... I'm aware that bugs can and DO happen with anything, technology-wise, but I do think you should at least take a lot more time testing a patch before it's released. Everything just seems so rushed together, and on my server's trade chat, there's a lot more people complaining about this new patch than there are people that actually sell stuff there.

Join the Conversation

Return to Forum