Please revert Horse Mount animation changes

General Discussion
Prev 1 4 5 6
05/22/2011 10:05 PMPosted by Mellvyn
Thank you. Guess I'll just put this guy away for a while. Again...


Or make a thread on the Bug Reports forum, nag until they fix it. ;)
i smell a necro somewhere
NECRO!
Hate to necro, but it doesnt appear they fixed this in the patch notes for 4.2. I dont see it listed under know issues so far, and i swear they still run weird so am i blind or have my eyes just become that damaged?
07/06/2011 03:53 PMPosted by Schneizel
Hate to necro, but it doesnt appear they fixed this in the patch notes for 4.2. I dont see it listed under know issues so far, and i swear they still run weird so am i blind or have my eyes just become that damaged?
NECRO
07/06/2011 03:55 PMPosted by Antipath
The Archerus Deathcharger and Crimson Deathcharger are indeed still bugged.


Indeed. So this is quite the appropriate necro, as it deals directly with dead horses!
I honestly don't notice a difference. Maybe it's because I always ride a talbuk and not a horse. /shrug

Also, what's a necro? >.>
When people post in topics a week-2weeks or more old. Esp bad when the topics last post was 3+ months ago.

Why people can't notice the dates of the posts (esp the last post), who knows? All of them are trolling?
This issue is still occurring on my Crusader's White Warhorse. I get the feeling we're getting the cold (orc) shoulder here.

(Anyone who has been playing awhile will know what this is a reference to.)
Hey guys, this bug still exists. Been reporting it for over a year now... and it's still broken in beta!

I would like to actually ride my favorite mount without looking ridiculous.

Join the Conversation

Return to Forum