The WoW Movie Recording Guide For Macs

Mac Technical Support
03/19/2012 01:54 AMPosted by Lesty
Can you suggest a few good external hard drives for recording on a Macbook pro? I'm having trouble finding a 10,000 rpm Firewire 800 hard drive online.

You likely won't find one that's affordable. One of the reasons being that most external drives are used for backup purposes rather than performance.

What I'd suggest is to just get a standard desktop hard drive from a site like Newegg, and buy a drive enclosure with the appropriate interface (Firewire, ESATA, USB) separately.
So something like this

and this

would that work?
bump for my last question
Except for the fact that recording would eat up that 74GB in about 30 mins before you stopped it, yeah. That drive also has a slow SATA interface.

As stated in the OP, the file being recorded is massive until recording has been stopped and compression ends.
Hi Awesome Guide Really helped me out. I just have one question. I have a macbook pro(core i5 2.3 GHz and 4 gigs of ddr3 ram) and every time I try to record my PvP matches and at some points in the videos it starts hopping around. Please give me your email and I can send you a piece of the clip that is messed up. please help me out.
hey i have a question. i just recorded a fall of deathwing run that was awful, but awesome to watch. My Settings are:

1920x1080 (full monitor size)
Framerate 29.97
Compression H.264
Available recording time: 0:51:46
Recording Data Rate: 89.237 MB/s

Question is the video is currently compressing, but its taking 3-5 minutes to go up 1%. Is this normal? Is there a way to record without using compression, cause right now ic an't do anything else in game i wanna record. And should i expect for this to be done by tomorrow, lol.

I know this is an old thread, but it is very good on this topic.

Does anyone know what happened to the Mac recording options with 5.0? Mine are all grayed out and I do not remember reading any changes on this feature for 5.0.
This is on Bug list, here on official Mac Fórum...

[64-bit] Movie recording is currently unavailable.
Hi, I am somehow unable to change the recording path, I've did the way you said it
but the recording still goes under World of Warcraft/Movies

any solution to this?
Hi, I am somehow unable to change the recording path, I've did the way you said it
but the recording still goes under World of Warcraft/Movies

any solution to this?

Came here to ask this exact question.

Bumpity time.
why does it say ''There is no application to set this document'' when I try and watch some of the videos. And sometimes it only records sound with the little music note for the icon. Does allow me to watch the videos. I have recorded videos in the past and still have a lot of them. Just cant seem to get it right atm. Is there anything im doing wrong?
thank you. you really helped me a lot.
I copy pasted the string to modify video recording location and changed it to suit the proper folder on my external.

The game keeps removing it at start up though.

What about Flash Drive??? I currently own a iMac (27''' ,3.4 GHz Intel Core i5, with 16 GB 1600 MHz DDR3 Ram, Nvidia GeForce GTX 780M 4096 MB).

I don't have issue recording, but all I record is a big green screen and the actual game sound....Im using H.264 Compression and for now resolution of 1280 X 760.

If I can't record correctly because of the Flash Drives I got inside my iMac, is there any other program that Mac user can use to make video out of WoW without buying a new External Disk Drive?
Hey guys, original author of the thread here:

As has been said many times in other threads, if you're getting corrupted video/audio on the final video file while using the 64-bit WoW client, you need to set your graphics settings, especially the Shadows, to Low. Then exit the game fully and relog.
Any updates on this? In particular, the partial WVD files.

I was bad and recorded to SSD since it's the only HD on my iMac.

I ended up with 1 WAV, 1 WVD and numerous WVD+#.

When I stopped recording, compression began according to the chat log, but at no time did I ever see any status or progress bar. I let the game run for a few minutes anyways. Still nothing.

iMac never crashed, game never crashed, nothing froze. I looked into the folder and saw no MOV file. I've since logged on/off and exited multiple times. But it seems to me the files aren't corrupted since I saw no indication of any compression occurring other than the chat log saying it started. I'm unable to resume compression, as the game alerts me that "there is no movie to compress".

My permissions are fine so that's not anything. I would love to know if there is any particular third party software that can merge/compile/compress/convert these files since I don't think I'm going to have any luck with the WoW client.

This is my first attempt to record anything in-game. Would love to figure this out because I finally just completed my Green Fire Quest and badly need a record of this achievement.

I'm in the same situation as Butts. I want to view my Green fire quests. Even an 3rd party program would be appreciated.

edit : I can make new vids but they are scrambled like colored static
07/31/2014 08:31 PMPosted by Mercadez
I'm in the same situation as Butts. I want to view my Green fire quests. Even an 3rd party program would be appreciated.

edit : I can make new vids but they are scrambled like colored static

Same situation, something is broken in the Mac movie recordings. i get a ton of broken files, it never compresses, when i try to manually compress it says "no movies to compress found" the one that did try to compress (out of 6 i tried to make) came out in a multi-color static like above poster described.

system info just in case it's needed.

Model Name: Mac Pro
Model Identifier: MacPro5,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.4 GHz
Number of Processors: 2
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache (per Processor): 12 MB
Memory: 6 GB
Processor Interconnect Speed: 5.86 GT/s
Boot ROM Version: MP51.007F.B03
SMC Version (system): 1.39f11
SMC Version (processor tray): 1.39f11

Hardware UUID: 78CC2B50-CE09-5A9D-911F-0F6BC9F171CD
ATI Radeon HD 5770:

Chipset Model: ATI Radeon HD 5770
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68b8
Revision ID: 0x0000
ROM Revision: 113-C0160C-155
EFI Driver Version: 01.00.436
Resolution: 1680 x 1050 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: H9FPA44105
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported

Imovie version 8.0.6 (821) or imovie 09'

[Edit]: i set everything on my graphics to lowest setting. the video properly compressed finally, but the entire video was multi textured green background static. so, obviously graphics settings are some of the issue as now compression seems to work, but not a fix as it's still not recording a movie file that's worth having. not to mention with graphics at the minimum settings nothing looks good at all.

any update on this would be appreciated. Possible Blue post?

Join the Conversation

Return to Forum