Quest - Prisoners of War

Bug Report
Having the same issue... I decided to skip it though but I can't seem to shake Jorgensen, any tips?

I hearthed and he's gone.
This quest is still effectively unplayable, Jorgensen is useless (though he does now camo correctly) he still agros any ork he gets within spitting distance of ... quite useless indeed
Jorgensen has been fixed with the camo but now the problem is that 99% of the time when your try to use the distraction it says "No Path Available". Unable to get in the cave because of this.
I just went through this and got the Key and freed the prisoners of war.

Confirmed on the "No Path Available" for trying to distract. -_-

What I did, after dying a few times at the cave mouth where the
guard was inside who had the key.

I simply rezzed INSIDE the cave BEHIND the two guards at the entrance,
BUT waited until the Guard at the back of the cave who had the key had his back to us.
Used Chloroform, but he still attacked us. Managed to kill him
without the other two guards coming in.

Then, Chloroformed both of them from behind, and made our way to the
prisoner of war cages.

The two guards at the cave entrance attacked us shortly after we were
(what I thought was) a safe distance from aggroing anything.

I just ran like the and eventually Jourgeson caught up and the
guards were left in the dust.

Then, using the newly aquired key, released the prisoners.

Then the servers shut down for maintenance just as we were about to
reach the

This is SOOOOO painful to have such an incredibly structured and fun Quest
crap out like this at it's conclusion.

Please blizzard...fix this.

So, then I tried setting the charges in the Tower.

The guard at the bottom of the tower with his back to the entry,
after you chloroform him and run to the top of the tower
wakes up and runs up to attack, then the rest of the mob aggroes...
And you can't use Distraction. It says "No Path".

Oh the pain...ohhhhthe pain...

I would rather have a less epic Quest which is solid without glitches
than a more epic one with glitches...ANY DAY OF THE WEEK.

Blizzard, just get them solid or don't make them so sophisticated.
This really is not an acceptable loss.

This really makes me loose a lot of the enthusiasm to continue gaming.
Where is the cave located? I've been running around in circles.......... :-)
On another char i was having the same problem, Decided i will come back later. Abandoned the quest but my camo kit is still on !

I restarted the game, quest is gone but still only have the camo kit as a hotkey.

Warped to Stormwind , Still no spells just a Camo kit for spells.. How do i get rid of this ?
FIGURED IT OUTTTTT!!!!! WOOOOHOOOO!!! So, while your dead, go ontop of the cave, away from the drake perched above. Resurrect there, and quickly camouflage. Then quietly sneak to the back of the cave, behind the two gards in the front. chloroform the one in the back. Get the key. and run for you life. Then ressurect wherever they killed you. (but you have the key) and release the prisoners. (: Hope it helped ! So happy. c:
I did this quest earlier today and encountered problems similar to what has been described. Distraction doesn't work beyond the first couple of Orcs on the trail. Chloroform fades quickly and the Orc would aggro immediately, but would usually go after my "helper" first. With that in mind, this is how I finished it relatively quickly.

I basically decided not to try to be fancy and make any attempts not to die. I hugged the incline on the right of the path, successfully avoiding all the Orcs up to the cave. Once at the cave I stayed against the base of the mountain and hugged the outer wall of the cave. Once the Orc on the Black Dragon was as far from me as possible, I darted around the entrance between the two guards to the back. The two orcs immediately aggroed to my helper, and while they were busy with him I chloroformed the guard inside and got the key. Then I let them kill me.

Once I released I ran back along the path at the base of the mountain and rezzed as far back from the mouth of the cave as possible. There aren't any Orcs in this area to see behind the tree, so I rezzed there and re-camouflaged. Crept back to turn in the quest.

For the two buildings (tower and hut) I stealthed around to the back of the hut first and hugged the outer wall until I was able to slide into the entrance behind the orc guards. Got to the back of the hut and set the charge, then retraced my steps out and over to the tower. At the tower I hugged the outer wall again and crept behind the guards and inside. Chloroformed the guard inside and got up top as fast as possible. Instead of going inside the upper room on the tower, I went away from the guards along the ledge behind it and set the charge. By the time I did that, the guard below woke up and came charging up to me, aggroing the two guards at the opening of the room. I just let them kill me instead of trying to escape.

Once I released I ran back to the backside of the tower and was able to rez on the ground unseen. Re-stealth, and go turn in.

Once I decided not to let it get to me, I found this was a pretty fast way to get it done and out of the way.

I did find that once the guards aggroed to me I could not toggle off the pack. I got the message "You can't do that because you are in combat", Making fighting back impossible anyhow.

Join the Conversation

Return to Forum