Login issue (Stuck after authenticator code)

Customer Support
Greetings,

After entering my authenticator code, this wordless dialogue box appears with a single button [Cancel] and refuses to proceed.

The problem lies with my account and not with the computer / network because attempts at logging into other accounts work as normal.

I would greatly appreciate it if you could look into this matter asap.

Thank you.

Edit : I did receive an email from Blizzard regarding suspicious activities from my account, and was directed to the password reset page. Upon entering my details, I was sent an email to the actual password change page where I could enter my new password. However, it seems that performing these actions as requested did not help resolve my problem.
This Battle.net account is unlocked at the moment, Zar - but it looks like you've tripped this multiple times. You do need to make certain you are using the very latest password that was sent. Since the account is not currently locked, I suspect that's what is going on here.
Thank you very much for your prompt response.

I am able to log into my Battle.net account through the WoW website and this forums, but I am unable to do the same through the game client.

As of the moment of this post, I am still experiencing the exact same problem while trying to login into the game.

As for the password used, I am using the same password as the one that allowed me successful logins into these forums. I've also tried several combinations of password / authenticator codes to login to my account through the game client, with examples as follows :

Correct password / Correct authenticator code
Correct password / Incorrect authenticator code
Correct password / Blank authenticator code (just pressed enter)

Incorrect password / (Correct/Incorrect/Blank) authenticator codes

All of which causes the client to not proceed forward past the dialogue box.
This does not appear to be isolated to one account, I am experiencing exactly the same issue. I can log in here but not to play the game, after entering my login info I only get the option to Cancel.
Try again now, I shut down and restarted the launcher and I was able to get in now. Probably a temporary issue :)
I'm still having the same issue :(

Edit: Tried more reboots, modem/router reboots, trying to log into the game while being logged into the forums and not logged into the forums, deleting the cache and WTF folders (made backups) and still the same issue.
Eyr, if you're still reading this, do you mean that you just restarted the WoW client?
I'm having the same issue, however I can add that when I try and resync my authenticator it reads "unsuccessful" thats never happened before. I checked my email for anything going on with my account but nothing is there. So whatever is happening with the client is also affecting the authenticator? What could do that?
Okay latest update:

Removed authenticator from my account : Able to login.
Re-attached authenticator : Unable to login again.
Removed authenticator, obtain new serial number for authenticator, attach the new authenticator to account : Unable to login again.

So it appears that as long as there's an authenticator attached to my account, I will not be able to login.

Edit : Deleted my previous 2 posts and condensed them into this post.
Your best bet at this point, Zaraax, is to call Billing when their open (about 30 more minutes, to be precise). In the meantime though, since I think you're using the mobile app - have you tried re-synching the authenticator at all?

Billing, Account Services & Technical Support
Hours: 7 AM to 8 PM Pacific Time


Phone: 1-800-592-5499
Australia: 1-800-041-378
New Zealand: 0-800-452-520
Chile: 1230-020-5554
Mexico: 001-888-578-762
Argentina: 0800-333-0778
Brazil: 0-800-892-1630
Thank you Taamane for the information!

I am indeed using the mobile authenticator on my iPhone and attempts at syncing have been successful, but have no effect on my inability to login.

The strange thing is the fact that I am able to login if I remove the authenticator from my account, but I am not willing to take that kind of risk just to be able to play.

Besides posting about this here, I have also sent an email to customer support, so hopefully they'll get back to me soon.
I don't blame you for not wanting to play without the authenticator. Good luck, mate!
Be aware that this behavior (blank box with cancel button that does not go away) is symptomatic (but not a guarantee of) the MITM emcor.dll (and variant) Authenticator-bypassing trojan.

A full scan with Malwarebytes (with dummy information at the login prompt) is strongly advised.
________________________________________________
Customer Support Forum MVP
HDL - http://hdl-the-guild.com/~nodrama/
E-mail - neppyman.no@spam.gmail.com
Cheers Pahanda, you're right indeed.

Malwarebytes detected this Trojan.GamesThief in a temp folder.

Now that it's gone, all's back to normal.

Thank you so much mate.
05/09/2011 08:22 AMPosted by Zaraax
Malwarebytes detected this Trojan.GamesThief in a temp folder.


Be aware that this may simply be part of the infection, and not the entire thing - check to see if the problem has gone away, before cheering too much.

If you can log in without freezing now, assume that all of your passwords - Battle.net account and e-mail account, among others - have been keylogged, and change them all.
________________________________________________
Customer Support Forum MVP
HDL - http://hdl-the-guild.com/~nodrama/
E-mail - neppyman.no@spam.gmail.com
I have been having this same issue. I've restarted my computer, the launcher, and run multiple full scans with MalwareBytes, AVG Free, and Spybot - Search and Destroy, and while they did find some problems, removing them hasn't fixed this.

The same issue is not happening on my laptop, so I'm playing on it for now, but this is really frustrating! Any other possibilities?
sorry to bump but this is happening to me currently. i would not be worried because servers were down for a restart and i know the login servers can get bogged down... but since im sitting with a blank box and not the connecting box... im concerned.

Join the Conversation

Return to Forum