Getting disconnected on pride of kezan quest

Bug Report
I have been having a problem where every time that i try and do the pride of kezan quest i will get disconnected from the server. I can get into the airplane and even fly around.. When i try and shoot the machine gun it will disconnect me from the server, when i try to use the rocket it will say something about my pet on the screen. Somebody please help me!!! Im almost positive i need this quest to move on.
Ive been having the same problem now for a couple days .
ive checked out the rest of the island and theres nothing i can do to advance im getting iritated big time
There seems to be a problem with all vehicles in the game making it extremely difficult to level in the game because of the new quests cataclysm brought us. Luckily Blizz made a post about this on a past post and said they were working on it. Were your Goblin Hot rods working? I
Ignore the I ^....and the fact i said game twice...:P
I'm having the same problem, I'm about to scream! It started with Rolling with my Homies back on Kezan, I had to do that and all other quests without my hot rod. I was hoping it was just that that was bugged, but now its EVERY vehicle quest I've tried so far. And now I can't advance because Pride of the Kezan is undoable... siggghhh.
i just dealt with this issue with a ingame gm myself, all you have to do is set your graphics lower, do the mission then set them back if you wish. they are aware of the issue (according to the gm i talked with) and are working to fix it
Please post here, and the setting graphics to low does NOT work for everyone, it didnt even work for you, it was relogging that did it.

http://us.battle.net/wow/en/forum/topic/2548997532
i never said it would work for everyone, i just posted what worked for me. i did not relog, i was logged in the entire time when i was talking to the gm.
rolling with my homies not working locking up staory line and can not get other quests becouse of quest line lock . what is going on it is a bug ot a lockout ?

Join the Conversation

Return to Forum