Modifiers and Macros

New Player Help and Guides
Hi, I am trying to get some macros set up. With some of them that require a "modifier" like shift or alt, nothing seems to be happening. I am creating a macro button and putting it on my UI with an assigned keybind. I hold the mod key "shift" and press the keybound key from the UI, and nothing happens.
Am I doing something wrong?
Here is and example of a macro I am trying to use:

/cast [mod:shift,target=focus] Spell Lock; Spell Lock;
/cast [mod:shift,target=focus] Seduction; Seduction;
/cast [mod:shift,target=focus] Axe Toss; Axe Toss;
/cast Sacrifice

And to make it even more confusing, I'll remove an icon from the "7" slot on the UI, and press 7 on my keyboard and it will cast Soulburn with nothing there...

Am I not understanding how macros should be set up? If they exist in the Macro menu, do they even need to be on the UI?

Very confused. Please help.
Thanks.
Icedragon or someone else can probably help you more but I think you need to separate those

/cast [mod:shift] [target=focus] Spell Lock; Spell Lock;

They need to be keybound to something I believe.
Does the keybind need to be written in the code?
No, just drag the macro to the slot you want to use it in.
I highly recommend www.wowpedia.org/UI_Beginners_Guide#Macros

Lots of good information there. And when done, check out the UI and Macro's forum here at WoW.
There's also a new2macros sticky in this forum.
The macro looks fine. Have you tried pressing it without shift to see if that works? It is designed to cast each ability on your target with nothing pressed and on your focus target when shift is pressed. If you didn't have a focus target when you tried it with shift then that would explain why it didn't work.
Hi, I am trying to get some macros set up. With some of them that require a "modifier" like shift or alt, nothing seems to be happening. I am creating a macro button and putting it on my UI with an assigned keybind. I hold the mod key "shift" and press the keybound key from the UI, and nothing happens.
Am I doing something wrong?
Here is and example of a macro I am trying to use:

/cast [mod:shift,target=focus] Spell Lock; Spell Lock;
/cast [mod:shift,target=focus] Seduction; Seduction;
/cast [mod:shift,target=focus] Axe Toss; Axe Toss;
/cast Sacrifice

And to make it even more confusing, I'll remove an icon from the "7" slot on the UI, and press 7 on my keyboard and it will cast Soulburn with nothing there...

Am I not understanding how macros should be set up? If they exist in the Macro menu, do they even need to be on the UI?

Very confused. Please help.
Thanks.

Did you have
a) the appropriate Demon out, and
b) have a Focus target set?

Join the Conversation

Return to Forum