Bugs While In Vehicle/Using Vehicle Abilities

Bug Report
1 2 3 14 Next
This has just started heppening to me today.

First, when I was doing the quest in Venomspite to steal horses from the scarlet onslaught, when I got on the horse and rode back to Venomspite, there would be no npc's visible and I would be unable to turn in the quest. I had to log in and out multiple times per attempt before I was finally able to turn in the quests. What I would notice is when I would log back in, my character would be standing in the spot at which she mounted the horse.

Then, any time after that in which I have attempted to ride in a vehicle and use an ability, I am immediately disconnected. This occured with the blight spreaders in Venomspite, and then again in Grizzly Hills while attempting to do the Thane of Voldrune quest and riding the proto drake.

I have noticed other people seem to be having this issue or other strange 'out of range' errors when using vehicles. This occurs with all addons disabled, as well as with addons on. I propose we use tihis thread to create a list of vehicles which are behaving in this manner. I am pretty sure it is affecting ALL vehicles (which makes it very hard to level through vehicle-happy Northrend) but just to be sure...

So...

So far this has happened to me with:

Scarlet Onslaught Horses (Venomspite quest)
Forsaken Blightspreaders (Venomspite quest)
Flamebringer (proto drake for Thane of Voldrune quest)

I have seen reports of this also happening with:

Demolishers in Strand of the Ancients
Argent Crusade Warhorses (Argent Tournament Dailies)
Argent Skytalon
The Shredders in Aszhara

Anyone else, please post your vehicles here!
The catapult in the worgen starting zone causes disconnects as well. But thats all I know of atm so ill edit this if I find anymore
Happening with the Nazjar Battlemaiden quests in Vashj'ir as well. Mobs would disappear, I wouldn't be able to attack things cause it would say "Your pet is out of range" even when things were hitting me, was also unable to exit the vehicle in any way except logging out.
I had a vehicle bug out on me in Wintergrasp just today. Other players in the battle (3 of all 5 of us) were able to get vehicles but were unable to damage the towers with seige-tank rams, the demolishers would disconnect you if you fired the "gun" (the boulder would still damage the tower). If you were disconnected, you would be in a random position from where you had been, sometimes not in the vehicles, sometimes in the shop.
One of the other players was indicated as being in Borean Tundra when it was registering him on the map as in Wintergrasp (albeit not moving with wheels spinning).
Also having issues with using Argent Tournament mounts.
This started happening to me yesterday, as well. It makes starting a goblin nearly impossible. The quest Robbing Hoods has you running over thugs in a car, and every 1 or 2 thugs, my client would hang. This was solved with a few reconnects, but later on the Lost Isles I ran into the quest Zombies vs. Super Booster Rocket Boots, where you must run over 50 zombies. This is going to take a while.
I also experienced this in both the battlemaiden quests in Vash and in the Demolishers in Strand of the Ancients
Same issues with problems in Strand of the Ancients, Isle of Conquest and Tol Barad. I can drive the demos as far as I want, but obviously the opposing team doesn't see me, because they ignore me, and then the second I use an ability, I get d/c'd and the log-in returns me to the point I entered the vehicle. Noticed it for two days now.
This also happened to me in three lower-lvled quests in Ashenvale: using the ballista as a vehicle, using the whirlwind as a vehicle and using the spirit of Shudumbra (the panther) as a vehicle. I managed to finally finish the first two, but as of this time, I am unable to complete the third. What gives?
Same issues here, two days now. So far, Wintergrasp and SotA vehicles are causing me the problems. Haven't noticed the issue with the TB vehicles yet, but it may happen here in a few minutes in the next battle.
I've been experiencing the same problems.
It's really annoying.
I've so far had problems with the Cat Spirit in the "Defend the tree" (Alliance) quest, the horses in the "The Hungry Ettin" (Worgen) quest and ALL the horses in "Grand Theft Palimino" (Death Knight) quest....
T.T Please fix this Blizz.
"Be Raptor" quest in Northern Stranglethorn, where you control the raptor hatchling. I can't talk with the first Raptor NPC that shows up right where I start, and none of the others ever appear. The troll guards in the first room completely ignore me, and there aren't any in the rest of the zone. Deleting add-ons / WTF / Cache has helped some people finish this particular quest from what I've read, but has not worked for me.
The Shredders in Ashenvale for the Alliance quest in the logging camp.
The Hippogryph in Stonetalon.
The boat you use to get around in Thousand Needles.

Looks like it's pretty much vehicles across the board...which is something that needs to get fixed -now-, considering how much is done with them.
Does this problem not rate a blue post? It seems to be happening to alot of people across all realms in questing, starting zones and battlegrounds... Ignoring us isn't helping...
DC'd consistently today in SotA while in a vehicle. DC trigged by an ability.
I can tell now that all vehicles in Azeroth, outland, northrend and cata zones have given me problems. Why has there not been a reply yet? Dont bother with the interface, wtf, or cache deletions it is a waste of time. Talking to the npc's mounted or dismounted makes no difference so far. Blizzard i need a response, and i would like to have it now, even if its a familiar "we are aware of the problem and working hard to fix it".
Bumping this because I see a lot of other threads, lets try to keep it here so that we can have one really long thread about it, Blizz seems to notice those better.
Yep;; quest vehicles are BUGGED.
I have been dcing for 4 days now trying to complete the Argent Tournament ground quest. I want my toons to be able to move on to the next faction, but I can't until I complete "The Valiant's Challenge".

I also deleted my 3 folders and have no add-on's anymore. This did not help at all. I've talked to 2 GMs the 2nd one said, they knew this was a problem and asked me to use the forums, instead of submitting a ticket. Sigh.
I opened a ticket yesterday about this issue on Argent Tournament mounts.

Just got a generic response about abandoning quests and then reacquiring them.

I've already done that. I also cleared my cache, and deleted all external add-ons. None of that helped. I opened a follow up ticket but no response yet.

Join the Conversation

Return to Forum