NVIDIA Optimus fix

Technical Support
Hello everyone, I've got a fix for everyone with the NVIDIA Optimus problem when unable to use the dedicated card to play WoW.

1. Right click the WoW Launcher that you use.
2. Go down and select "Properties"
3. in the "Target" box, it 'should' say "D:\Stuff\World of Warcraft\Launcher.exe"
4. Add -d3d11 to the box (adding a space after the ...exe" part)
5. Should look like this... "D:\Stuff\World of Warcraft\Launcher.exe" -d3d11
6. Click apply.
7. Open your game as normal, and enjoy!

P.S. you may have to turn off your "Hardware Cursor" if your mouse does not show up after this, just log out, go back to Properties, and delete the -d3d11 part, re-open WoW, turn off the "Hardware Cursor" Log back out, and repeat steps 1-7.

P.S.S To find your "Hardware Cursor" while at the WoW login, or inside the game, go to your options menu, and select the "Advanced" tab, then Select the "Hardware Cursor" (3rd one down) and select to disable it. Click apply and your done.



EDIT: Personally I have the NVIDIA GeForce GT 425M w/ NVIDIA Optimus and I have found that this fix works.

Special Thanks to Nox from my guild who has helped me in countless hours with finding a fix! Thanks buddy.
I am glad nox got ya fixed sir!
Forcing DX11 bypasses the issue? Interesting. Thanks for the info, Nachten (And kudos to Nox), I'll pass this workaround along and have it thoroughly investigated.


____________________________________________________________________________
If you think I'm being a helpful tech then let us know at- https://www.surveymk.com/s/R6YGTBT

Is your issue urgent? Need direct assistance? Contact an Accounts and Technical Services Rep! http://us.blizzard.com/en-us/company/about/contact.html

Good luck with the issue, and good gaming! (Note: I'm off on Tues. and Wed.)
____________________________________________________________________________
Thank you. Now I know this isn't the sure fix for things, but to help ease the players until a fix for this comes out, this works! :)


P.S. This works for other games as well that has a directory IE; CA, Rift, Sims, ETC however as of now I do not have a fix for any game from steam, as no directory is able to be found, as well with any game it should have a Target Location, whereas Steam games only have a URL (unless you downloaded with a CD)
06/04/2011 09:56 AMPosted by Nachten
Thank you. Now I know this isn't the sure fix for things, but to help ease the players until a fix for this comes out, this works! :)


I'm a big fan of workarounds. After all, there's nothing else to do but to wait for Nvidia, AMD, Intel, and the laptop manufacturers to figure out why the Intel HD isn't handing off like it's suppose to. (Yeah, this happens on non-Optimus, AMD graphic setups as well. On those you can flick off the Intel HD in the BIOS as an alternative workaround.)


____________________________________________________________________________
If you think I'm being a helpful tech then let us know at- https://www.surveymk.com/s/R6YGTBT

Is your issue urgent? Need direct assistance? Contact an Accounts and Technical Services Rep! http://us.blizzard.com/en-us/company/about/contact.html

Good luck with the issue, and good gaming! (Note: I'm off on Tues. and Wed.)
____________________________________________________________________________
I was having the same problem and just used the DX11 option and it fixed the water and sunshafts issue.

I have a 555M chipset.
I can change options pertaining to the water and sunshafts now, but the nVidia tray icon still says that the dedicated card's gpu isn't in use after doing what the op said.

Any help?
Natchen

My immense thanks for this. Just replaced an old HP 17inch Pavillion with one of the new Asus ROG G73SW (not 3D). Just loaded WoW on to it and it was driving me nuts on the mouse disabling when I booted the game in full screen. Your little fix worked perfectly!!
Nachten,

You have my sincere thanks. Now, if only nvidia would get off their butts. This Optimus technology is a nightmare, and truthfully, I see either public relations or legal issues in their future.

Sincerely,

Me.
Thank you so much Nachten! I just bought this Samsung RC512-S02 laptop and was sad when I saw that WoW wasn't seeing the GeForce GT 525M card... you fixed my problem :-)

Beers for you for sure :-D
This didn't work for me...WoW immediately crashes after clicking PLAY on the launcher.
I have a GT 555M on an Alienware M14x.
Anyone have any tips?
is this only for laptops?
This didn't work for me...WoW immediately crashes after clicking PLAY on the launcher.
I have a GT 555M on an Alienware M14x.
Anyone have any tips?


Im thinking of maybe getting an m14x...did you find a fix or are you still having the problem?
I just bought this Samsung RC512-S02 laptop, and this didnt work for me, I saw that It did work for someone else with the same laptop. Any idea why this didn't work for me, I did exactly what the instructions said to do. I hope I can fix this.
Thank you so much. I spent so much money on my new laptop and i was really bummed when i couldnt get above 8fps and now with this bypass i am stable at the high 40's.

This fix still works, i have the new GTX 675MX card so a heads up for anyone with a new laptop this will work for you.... Hopefully

Thank you so much.

Btw, what does D3D11 mean?
I'm currently using an Nvidia Geforce GTX675M tried using this fix and nothing changed at all still running at 20-30 frames any more help on this?
Gaming on laptops is bad mkay.
Well I'd love to carry a desktop to school everyday but do I don't see that happening :P
Sorry for the necro, but I just discovered there was a thread where I got kudos from a blue and I missed it! I had to post. Glad I could be some small help to some people.

Join the Conversation

Return to Forum