Mobile armory won't connect

Mobile Bug Report
I also have had this issue all day, got no response from BlizzCS on twitter, it would be nice to know that the issue is being addressed and maybe an ETA ?

Cheers
Ditto, iPad & phone are showing no connection love today
Having the same issue on my iPhone 3Gs. Can connect to other locations just not Americas.
same....no connection for evo/android ap.
also when i check a realms status ap it shows my server as down (which it isnt) and it cannot find any other us servers???
Same with me. iPhone app. Only since today.
I can't connect either :\

Has blizzard said anything? Has an ETA been given for when this will be fixed?
Still no blue post? :l

I want the comfort of checking my 300 or so auctions from my bed.
It's just the US server I tried euro and it logged in. I'm sure they are working on it.
Mobile App's been off all day. I have been able to connect via the web version of the app on the Battle.net server. It's not as smooth for me as the mobile app, but you can watch your posts and manage your bids in a pinch.
Just tried and I could log in. Maybe they fixed it.

Problem solved for me.
Haven't been able to connect since about 5pm Central time 6/1/11.

iPhone4, all curent versions, 3G and WiFi

failed, unable to connect, blah blah blah

Love it when I pay for something that only works half the time or less.
Yep... same thing here... 3G, WiFi, webinterface... all offline. Android version(Xperia X10).
I got an error first time I tried to connect. Tried again and I was able to connect and use everything except the mobile AH. Any official word on this?
Having remote AH issues too. "The Remote Auction House is temporarily unavailable. Please try again later." :))))
I was able to log in about 4am Eastern, since then nada. that's with the iPad and Droid apps as well as online web browser.
am i getting a refund for my downtime for remote AH... they need to setup a service status page for wow remote and give extra days of service..
What's disconcerting is that in web based version of the armory, when you go to the Auction House, it shows your gold amount as the text 'In-game'. Nobody better be in game right now, because I'm not logged in.
Mine wont connect at all i have restarted the phone redownloaded the app still nothing
What kills me is they haven't posted a solution for this problem. I've been having it for 2 days now. I need my WoW!!!!

Join the Conversation

Return to Forum