Mobile armory won't connect

Mobile Bug Report
Blizzard people please fix mobile armory not working for 2 days now
At least give us when it will be fixed or some status what's going on. C'mon guys this is ridiculous if you want to make something for the users please make sure it works or dont make it all, constant login failures and chat problems. And dont you dare delete this post like you did with my other posts, I love when this company does not like to be criticized they deleting user posts so no one will see it. Very professional on your end, congrats !
I'm glad to see I'm not the only one having issues with the mobile app. Please fix this Blizzard!
Having the same issue. Will not connect. Uninstalled, reinstalled "unable to establish connection to server."
There is no point installing or reinstalling its not on the users end, its on the Blizzards servers end. You have to wait till they fix the issue hopefully in 1 year it will be resolved
There is no point installing or reinstalling its not on the users end, its on the Blizzards servers end. You have to wait till they fix the issue hopefully in 1 year it will be resolved


The issue began on the evening of Sunday 4/14 (PST) so it's just bad timing really.

Weekend server failures are the worst because most of us are not around. I didn't have time to come to the forum yesterday but I did manage to have our server engineers take a look and get everything rolling again. So, this should be good as of Monday morning (4/15).

Join the Conversation

Return to Forum