Keyboard stops working

Technical Support
I have been having this issue where every time I zone into an instance, die, or am online for about a half hour my keyboard stops responding to WoW. Even when I use my mouse to logout, I can't type in the password or email section on the loading screen, I have to back all the way out of the game, restart and then it works fine. The other strange thing is that it is only happening on one of my characters.

I am running minimal addons and those I have on are all updated. I found a fix in a forum somewhere that had me go and change the keyboard settings in my control panel, and I was hopeful that would help, but clearly it hasn't.

I just sat in a 30 min que for a troll random only to discover when it popped that my keyboard had failed, by the time I restarted wow and got back in I had been kicked, and rightfully so.

Are you using a special or smart keyboard? Do you have any keybinding or configuration programs for your keyboard that you are using? If so, try disabling those programs temporarily and try the game.

When this issue occurs, does it affect other programs? When you log out of WoW, are you able to type again?
Technical Support
Want to speak with someone directly?
How's my driving?

Check your G-diffuser system!
I have a Saitek Eclipse, it has no keybinding programs at all. The one thing I read is that if you press left alt + shift in windows, it changes the language settings/configuration of the keyboard and that is what might have been happening since in WoW I use a lot of bindings including the shift and alt keys. However in my windows control panel I disabled that function, settings all those settings to 'None' yet the problem persists.

All I have to do to get it working again is exit wow, while the problem is going on in wow (I run windowed with 2 monitors) I can type fine everywhere else, and as I said, I have to exit right out, since my keyboard won't respond even on the login screen in wow. When I start it back up it works fine.

I have recently made two macros and put them on my toolbar (since I can still use my mouse and everything) one that reloads my ui, and one that apologizes to my party saying that I just have to relog real quick. I haven't had a chance to try reloading the ui so I don't know if that works or not.

Was kind of hoping this issue had happened to others since it sounds like one of those Ghost in the Machine type things we may not get to solve, which just rights itself at some point just like it started.

If you have switched your keyboard language settings, then you should be able to switch it back with Alt + Shift.

You may also want to see which keyboard layouts your system is set for. It should be possible to delete extra layouts and only use the US standard.

    Click Start and then Control Panel
    Open Regional and Language Options.
    Click on the Languages tab.
    Under Text services and input languages, click on the Details button.
    Under Installed services you can add or remove different language layouts.

Technical Support
Want to speak with someone directly?
How's my driving?

Check your G-diffuser system!
I am also having this issue, I am using just a basic keyboard that came with my computer, minimal add-ons and no keybinding programs. I've already uninstalled all the un-needed language options as well.
Hi guys, Have just brought a new acer and Im having the same problem. As soon as it comes up to accept terms and conditons, mouse and keyboard stop working, however the escape key works, this is how I'm getting back into windows. Would really, really love any thoughts?

Cheers Guys
same issue. but im on a laptop...
to elaborate: i am unable to type in WoW. either in chat or at log in screen. binded keys (movement and action bar) still work but default binds (M for map, B for bags) do not work.

the keyboard works eventually and i can get on w/o communicating with group for that time. but when questing and i receive a reward i am unable to select it. when i click it it trys to show it on my character as if i had shift+click. resulting in me not able to turn in the quest and become frustrated....

again all function come back after a few minutes. is just really annoying.
I am having the same problem.

I have a Razer DeathStalker keyboard, and it has been working great on wow but all of a sudden when i open up wow and im at the home page i can not type in my password and no other keys work the only way i can get back to the desktop is to restart my computer.

I have re installed the razer synapse 2.0 and made sure that there is no key binding on any keys.

this is annoying me if anyone knows of any help would be great.
My keyboard wouldn't work with WoW. Didn't know what was causing it until I realized my XBox controller was still plugged in to the PC. Disconnected it and problem solved.
sometimes a button on the keyboard will get stuck half way, and it's just enough to keep your keyboard busy with that input but not enough to indicate which key it is. space bar is frequently the one that gets stuck when i encounter this problem
so has anone figured out a solution to this problem as its driving me crazy to have to restart my laptop every 30 minutes and it ONlY happens when playing wow
So this happened to me last night during raid. I was messing with my configuration in ventrillo. It took me all night and today to figure out the problem. Nothing suggested ever worked! But apparently MY problem was within ventrillo. I checked the button in the settings that says, " Use Direct Input to detect Hotkey". Saved it, then closed out of vent and wow and reopened. Walah! It fixed! Let me know if this works for you all!
ive had this issue for about a year or so now. I have an ASUS laptop with windows 7. The whole thing is pretty random while playing. Some days it doesn't happen, other days it will happen like 3-4 times. Only way I can fix it is by restarting my computer. Ill hit my windows key to get out of WOW and the same thing is happening anywhere you have to type something in. Sometimes sticky key has worked (shift key 5 times). Other times it won't let me bring up the sticky key option.

Join the Conversation

Return to Forum