Blizzard Updater UnableToInitializeStreaming

Technical Support
Okay. After struggling for the past 8 hours and counting to find a working fix for my problem and seeing post after post containing the exact same issue being ignored (probably due to a lack of information on the posters part)... I'm finally forced to post here in the hopes of finding a solution.

I'm running on Windows 7 64-bit.

This is the error message I am receiving:

Blizzard Updater

Blizzard Updater was unable to start up.

"<UnableToInitializeStreaming> <ContactTechSupport> (InitializeStreaming)"

The Launcher shows the following:
"Applying updates: 0% Complete"

And eventually a box shows up with "Updater connection timeout."

The updates downloaded just fine and are 100% downloaded, confirmed with BackgroundDownloder.exe

The error is occuring when the patch is attempting to install (or it seems).

I am able to run Wow.exe and log in however it is still version 4.1.0 (14007) and upon logging in there is a "Patch Required" screen and a Restart button.
Pressing it does still brings about the error.

To save time and to actually get a worthwhile response that will be helpful to myself and others please factor in the following:

1. Yes. I have searched the forum for others who have this issue.

2. Yes. There is enough space on the hard drive. There are no errors on the hard drive either. It has been defrag'd.

3. Yes. I have tried the solutions given in those posts. Every single one of them.

4. Yes that means I've tried the following:

    -The "safe mode with networking" fix.

    -The "selective start up" fix.

    -The "Permissions" / "Ownership" fix.

-Yes I'm running as administrator and I do have ownership of the folders and files.
-Yes I've also right clicked the files to "Run as Administator"

    -The "internet explorer" fix.

    -The "your security software is blocking something" fix.

-Even though ALL world of warcraft files and folders have been added as Exclusions or Allowed.
-Yes I did disable them all.
-Yes I also tried uninstalling them all (and then reinstalling, which was more wasted time)
-For those wondering running real time are the following: MBAM, NOD32, PrevX Safe Online, Outpost Firewall Pro.
-There are no conflicts with these programs running together.

    -The "your modem isn't port forwarded" fix.

-I even tried another modem, one which has updated WoW in the past. The Error is still generated.

    -The "Use Google DNS" fix.

    -The ".bat file" fix.

(i.e. wow-patch.bat file with the following:

@set CDIR=%~dp0

"%CDIR%Blizzard Updater.exe" --patchlist="Updates\wow-0-14333-Win-final.MPQ")

I'll also add that I have tried the following "solutions":

- Running MBAM, PrevX Secure Online, NOD32 scans to check for Viruses. Nothing found.
- Running Repair.exe
- Deleting the patch files and running Repair.exe
- Deleting the Update and Temp folders completely - then running Repair.exe
- Deleting the Launcher.exe and Blizzard Updater.exe - then running Repair.exe
- The "delete your Addons folder" fix, which isn't even for this issue.
- Deleting the WoW.mfil and WoW.tfil files then running Launcher.exe

And probably other "fixes" that aren't coming to mind right now.

None of the above has worked.

Repair.exe does appear to fix something as after running it, the Launcher shows that I need to download another 28 MBs.

After downloading this 28 MBs though the above mentioned Error still occurs.

If anyone has anything I could try to get things to work I'm all ears.

I will not reformat a perfectly working computer that was fine running WoW 24 hours ago.

In a worst case scenario yes I will uninstall and reinstall WoW in some ridiculous effort to get WoW to work, I'm looking for an alternative solution that doesn't involve such a drastic measure which doesn't seem to work anyway according to what people have posted.

Thank you.
Ok... in a desperate effort I asked a friend to give me the following 2 files which I narrowed down as being the potential culprits for my above mentioned issue:


(Their 4.2 version)



(From the World of Warcraft > Data > enUS Folder)

After replacing these two files I was able to get the game to finish installation through the Launcher.exe

Hopefully this will help other players out there with the same or similar issues!
I posted re the same issue here and recieved, like you, no help:

I did attempt moving base-Win.MPQ temporarily, it was simply recreated and the launcher errored out as before after a quick download.

Not even repair will function if I relocate WoW.exe, and I've got no access to alternate wow.exe that I'd remotely trust.

Would like a solution to this that doesn't involve 3rd party sources. I'm verging on doing a full reinstall.

Join the Conversation

Return to Forum