WoW won't open since 4.2 update

Technical Support
1 2 3 6 Next
Hey! So, I opened up WoW today and updated the patch like I would any other. I Pressed the Play button after the patch was completly finished downloading, it just closed the launcher without starting the game. I restarted my computer thinking that would help it, and tried again with the result. I tried to run repair but it said no errors were detected, I restarted my computer again. This time Windows failed to open completely. Nothing major but the top bar with the shortcuts didn't start up ( My systems is Windows 7 Home editon). I read a few of the topics here on the forums to find a solution. I deleted my Catch, WTF, and Interface folder. I read one thing on here that said stopping the launcher in the proccesses menu in task manager worked as a temporary solution but then when I tried opening the task manager up I noticed that it would no longer open. ( I did this with CTRL-ALT-DELETE then pressing start task manager.) I've also tried just directly opening WoW without the launcher getting the same results as pressing play in the launcher. Help?
UPDATE: Tried to run dxdiag to post my system information and THAT won't even start. I can understand a WoW update messing up WoW but rendering Task Manager and Dxdiag unable to start is rediculous..
Having the exact same issue here with windows 7, le sigh.
Well if it helps, I just called Blizz support. They told me they think I have some sort of virus.. Don't see how I could have gotten it seeing as my CPU was working fine untill I downloaded this patch but /shrug. I guess I'll try a virus scan and see if I can find anything. The Blizz represenitive told me I should wipe my CPU =/.
Don't wipe your CPU, man... They undoubtedly have a script from which they read when giving tech support. This is wide spread. I can't log in now either. After the connectivity BS I've been enduring since 4.1, I'm not renewing my subscription.
Same exact issue. This blows dogs
I'm having the same exact issue and I'm also on Windows 7. Wonder if that's the common issue? Please post if fix is found. Currently waiting on phone for tech support (43 min. wait time).
Another gamer was told by tech support that it might be your graphics card being out dated but i think thats bull...
I also have this same problem BUT I just found a temporary solution. For those this is happening to try this.

Right Click on your WoW shortcut select file location.
Go down the file list until you see a file named WoW. Nothing more just WoW. It should have the game icon.
Click on that and it will load up the game while skipping the initial launcher.

Hope this helps until they fix this problem.
I'm having this issue too, win 7 32bit - all drivers are updated - everything worked fine, no virus in scan. I dl the patch, and the launcher collapses to a background program but won't launch the game. The only way I can get in, is to launch from the EXE, which Blizz always says not to due for security reasons. I would really appreciate a blue comment on this matter. Based on the information above from telephone tech support, clearly they are unaware of the multiple threads and numerous individuals this seems to be affecting.
yes that will help, but if you have windows 7 it might be hard to find the WoW.exe file like it was for me.

here is how i fixed this simple problem! right click on your world of warcraft icon, and scroll down to properties. when properties opens, you should be under the SHORTCUT tab. under the shortcut tab, there will be a bar that says TARGET : "C:\Users\Public\Games\World Of Warcraft\Launcher.exe"

this is what ya have to do, delete the word "launcher" and replace it with WoW, so it says WoW.exe at the end. then press okay and open up WoW straight from your desktop and it worked fine for me. then when on the wow screen i disabled my launcher even opening up, so i just go straight to the login screen.

hope this helps someone out!
I'm having to start the game from the wow.exe, too. My launcher won't work (same trouble you're describing, but not affecting anything else...yet).

I called tech support when this started yesterday (after one successful launch & log-in), and the only answer the tech had for me was to stop running Norton. My husband and I have run WoW and Norton on both our computers since we started playing. The only "trouble" Norton has ever caused us was having to create an exception in SONAR for updates (easy to do, and problem solved). Not wanting to argue, I disabled Norton completely, and the launcher still failed. Deleting my addons, running as admin, running the repair tool, deleting the launcher then running the repair tool, running as admin from a new user account, Norton on, Norton off, and various combinations of all the above, all failed to fix the issue.
I'm running Windows Vista, so it seems like this problem is not particular to you, or your OS.
Hopefully, Blizz can figure this out soon and find a real solution for everyone. By the end of that call, I'm pretty sure the tech was as disappointed as I was that nothing we tried worked.

I tried loading the game without the launcher to no success. No when i open the launcher though it tries to download updated tools but then crashes after 5-7 seconds. Its frustrating
Alltaire, I'm at the exact same point as you now, the launcher tries to update then within five seconds crashes. Have tried reinstalling, tried reloading drivers, the work around through exe doesn't work it merely results in the same five second flash then nothing. Funilly enough my mozilla no longer works nor does steam. Could this have something to do with the coinciding windows updates?
Having the same problem... windows 7.. cant even bring up the launcher
Same problem here this is so frustrating and if you call, then you have to hold for 60 minutes and tey still have NO answer. What to do... What to do...
This is a windows 7 related issue, that part is obvious enough. So until blizzard is able to locate the source of the problem no hotfix will be delivered. The issue varying between those who are still able to use a "work around" by opening the unsecure exe in admin and those who are completly locked out from either launcher updates or even general game access. Never thought i would say this but i am beggining to miss Deathwing's ugly mug on my log in screen!
I am also having the above issue, however my patch isnt fully downloaded yet. (i was trying to play asap cause ive been out for a week). But I'm sure I'm gonna have the same problem, windows 7 here also and my comp is completely fine..

Im also having huge download problems for the patch, it will only down load in short bursts and is taking forever when I usually update in no time.
THANK YOU VERY MUCH!!! That worked..i found WoW.exe in WoW folder and used it to log on...have been trying since last night

Join the Conversation

Return to Forum