Razer Naga Issues Post Patch 4.2

Mac Technical Support
So bummed the firmware is for PC only, and I don't have Bootcamp. ; ;
Still no effect for me, but I appreciate the effort. =)

Thankfully, Vamptessa's fix does the trick - those of you also having trouble may want to check it out.

All you have to do is make sure this little app is running alongside WoW and it allows you to use modifier keys.

http://dl.dropbox.com/u/360607/WoW_Keyboard_Fix.zip



Man this was so great to find, thank you. I was surprised how easy it worked after trying so many different things and spending hours standing in Org hitting random keybinds.
Bump, any word on a fix?


I still can't assign shift to my mouse and use it in conjunction with other keystrokes.
I'm trying to get an update for this. Some Mac features were updated in the PTR, so I'm seeing if this has any affect on it. Might be a bit before I get any information back, but I will try to post when I get a more recent update for this.

Thanks!
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
Dedicated to making your Mac/Blizzard Experience an awesome one!
Knowing others is intelligence; knowing yourself is true wisdom.-- Lao Tzu
Is there a fix for this for a PC user? All I can find are the threads addressing MAC naga razer users. Any help would be greatly appreciated...
Aramun, you may want to try asking in the PC forums.

http://us.battle.net/wow/en/forum/1011701/
I apologize, after some further reading and messing around with different settings both in the wow interface and bartender4 interface, i got my shift modifiers working once more (YAY!!). Thank you for the swift reply, however!
Woot! :) Glad you got it working!
So, and update of sorts.

As mentioned earlier, we've implemented a terminal command that you can use to disable the expose/Spaces fix that was implemented in 4.2. (you can copy/paste this in Terminal)

  • defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

  • This is somewhat working, as after some testing with a naga here, the [Shift] key was able to be mapped to button 1, and used, but this was tested here. Are y'all able to test this out for constructive feedback? The [Cntrl] and [Option/Alt] keys were still not recognized, and that is something we're still investigating.

    I want to ensure you that we're still working & looking at this, as well as working on a variety of other things at the same time. I'm making this a sticky for the time being, so we can have some visibility on this. Thanks!
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
    http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
    Dedicated to making your Mac/Blizzard Experience an awesome one!
    Knowing others is intelligence; knowing yourself is true wisdom.-- Lao Tzu
    So, and update of sorts.

    As mentioned earlier, we've implemented a terminal command that you can use to disable the expose/Spaces fix that was implemented in 4.2. (you can copy/paste this in Terminal)

  • defaults write com.blizzard.worldofwarcraft disable-expose-fix -bool YES

  • This is somewhat working, as after some testing with a naga here, the [Shift] key was able to be mapped to button 1, and used, but this was tested here. Are y'all able to test this out for constructive feedback? The [Cntrl] and [Option/Alt] keys were still not recognized, and that is something we're still investigating.

    I want to ensure you that we're still working & looking at this, as well as working on a variety of other things at the same time. I'm making this a sticky for the time being, so we can have some visibility on this. Thanks!
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
    [url]http://www.surveymk.com/s/RF8K3KG[/url] ---- Rate my Baaaaalue Posts. How's this sheep doing?
    Dedicated to making your Mac/Blizzard Experience an awesome one!
    Knowing others is intelligence; knowing yourself is true wisdom.-- Lao Tzu


    Is this only for the Naga or does this work for the Death Adder too?
    This should work for any mice that were having the issue. We've only mentioned the Naga, as most users have reported this for this mouse. Try it out on your Death Adder and let us know the feedback as well.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Fri-Tue 1:45 pm - 10:45 pm CST
    http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
    Mac Blue will make you JUMP JUMP
    TonyM will make you JUMP JUMP
    Blue Posts will make you JUMP JUMP
    EDIT/Update:

    After adding that line of text into terminal, and removing every single wow preset keybind, my Naga & Rat7 & Death Adder have the assignments of the alt/opt/ctrl mod and work flawlessly with my Nostromo.

    #showtooltip Haunt
    /cast [nomod] Haunt
    /cast [mod:shift] Unstable Affliction
    /cast [mod:ctrl] Corruption
    /cast [mod:atl] Bane of Agony


    Tried every step mentioned above. At one point it was working but it no longer does. I have removed all Keybinds, Mods, added the terminal line of text, downloaded third party Wowkeyboard software and still cannot use any of my macros ie:

    #showtooltip
    /cast [nomod] SpellX
    /cast [mod:shift] SpellY

    Would be awesome if Blizzard might could spend a weekend effort to fix the solution for us mac people /cry
    Did you do the terminal entry prior to this? http://us.battle.net/wow/en/forum/topic/2743696123?page=3#49
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment
    Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact

    Pfft! Secret doors, who needs 'em? What do I care about secret doors?... and the unparalleled delights they keep hidden from the world!
    I recently bought a black widow ultimate and I'm playing the game world of warcraft. not sure who to contact but making a keybind in the game, it will not allow me to use Shift on the keyboard and 1 on my razer naga for Shift-1. my middle mouse button works and the extra 2. but not Shift-1-12. not sure what the problem is. Using a Mac as well, all is compatible. anyone with black widow ultimate and razer that can help me?
    I was reading this thread and I see alot of people having the same problem. at first I thought it was my new keyboard. but I can see it's the mouse I'm guessing. is there anything I have to download or should have download? is this problem fixed?
    Did you try the terminal entry I mentioned in my last post? This is something that occurs due to the OS thinking it may have 2 different keyboards and can only accept 1 entry at a time. The terminal entry toggles an option for an old fix (expose/spaces issue) that can help with mice buttons acting as modifiers. This may be your best option.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

    I'm not big on boasting, but you might have to take a victory lap.
    Cannot get this to work; terminal fix did not work. Any idea when this will be repaired? I see posts in this thread from nearly a year ago when this issue started; is there honestly no fix yet?
    Did you do the terminal command when wow was CLOSED? if it was open the command would not have worked nor saved, it would have been overwriten and not taken effect as soon as you exited.
    How do I do this Terminal now? I'm not sure what that is or what to do.

    Join the Conversation

    Return to Forum