App drops out soon as it connects!

Mobile Bug Report
Has been working well on my g3s running version 4.2.1. I go to log on now and the whole app drops out as soon as it connects. I've tried turning phone off and have deleted and re-downloaded the app but is still doing it??
What do you mean "drops out," exactly?
The Chat Gem Lives!
Fansite Administrator: DiabloFans, SC2Mapster, SC2Replayed
It totally turns off and it goes back to my iPhone screen
Have you tried deleting and reinstalling the app (and/or checking the app store for updates)? Also, is it when you connect in the initial login screen on the app or when you connect to chat?
Have done all those things. Was initially cutting out soon as connected from login page. Since yesterday afternoon I've been able to get on to ah but still cuts out randomly back to iPhone home page. I have not used chat or anything else other than ah.
I have only one account. Truffel has been the main char using the app though I have not 'set' her as the main? Have not Logged into the armory with any othe bnet acc. Just cleared cache and is at this moment still crashing as soon as it connects from login. Am running os 4.3.5 on phone and app is up to date. Was able to use ah for 5 to 10 min yesterday randomly before crashing.
Yes, have friends who play wow and am 95% sure they have not tried to access their acc through this phone. Have previously tried deleting app from the history bar. Looks like I'm going to have to cancel the acc :(
What you're describing is the app crashing. We'll need more information in order to deduce the possible cause...although what information that is, I'm not quite sure =\.

Thought I'd throw this out there, perhaps see if the devs can figure out a way to save a crash log or something? I realize you don't want to save a log every time something crashes because most phones don't have the extra space to spare, but... times like these it'd probably help.
The Chat Gem Lives!
Fansite Administrator: DiabloFans, SC2Mapster, SC2Replayed
Ok, I will look for those files. However I will not know what I'm looking at when I find them in order to fix any problems >.< tyvm for help :)
Ok I'll try that this weekend. I'll post the result. Ty
Ok yes the crash files are there. I deleted the folder, disconnected, re-opened armory, crashed straight away :(. The crash file was there again after re-sync. What program should I use to read the crashed file? If I post the file results can you help?
Crash logs are saved on the phone, but they are unfortunately not terribly useful for us most of the time. The other problem is transmitting that data to us, which isn't easy.

Just for your own FYI, to see your crash log folder, make sure that "Show hidden files and folders" is enabled in Folder Options, then plug your phone into your computer and sync it to iTunes. After that (in Windows Explorer window) go to:
C:\Users\[UserName]\AppData\Roaming\Apple Computer\Logs\CrashReporter\MobileDevice\[Device Name]\

You'll find your .crash and .plist files (both files are generated for each crash) in that folder.

That's unfortunate, but thanks for the heads up, I'm sure that'll be useful at some point in time throughout these forums, ;).

Is there also a dump for Droid phones as well?
The Chat Gem Lives!
Fansite Administrator: DiabloFans, SC2Mapster, SC2Replayed
Having the same problem, started yesterday. Running iPhone 3G. Tried reinstalling and turning phone off/on to no avail.

It seems to crash when attempting to load my guild for Remote Chat. I logged on to the Europe region (where I have no characters or guild) and did not crash. If I log on to the Americas region where my characters are, it crashes instantly. I am subscribed and paid with Remote Chat.

I hope you can help, I like my Remote Chat :)
I had it set to "Never log in". I always manually log in to guild chat after connecting to the app. However, since I recently reinstalled the app in an attempt to fix the problem, this setting will be whatever the default settings are - I cannot stay connected to the app long enough to change the settings, as I cannot access guild chat settings from regions where I have no guild/characters, and attempting to log in to the region where my guild is will automatically exit the app when I connect.

My guild name is Death Unlimited in the Americas region, and my main character is set to Kalwyrla (this character).

I remember the last time I accessed Remote, I was in the process of connecting when someone called me, and I answered the call. A few days later, when I tried to access Remote again, I'm getting these constant crashes.

I'm going to test your theory about the character-related problem by changing my character on this website and attempting to log in (it should change the character in Remote right? or at least I noticed that it seemed to do so). I will let you know what happens as soon as I test.

[EDIT]: Liogela, your intuition is absolutely right!!! Kalwyrla is causing crashes - I switched to Quicksilverr in the same guild and now I can access everything. I then attempted to change characters to Kalwyrla while connected to remote and the app crashed again. What should I do?

Join the Conversation

Return to Forum