Trouble installing/reinstalling Warcraft III

Technical Support
Blizzard,

My Wacrarft III has been giving me problems lately. Now when i try to reinstall it in "Program Files\Warcraft III" it says something like unable to copy the file war3.exe, operation aborted. When i try to install it in a different directory it says unable to copy the file Technical Support Web Site.

Note: When i clicked uninstall before it said unstallation successful. But the Warcraft III folder is still in my all programs part of my start menu, and they only things that are in are Technical Support Web Site, and Warcraft III Rgistration, and i can't delete the Web Site file.

Thanks
Hey Baileydog, let's try installing in Safe Mode: http://us.blizzard.com/support/article/safemode
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'There's an old saying about those who forget history. I don't remember it, but it's good.'

Rate Me! https://www.surveymk.com/s/R6BG5YS
Alright I installed it in safe mode but when i tried to launch it in safe mode it said unable to find war3.exe. When i ran it as administrator in safe mode it said unable to launch Warcraft III in safe mode. When I logged out of safe mode it said it was unable to find war3.exe. Outside of safe mode, I don't know how to run as administrator.
Can you make a new User Account in Windows, and see if you can run Warcraft III on that User Account?

Windows Vista & Windows 7:

  • From the Start menu, select Control Panel.
  • Double-click User Accounts, and then click Manage User Accounts.
  • Click Create new account. Enter a name for the account, and then click Next.
  • Click Computer administrator, and then click Create Account.

Windows XP:

  • From the Start menu, select Settings, and then Control Panel.
  • Double-click User Accounts.
  • Click Create new account. Enter a name for the account, and then click Next.
  • Click Computer administrator, and then click Create Account.

________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'There's an old saying about those who forget history. I don't remember it, but it's good.'

Rate Me! https://www.surveymk.com/s/R6BG5YS
Same problem. Im downloading the patch on both accounts now and I'll post the results.
The newest patch failed on the new account. At the very end of the patch it said that it failed.
I will try to download an older patch on the new account. Then I'll try to do the same thing but on the older account.
It said something like "Unable to apply patch because it does not match the file checksum.

File Name: Program Files/warcraft iii good/war3.exe"

Then it said"

"ERROR: unable to get version size for file 'c:\program files\warcraft iii good\War3.exe'
The specified image file did not contain a resource section."


This applies to both the new and old patch. BTW the "warcraft iii good" folder was when i tried to rerinstall it a while ago. However this folder has been deleted.
Let's check your hard drive for errors and defragment it: http://us.blizzard.com/support/article/21144

I'd also run a Windows Memory Diagnostic, or a memory test like http://hcidesign.com/memtest
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'There's an old saying about those who forget history. I don't remember it, but it's good.'

Rate Me! https://www.surveymk.com/s/R6BG5YS
I was unable to check my hard drive or defragment it because for the hard drive it said:

"The disk check was unable to be performed because the disk check utility needs to exclusive access to some windows files on the disk. They can only be accessed by restarting windows. Would you like to schedule the test when windows restarts"

When I click yes and restart it nothing pops up and I try to test and the same thing happens.

It also says that the defragment is not installed, when I try that.
The memtest reported no errors.
Bump
Can you make sure you have the latest Service Pack for Windows, as well as all of the latest Windows updates?

http://windows.microsoft.com/en-US/windows/downloads/service-packs
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'There's an old saying about those who forget history. I don't remember it, but it's good.'

Rate Me! https://www.surveymk.com/s/R6BG5YS
Got all of the windows updates as well as Service Pack 3. Still doesn't work. If it matters I do have TFT expansion, ready to be installed.

When I search warcraft in windows two folders pop up called Warcraft III both containing Tech Support Web Site, Warcraft III, Warcraft III Readme, Warcraft III Registration, Warcraft III World Editor, and Warcraft III Uninstall. Is this all that should be in the folders?
08/26/2011 09:12 AMPosted by Baileydog
If it matters I do have TFT expansion, ready to be installed.

Ok, I'd try a fresh install again, from scratch. Install Warcraft III: Reign of Chaos first, then install TFT, and then try patching manually:

http://us.blizzard.com/support/article/21224
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'There's an old saying about those who forget history. I don't remember it, but it's good.'

Rate Me! https://www.surveymk.com/s/R6BG5YS
It says there are still some files in the Warcraft III directory. Should I change the directory?
Yes, try installing in a different location.
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'There's an old saying about those who forget history. I don't remember it, but it's good.'

Rate Me! https://www.surveymk.com/s/R6BG5YS
Said something like acess denied cannot copy the file Tech support web site at the end of the installation.

Just searched warcraft again and some other warcraft folders came up from previous installs that have nothing but War3 in it.... and some folders only have the tech support web site.
Can you try it once again in Safe Mode?

How old is this installation of Windows?
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'There's an old saying about those who forget history. I don't remember it, but it's good.'

Rate Me! https://www.surveymk.com/s/R6BG5YS
Just searched warcraft again and some other warcraft folders came up from previous installs that have nothing but War3 in it.... and some folders only have the tech support web site.
08/26/2011 10:14 AMPosted by davidhc
How old is this installation of Windows?


What do you mean? How do I check?

Do I login as Administartor or the new account you told me to create?

Join the Conversation

Return to Forum