Wow Launcher Not working

Technical Support
My Wow Launcher launches the first screen with the single button to login and I press it and nothing happens. Task Manager shows no applications running. Seems to start happening after the last set of updates.
Mine has been doing that as well but with one difference. I show the Launcher application running in my processes. I've deleted the launcher, WTF, Cache, and Interface folders, run the repair function, and still nothing.

Maybe someone with more knowledge than the drone who took my call at tech support (the noise level behind him was comparable to a school cafeteria) will reply to this thread and give us more insight.
I have also had issues with the launcher as of late. I have had to kill the launcher process and restart it up to 5 times to get the Play button to activate. Sometimes it appears that the Launcher.exe item never runs as viewed in Task Manager. This has been a rare occasional problem in the past, but since the last patch its frequency has really grown. It has been much worse this week as well.

I did notice mention of Launcher changes in the last patch, perhaps something got knocked off kilter with a code change? Is there any resolution in sight?

Windows 7 64bit
4 core AMD processor
8GB ram
I have resorted to launching wow from my task i have the same problem.
I'm also having this problem..

XP latest SP and all patches. I've actually been running wow on a similar configuration since 1 year after WoW's release.. This is the first time I've seen such an issue in a while with WoW.

Behavior is same for me..

I can run the Launcher.. every once in a while WoW will start within a few seconds (i.e. normally).. but most of the time the Launcher will just sit in my task list (I can see it in task manager). It collects no processor time, simply sits there. When it does this, I've occasionally seen it start WoW after a couple of minutes.. but normally if it goes for more than 30 seconds I just kill it in Task Manager and start WoW.exe directly from my install directory.

To try to rectify this I actually >>>uninstalled WoW and reinstalled.<<<. that didn't help.. I've tried opening the ports as specified in the support site (although I've NEVER had to do this before), but that doesn't help either. I've verified my firewall is correctly configured.. and it is.

For me this trouble happened after the last patch. Its not preventing me from playing the game.. but it is something I'd like to see fixed.. since the Launcher provides some level of security.
More information..

I've tried the 'automatic detect settings' in IE fix.. and that didn't change it..

What I *have* discovered is that the Launcher indeed always starts WoW on my system.. but it can take up to 2.5-3 minutes.. looks like something must time out in the Launcher before it starts the main WoW.exe. Kinda curious.

I have a fast broadband connection.. all my network connections are set 'auto'.
I've got Comodo Firewall and WoW and the Launcher have full access. I've set the proper ports on my router. I'm *not* using WiFi.. my PC is on a wired 1 Gig ethernet connection.

I run a number of games over the internet and nary an issue with communications with any of them. Wow.. once it comes up.. runs like a dream on my system.
I have this exact same issue as well. It started after downloading last night. (working on a fresh install of the game on a new system).

There were topics relating to this on several instances on the EU forums. If I delete the found inside the WTF folder and try the launcher.exe it works once (prompts the updater to run again for non critical updates). However as soon as you close out and try again the hanging issue persists.

I'm on Windows 7-64bit and the game loaded just fine until that one update ran.

The EU forum mods mentioned disabling Bigfoot Network Killer etc but I'm not willing to start uninstalling my software when the launcher was working just fine with said software prior to this update.

I also tried the "run cmd as admin, type netsh winsock reset, hit enter and reboot PC." Although that appeared to work for some it isn't working in my case. I can still run Wow using wow.exe but fix the flipping launcher.
I've been having this problem since 4.2, I've just been running Wow.exe instead of the launcher. Annoying, but manageable.
Same here...where are you guys...I'm in SoCal I don't think WoW is in control of what's happening to us.........unless lost some IP info of us
I don't want manageable
Same problem here it takes about 10-15 mins if it DOES even work :P
This happens to me as well, and my partner, with the added problem being that our wireless router kills the internet connection as well. We have been using the 'fix' posted here a while back by players of opening the game directory and launching the game using WoW.exe instead. That lets us login but every now and then it still shuts down our net. On those occasions, I have noticed that the game opens instantly but the cursor takes ages to appear in the text field. By the time it appears, I type in my password, it thinks for 2 minutes and then says I've been disconnected from the server. If I try to open the internet, there is no connection.

We need to restart our router so often its beyond crazy, and this results in us getting a new IP address each time, which has in turn resulted in our accounts being locked for suspicious activity, my partners once and mine twice, just in the 2-3 weeks since we came back to playing after a break.

For us, when starting the game as you normally would, the launcher appears, downloads a small amount of data, but only sometimes, and then we can hit Play as normal. The whole thing disappears and the computers appears to lock up briefly, the Windows hourglass appears, then nothing happens. If we check our Task Manager, Launcher.exe is there, but nothing ever opens. I have walked away for up to half an hour and come back and the game still hasn't launched. Without fail, everytime we try to use Launcher.exe, our internet connection is killed, and can't be recovered without a full router reset.

It sometimes happens with WoW.exe as well but not as often, so that is how we are logging in for now. I posted my own thread but haven't had any reply, I'm in Australia and missed Customer Service today as I had to go out for the morning.
Same thing happens to me.. I've spoken to a GM about it and he said that they will fix it in the next hot fix... 2 weeks ago FTW blizz please get on this problem
Ok.. by removing and then 'repairing' I've been able to get the Launcher to upgrade to and now it appears that it always comes up and will go through an 'Applying non-critical updates', even though it did that the first time after the 'repair'...

But.. There is something MUCH worse lurking. Now when I quit from WoW.exe proper, wow never actually ends. I tested this over lunch, and when I came home 7 hours later, Wow.exe had still not quit (can see it in XP task manager).

I discovered this because when I first tested this, the launcher wouldn't restart at all.. so I looked in Task Manager.. and when I came home tonight I retested..

I think there are still issues here.
Im going to reinstall world of warcraft. I'll post update if it works.

correction, if it doesnt work, I will repost.
I've been running it through wow.exe since 4.0 and it never has stopped working. I suggest that more ppl use this route to log into wow if the launcher is giving them problems. If you can pin that link to your task bar and you should be running start into the log screen of wow. Less stressful and works like a charm.

PS, I'm running Windows 7-64 bit.
I have turned off all firewalls and anti-virus. I have even disabled the internet. I have uninstalled and reinstalled. I have delete WTF, cashe, and interface folders. None of this has worked. I have been using the wow.exe for two months now. The only time the wow launcher works for me is when the launcher is downloading.
I really don't want to reinstall. Is there really no fix for this?
I really don't want to reinstall. Is there really no fix for this?

next time please dont bump a thread.As you can see last post was 2months ago.And if you tried everything your last resort is reinstall
02/17/2012 03:56 PMPosted by Balanden
I really don't want to reinstall. Is there really no fix for this?

next time please dont bump a thread.As you can see last post was 2months ago.And if you tried everything your last resort is reinstall

Thanks to other threads (bumped, rather than making a new one), I have indeed found other things to try. The problem is still ongoing for quite a few people, and they all list reinstall as one of the things they try. Cata just doesn't have enough going for it right now to invest that much time in it.

My best option may be to go back to the Other Game until Blizzard gets their act together.

Join the Conversation

Return to Forum