Launcher won't open

Technical Support
Okay, so, this has been going on for a few weeks, about a month or so, but basically my wow launcher won't open. I can still play, not a problem, but, in order to do so, I have to go into my WoW folder and open WoW manually. Has this been happening to anyone else or does anyone have any suggestions on how to fix the problem? Starting to get a bit annoying.
You would want to run over to the Tech Support forum and ask this. They would be able to assist you better over there. Good luck, I could see how that would be annoying. :)

Edit: Or the Blues could simply move it over while I was typing. You should be in good hands over here... :)
Nymmastus, do you mean that when you press the Play button on the launcher nothing happens, or the launcher won't come up at all?
________________________________________________
Accounts & Technical Services || Tues-Sat 7AM-4PM Pacific Time
Truth poorly defended loses not its truthfulness

Contact a live Support Rep directly - http://us.blizzard.com/en-us/company/about/contact.html
Please feel free to rate my services: https://www.surveymk.com/s/DXF96P2
I kind of have the same problem. I play WoW through steam and recently whenever I launch it through steam I press play on the launcher it closes but WoW never launches. Now I know I can play like this because I've done it in the past, and if I change it to launch Wow.exe instead of the launcher I can play. Does anyone know if I can fix it?

**EDIT** WoW won't launch from the launcher period. Whether or not I launch it from steam or out of steam.
The "Pressing Play does nothing" issue is most often caused by security software or permissions issues, but there are numerous identified causes enumerated here: http://us.battle.net/wow/en/forum/topic/2721565353#2
________________________________________________
Accounts & Technical Services || Tues-Sat 7AM-4PM Pacific Time
Truth poorly defended loses not its truthfulness

Contact a live Support Rep directly - http://us.blizzard.com/en-us/company/about/contact.html
Please feel free to rate my services: https://www.surveymk.com/s/DXF96P2
My problem isn't that when i click play, it WoW won't open. My problem is that when i click on "World of Warcraft" on my desktop or start menu, the launcher won't come up at all. I can still play, like i said, but only when i manually open WoW. I just want to figure out a way to have my launcher its self open (oh yeah i've tried "run as admin", that didn't work either).
OK, go ahead and delete that shortcut on your desktop. Then open up the World of Warcraft folder and delete Launcher.exe. Run the Repair utility, which will re-download a fresh Launcher, and re-create the shortcut.
________________________________________________
Accounts & Technical Services || Tues-Sat 7AM-4PM Pacific Time
Truth poorly defended loses not its truthfulness

Contact a live Support Rep directly - http://us.blizzard.com/en-us/company/about/contact.html
Please feel free to rate my services: https://www.surveymk.com/s/DXF96P2
Alright, sounds good, thanks
I wasn't able to get that to work either, running windows 7 64 bit.

I got it fixed by going to

Start --> Programs --> Accessories (Right Click on Command Prompt) --> Run as Administratorthen type in: Netsh winsock reset

Then reset your computer. It prompted me to re-enable family services from verizon security suite when it booted back up,(don't know if you have that, but it was disabled on mine even before) but I didn't re-enable.
but the reset itself with the command prompt did it!This fixed my Itunes store not loading also was an issue, and when I did this It fixed the WoW launcher from not launching the .exe file! Now I can resume life as it was.And it also fixed the background launcher issue!
I wasn't able to get that to work either, running windows 7 64 bit.

I got it fixed by going to

Start --> Programs --> Accessories (Right Click on Command Prompt) --> Run as Administratorthen type in: Netsh winsock reset

Then reset your computer. It prompted me to re-enable family services from verizon security suite when it booted back up,(don't know if you have that, but it was disabled on mine even before) but I didn't re-enable.
but the reset itself with the command prompt did it!This fixed my Itunes store not loading also was an issue, and when I did this It fixed the WoW launcher from not launching the .exe file! Now I can resume life as it was.And it also fixed the background launcher issue!


This fixed my Launcher from being stuck on Initializing, please wait. I use Windows XP and don't have any of those extra programs that you do. So, thankyou for this fix!
Ok i was having the same issue as Nymmastus and i tried deleting launcher.exe but it says that the launcher is still running close and try again. So should i restart my computer and try again?
Hi, the same thing has been happening to me, except when the launcher opens, it says " downloading updated tools" then it close's once it reaches a certain point.
Bumping threads from last year causes a bit of confusion. If you need assistance with an issue, please create a new thread and detail your issue there. Make sure to include any steps you have already tried.

Join the Conversation

Return to Forum