"Unable to connect. Please try again later."

Technical Support
I've just been browsing the forum here and a lot of people are saying they can't log in due to a survey or something? I've never experienced this problem and i'm not sure if my problem is related at all. But whenever I try to log into my account this pops up;

"Unable to connect. Please try again later. If the problem persists, please contact technicaly support at: [http://us.blizzard.com/support/index.xml?gameId=11&rootCategoryId=2316]"

I've never had this error before in all the years i've played so I have no idea what is causing it?

I use avast anti-virus if that's of any benefit.

Is this something that can be rendered easily or will it take a while? I just bought a new month of WoW time today, FML.
I'm having the exact same problem currently, Net connection is fine, turned off my anti-virus and firewall, did nothing.

Deleted my WTF, Cache and Interface, still nothing. No idea whats causing it =| was playing perfectly fine earlier.
this must be some kind of government conspiracy. sigh. same thing for me.
also for me too, threw in a ticket to support on the website and they said i may have something to do with their silly survey and it causing problems if they have their firewalls or antivirus up. i dont know if its true though, as for i dont keep either up and was playing just fine earlier, logged out for dinner, and now i cant get the game to load.
Seriously, I am not impressed that survey which gathers information that Blizzard may or may not be entitled to is stopping me from playing a game that I have enjoyed playing for the past 5 years.

Providing this information should be optional, not mandatory.

I have disabled my software firewall and it still won't let me in.

Poor form Blizzard, poor form.
Been over 2 hours and still can't log in, just awesome.
Been quite a while for myself, tried logging in at around 1 PM.
It's now 7:25 PM (Australia), still can't log in.

No firewalls or Anti-virus active, Cache etc etc.. deleted.

Not impressed.
Hmm I'm able to log in fine.

I've also been able to recreate the message coming up yet I can get in fine.

The non personal system information is gathered by the login server which appears to be up.

Hmm I'm actually running late for work so I'm going to have to get back to your with an answer. There's a setting you can put in somewhere to say "yes I've done your silly survey of my hardware details". It's in the registery on Windows and in the Library folder for Mac.
5 Hours now, still got no idea how to fix this.
9 hours since I tried and still no changes :(
I have same problem but i can play now, i have used the repair tool from launcher, now i can login again =), try to use that and login again ^^
Already used that hours ago, Did nothing.
WTB a fix for this already.
Okay it's finally working now. I did nothing but wait guys, unfortunately if you're still suffering... took 14 hours but it's finally working.

Said something like 'Submitting non-personal information' then logged in.

Let's hope it stays this way.
Ok so been 22 hours and I still cannot log on, Looks like i'm going to miss raiding tonight as well.
Having same issue, says "connecting" for like 10 or so seconds then everything resets and says "Unable to connect to server", this is the 4 day i've gone without WoW, and being a major fan and adict, Im having major withdrawls... anyways it does that crap, i do what Blizz tells me to do, even after the went a comprimised my account (seriously?!) got it and password is reset, tried it and still says unable to connect... ive had no survey, and firewall (MacAfee) is letting WoW through... I WANT SOME ANSWERS TO FIX THIS!!! Blizz if you see this just to let you know that you need to work better for your customers, probaly the reason your stocks are going down. IF ANYONE HAS THE SOLUTION, POP IT ON THIS FORUM PLEAZ!!!

PS: with this going and a timed event (Hollow's End) going on, i am desperate for an answer instead of crap like reseting motems all that...
Just now saw something that im curious about and need some explanation...

If you do see a folder called enUS, open it up and then open the realmlist.wtf using wordpad. It should say:

set realmlist us.logon.worldofwarcraft.com
set patchlist enUS.patch.battle.net:1119/patch
set realmlistbn ""
set portal us

i checked my files and all but there is no folder, but instead apps for the dowloader and patch tools along with the WoW-installer (all of them conatain enUS with in it)... is that what its suppose to be or what?
Where are u guys from? I was thinking that could be my internet provider (net virtua, Brazil), because my friends from my city (Brasilia) that have other internet providers can log in w/o any problems.

Join the Conversation

Return to Forum