There was a problem logging into your account

Mac Technical Support
Hello, i just found out today that my mac (not yet lion) laptop, has an error while logging in. The error is as its shown below:
There was a problem logging in with this account. You may not have a world of warcraft game attached to your account, or you may be logging into a region different from the one you created this account in. If you continue having trouble, please contact Customer Support.

I checked everything, the realm (Dreadmaul) and US/Oceanic servers. My windows desktop can run this smooth though, and im confused why there is an error message, can you guys please help me?
Do me a favor, Fluffy. Open the WOW folder and go into Data. If you see a folder called "enGB," delete that folder. Then, open the Cache folder and delete the same folder. Then, delete the WTF folder and run the Launcher.

That *should* resolve the problem. Please, let me know if this works for you.
Also delete wow.mfil and the wow.tfil files as well before opening the launcher.
Hello, i deleted:
enGB (Data folder)
enGB (Cache folder)
WTF Folder

but the problem still persists, is there any other solution?
Let's try deleting the Blizzard folder found under Mac HD/Users/Shared/ ; and the Interface, Cache & WTF folders from /Applications/World of Warcraft, & the Cache folder located in Applications/World of Warcraft/Data. After these folders are removed, we want to run the Repair Tool. This can be found in your World of WarCraft folder under Applications. Then test the game.

If still same error, please uninstall/reinstall the game via the instructions on the following link:
Klint P
Mac Tech Support for Blizzard Entertainment || Mon - Fri 1:45pm - 10:45pm CST
If you can't find it here, contact a rep direct : <---- Rate my Blue post here...
If there is a problem Yo I'll solve it, now check out my hook while the DJ revolves it...Mac Mac Baby!
10/20/2011 08:46 AMPosted by Fluffybuffy
but the problem still persists, is there any other solution?

Did you open wow from the launcher then try to log in ?
Ok, i deleted those folders and now im downloading an update or something
Thank you KlintP, it works now!
hello guys im in a tad worst of a problem and id like to do all that stuff but heres my problem.
Went to and all downloaded the game and waited until it was playable im coming back from a 2 year vacation and it says the thing sad thing is i have no way to acess the wow folder all i see is the wow repair and technical support thing and play. i meen everything else works and all but that is my problem i cant acess my folder i see it but all the data and stuff is not in it. just the stuff i listed help would be awesome thanks.
Please don't necro threads :(

This thread doesn't seem related to the topic you are posting about. If you could please, create a new post with this information so we can better assist you with your Mac troubleshooting.
Mac Tech Support for Baaaaahlizzard Entertainment || Sunday to Thursday 11:00 am - 8:00 pm CST ---- Rate my Baaaaalue Posts. How's this sheep doing?
The mechanical sheep with a heart of gold...
If at first you don't succeed... call it Version 1.0..

Join the Conversation

Return to Forum