Unable to Connect to Guild Chat after Paid Service

Mobile Bug Report
1 2 3 8 Next

I've been unable to connect to remote my guild chat through any mobile armory (tried with WiFi and 3G already) not even with an Android Emulator, after we performed a guild name change. I am able to connect to my Bank guild's guild chat, which haven't changed name. As a programmer I believe that this can be caused by some sort of ID problems with the guild name changes.

Looking forward for a fix.
Same thing. Unfortunately I don't have any other alts in guilds to test if this is strictly due to the name change.

edit: No offense, but that's some pretty bad QA, if there was any even done on this service :P
Whew, I thought I was alone, did all sorts of forum searches over the past 2 days (and thanks to Kenda (Customer Support) I found this post.

We've tried all sorts of ways to fix this with no success. Kenda is also trying to find a fix but wanted me to post here to get the app creators to see it too.

Sadly I still have the problem even though I did the following. (and I have no idea if it's because I had a tech rename the guild for me after I moved it - from CastleRain to Suspicion of Mischief - just throwing it out there)

I uninstalled both the Armory and Battle.net Authenticator app (for good measure)
I rebooted the phone
I cleared all caches
I reinstalled both the Armor and Authenticator (though the authenticator is only there as a back up, I don't actually use it)
I cleared the caches again
Sadly nothing changed.

I can log in and use the auction house without issue, but guild chat just hangs for a very long time then gives the error "unable to connect to server".

BTW, I never get to say how great the customer support is at Blizzard because I don't want to reopen the ticket just to say that. So I'm saying it now!! You guys rock! OK, Theodas.... Focus... lol

So... any ideas? I'm sad it's not working for me.

And it's only since I moved the guild over and had it renamed as mentioned above (but I dorked the renaming because Mr Genius here (me) forgot to hit the check box during the order process).
I thought to try to re-install the App too, but I guess that's pointless :P

So, those who are locked out of chat, but are still paying... can we get some light shed on the situation?


Just so no one thinks I'm crazy.

No I'm not, yes I am, no I'm not, yes I am!
This isn't a mobile issue, this is a server issue.

4. I just left my guild, but Remote Guild Chat still shows me as a member of that guild.
Some types of character data are not instantaneously updated in the Mobile Armory application. In some cases it may take up to a day before you see changes such as these reflected on your mobile application. If you still feel there's a potential issue with the updating process, then please report your findings on this forum or via e-mail at wowarmory@blizzard.com

This isn't just due to guild changes, but also character data changes that occur when any paid service is initiated. We have been aware of this for some time now and have made it known on the forums since its inception. It is not new to the Guild Transfer service.
I know it's not the same scenario as outlined in the "Commonly Reported Issues That Are Not QA Bugs" but it's the same data that takes time to update.
Well our name change was more than a day ago. The battle.net page shows me as in the new guild, and the drop down menu also shows me there. Still get disconnected when trying to log into guild chat.

Don't remember having this much issue when doing a regular server transfer.
My Guild change was on Monday, it's now Friday. I would think by now the servers would've updated the information.

Again, a support member Kenda suggested I post on the mobile forums. So what should folks like us do or expect? Or will it just be left as a known issue with no resolution?

None of my characters can access the guild chat after the move. Seems odd that if it's not due to the move, and I have moved characters before without issue, and that after my characters got to Frostmane, they did not have any issue.

But when the guild moved they all have issues with it, that would indicate something related to the guild move.

Do we have to wait for the next server reboot?
So, I did a test. I took out my main of our recently name changed guild, and had my alt get invited instead.

I joined a different guild on my main.

Took until this morning, but both finally show up in the correct guilds on the armory drop-down tab.

Guess which one can connect and which can't?

My main can connect to the alternative guild I joined, and my low level character now can't connect to the recently name changed guild that he has never been in.

^ me btw :P

So, unless this guild name change thing takes over a few days to update to the armory apps... something is still wrong.
Looking into this.. Sorry guys. One of my guilds did a name change and I had no problems with the Mobile Armory after the cache was updated.
My guild as well has the issue
Been almost a week since I moved and rename my guild. Still have no Guild Chat app love.
Looking into this.. Sorry guys. One of my guilds did a name change and I had no problems with the Mobile Armory after the cache was updated.

Actually, here's the correspondence from Kenda on 11/2/2011 about the cache.

Hi Theodas,

I have done a cache kill on your WoW account on our end, this should clear any temporary files that might be causing a problem. You may want to try clearing the cache and temporary files on your phone/device and/or reinstalling the Mobile App and making sure your phone, the app etc are all up to date.

Keep me posted.


Kenda S.
Customer Service
Blizzard Entertainment
My Hours - 9am-5pm CST Tuesday - Saturday

Her efforts sadly did not help. But she's been a real help in trying as hard as she does. She's very determined.
Hey guys, I too have been having this issue since my guild had but a simple name change. Have cleared caches, reinstalled app, wifi and 3G but to no avail. I have one character in a guild that isn't my own, and that can still connect to guild chat, however none in the name changed guild can connect. Just posting here cause I can't see anywhere else to post, and also so the peeps know there are more having issues.

Characters, maefyre, spitlock, hatred
Guild : "awkward silence", previously "horde ate my mount"
Server: dath'remar
After server maintenance today, all my characters (except the level 1) can access guild chat! And AH! Woot!
11/08/2011 12:37 PMPosted by Theodas
After server maintenance today, all my characters (except the level 1) can access guild chat! And AH! Woot!

Very happy to hear about that, Theodas! Is there anyone else who can now access guild Chat after Tuesday maintenance?
This should be resolved for ALL guilds. Please let me know otherwise.

Join the Conversation

Return to Forum