internet connection interrupted

Mac Technical Support
For some reason over the past week or so (since the updates/patches started, I'm guessing to prepare for the BIG patch) every time I launch WoW, and even when I exit the game, it causes my internet connection to drop, or reset, or something. At first I thought it might have something to do with my ethernet, so I unplugged it and went wireless (on my desktop computer). I reset my modem, reset my router, etc. Launch Wow and boom - no internet connection, my computer is trying to reconnect to my router all of a sudden. But, a few seconds later, it's back up, and i can connect to wow. It's irritating because if I am in skype, or in ventrilo, it disconnects me from those applications.

So, then I thought maybe it's the computer? So I set up my laptop to run skype/vent and play wow from the desktop. Nope, still does it. Have skype or vent running on the laptop, launch wow on the desktop, out goes the internet for about 10 seconds - disconnecting me from skype/vent on the laptop.

It's the WEIRDEST thing...never had this problem prior to these little mini updates/patches in the last week or so. And for it to affect 2 computers (one that WAS hard wired to the modem, the other was wireless, and now both wireless) makes no sense.

So if any of you wizards out there have a suggestion, I'd love to hear it ;-)

I run a Mac Mini with 2.66 GHz Intel Core 2 Duo Processor with 4GB memory, the laptop is 2.16 Ghz Intel Core 2 Duo with 2 GB memory.
Connection problems can be caused by many things.

First, please remove any security software you have installed including PeerGuardian or Norton.

Second, make sure you're logging into WoW using the email address associated with your account rather than your old WoW account name.

Third, check your file:
1. Navigate to World of Warcraft/Data/enUS/
2. Open the" file using TextEdit.
3. Make sure it looks like this:

    set realmlist
    set patchlist
    set realmlistbn ""
    set portal us

4. Save it in the enUS folder.
5. Test WoW.

Then, I want you to remove 3 folders from the WoW folder.
1. Navigate to /Applications/World of WarCraft
2. Delete the Cache folder.
3. Move Interface and WTF to the Desktop.
4. Launch WoW.

If that fails, powercycle your network devices.
1. Unplug your modem and router (if you have one.)
2. Let them set for 30-60 seconds.
3. Plug them back in modem first, then the router.
4. Reboot your computer.
5. Test WoW.

Now, if all that fails, you'll need to flush the DNS.
1. Navigate to Applications/Utilities and open Terminal
2. Type in the following commands:

sudo killall -HUP mDNSResponder
sudo killall mDNSResponder
sudo dscacheutil -flushcache

3. Then go in your Network pref pane -> Advanced and click "Renew DHCP lease"
4. Attempt to connect to the game.

Please, let me know if this works or not. Thanks!
I have tried all theses steps, so far none have worked!

My husband, sister and I are also having this problem. Every time anyone in our house launches WoW, it hicups our connection. All other programs I am running such as Skype/Vent also are effected by the loss in connectivity.

Any other Ideas? Please don't tell me to reinstall WoW because I have also just done that.. and removed all my addons. To no avail

Something else that is strange is that Skype now won't even allow me to make calls now. I can use it as an IM but not make calls... This leads me to believe that the issue is greater then just with WoW . I am going to try updating my router firmware (if needed) to see if maybe this is the problem.

Any additional insight would be welcomed

Please, don't bump your thread unless it falls past the second page. Please remember that Technical Support moderates the forums 7 AM to 8 PM Pacific Time, 7 days a week.

If no Blizzard employees are able or available to provide an answer in your thread, you should contact our techs more directly:

Let's run a trace:

1. Go to Mac HD => Applications => Utilities folder.
2. Open the Network Utility program.
3. Choose Traceroute tab.
4. In the box enter:
5. Click the Trace button.
6. Select all the data that comes up in the box below.
7. Command + C to copy the data.
8. In your reply, use Command + V to paste the data.

To get a trace to the realm while you're connected:
1. Go to Mac HD => Applications => Utilities folder.
2. Open the Network Utility program.
3. Choose Netstat tab and leave "Display the state of all current socket connections" selected.
4. Click "Scan."
5. Find the first foreign address that says battlenet.
6. Copy/paste the IP address into the Traceroute tab.
7. Command + C to copy the data resulting from the trace.
8. In your reply, use command + V to paste the data.
I am also having this same problem, before the recent updates/patches my router never once restarted when I launched wow, now every time I launch wow or my gf launches wow my router restarts and I can play wow about 10 seconds later. Its the strangest thing I've ever seen happen on my computer anyway.

Oh and I'm not using a mac.
are you using a linksys router? make sure your router has latest firmware update available, go to manf. website and get the latest firmware you can find for it and update it. a few linksys router models had this problem and they were fixed in firmware updates
Mac Tech Support MVP
Addon Author
I have this same problem as well, drops the connection for a few seconds then goes back to working just fine. I have however noticed it only does this with the launcher, if i say, launch WoW directly from the file location without using the launcher it doesn't drop the connection. I also use a linksys router and tried to upgrade the firmware but that was presenting it's own problems for me. I also don't use a mac either but the problem seems to present itself elsewhere.
Thanks to this post I just saved 105$.

With my old router I was noticing an issue where every time the game was loaded my entire networks internet connection went down. All we had to do was click the Icon for the splah screen and it would drop the internet on every computer. So I had just purchased a new linksys router which cost me about 80$ to try to solve the issue. It worked but I soon realized that my connection speed sucked it was way better with my old router. I had loading times for youtube video's it was dreadful!

I decided to see if I could fix the issue with the old router. After seeing this post I updated the firmware on my old linksys router and it works better than before!. So I returned the new router to best buy plus my banking account is in danger of overdrafting (yes I hate bank of america).

So many thanks for your post Omegal!

Join the Conversation

Return to Forum