Addons breaking for 4.3?

UI and Macro
Disabled FishingBuddy and Recount for myself - and the game seems to load fine (if after a few mins. of load time, but it still loads).

Though I've always had issues with Load Times ever since 4.0.1. Had a thread about it that Blizzard Blues were helping me with at one time, but have never gotten resolution on. :(
Also ingame, auctioneer looks to be really buggy so I'm going to disable it as well...
Mounted is also one of the crashers.
Thanks to the folks who suggested disabling FishingAce. I disabled it and now WoW loads fine. Thank you.
Had a similar hang with Broker_location.
My only problem was FishingBuddy, and recount seems fine for me so far.

A ticket with the author of FishingBuddy was already submitted by someone else, but so far no update is available.

P.S. The only other addon issue I found was with Atlas, which on curse was not in a complete package as in the past. Instead, I had to separately download the main addon along with each of the components individually (e.g., OutdoorRaids, Transportation, DungeonLocs, Battlegrounds, etc.).
Any way to figure out what's broken with Fishing Buddy/FishingAce? Since it keeps WoW from loading at all, I don't know how to try to help the addon author figure out the problem. Just trying to help out.

Though, TomQuest2 did the same thing. I should see if they have any libraries in common, I guess!

ETA: Apparently it's Lib-Tourist that's breaking the Fishing mods. Updating it to this one fixes it: http://www.wowace.com/addons/libtourist-3-0/files/122-wow-4-3-beta1/
Any way to figure out what's broken with Fishing Buddy/FishingAce? Since it keeps WoW from loading at all, I don't know how to try to help the addon author figure out the problem. Just trying to help out.

Though, TomQuest2 did the same thing. I should see if they have any libraries in common, I guess!


The addon author needs to update his copy of libtourist. This applies both to FishingBuddy and TomQuest2.
Any way to figure out what's broken with Fishing Buddy/FishingAce? Since it keeps WoW from loading at all, I don't know how to try to help the addon author figure out the problem. Just trying to help out.

Though, TomQuest2 did the same thing. I should see if they have any libraries in common, I guess!


The addon author needs to update his copy of libtourist. This applies both to FishingBuddy and TomQuest2.
Downloading LibTourist's 4.3 beta from WowAce and installing it as a stand-alone AddOn may fix it.

http://www.wowace.com/addons/libtourist-3-0/files/122-wow-4-3-beta1/

If that doesn't work, you could try putting an exclamation mark at the front of the folder and .toc file's names (LibTourist-3.0 becomes !LibTourist-3.0). That should force it to load earlier and (hopefully) prevent the older copies of it (packaged with FishingBuddy and TomQuest2) from dividing by zero and crashing the game.
I was hanging on login due to both of the following mods:

Cromulent
FuBar - GuildFu

In both cases, it was an old version of LibTourist-3.0 causing the issue.
Was locking up at load screen as well and had to manually kill. First I disabled old addons so I could successfully load. Then I enabled old addons and unchecked FishingBuddy, Recount and Mapster. Was then successfully able log.
If you're having issues with Recount, get Skada. It's working just fine.
I believe Bagnon (NOOOOOOO) is also fried.
Cromulent addon was the culprit for me. Hope this helps someone else.
TravelAgent was causing the hanging on loading screen issue for me.
11/29/2011 12:39 PMPosted by Ryoxo
Some minor trouble with Chinchilla due to the LFD functions but three lines commented out of two files brought it back mostly functional.


Ran into a similar problem myself with SUI. Rename LFDSearchStatus to LFGSearchStatus and you should be good to go.
________________________________________________
The wise speak only of what they know. - J.R.R. Tolkien
CORE I7 3.8GHz | 12GB RAM | ATI 5970+5870 | F120 SSD
Live Support: irc://chat.freenode.net/wowtech

Join the Conversation

Return to Forum