Addons breaking for 4.3?

UI and Macro
Auctioneer has been fixed for the most part. Be careful when scanning though. There was a change made to GetTime() which can cause a crash on slower computers when a scan finishes.

I posted a patch for the addon in the comments on this page:
http://www.curse.com/addons/wow/auctioneer

Look for the post by me; twistdshade
Inline Aura seems to be behaving erratically for me...the aura on buttons seems to go away and come back randomly. I think it might have something to do with the changes to GetTime(), but I'm not familiar enough with UI development to try and fix anything. Today's update by the author didn't seem to help.
Make sure you submit the ticket up at wowace inline aura page about it.
Yeah, I made a ticket. Was just checking if maybe people who are more familiar with the GetTime() change had any insights.
I can't say for sure what will happen. If Blizz isn't making any changes to the API and such, everything should be fine. However, some (or all) add-ons will not load if you do not have "load out of date add-ons" checked.

Rest assured that many authors have already updated and tested their add-ons on the PTR and will have a working version ready by tomorrow.


Where is this button? My addons arent loading post patch,
I can't say for sure what will happen. If Blizz isn't making any changes to the API and such, everything should be fine. However, some (or all) add-ons will not load if you do not have "load out of date add-ons" checked.

Rest assured that many authors have already updated and tested their add-ons on the PTR and will have a working version ready by tomorrow.


Where is this button? My addons arent loading post patch,
In the character selection screen AddOn menu.
I lost a ton of my skins to achievements, maps, etc... this patch, although about half still work. Anyone have any idea if they changed any functions with any of those elements?

For example, skin for the raid control still works, but then achievement pop up doesn't neither does ready check.
My add-on button is no longer available at character selection - anyone else?
12/03/2011 04:46 AMPosted by Taric
My add-on button is no longer available at character selection - anyone else?


Read the FAQ.
http://us.battle.net/wow/en/forum/topic/1536706542

Join the Conversation

Return to Forum