Game freezes on Dragon Soul Videos

Mac Technical Support
Prev 1 7 8 9 12 Next
12/23/2011 11:47 AMPosted by Kaoskat
Just to add something I've noticed that helps. I'm running on a iMac, full screen, with a resolution of 2560x1440. If I switch quickly to "windowed" mode before the cinematics start, then I don't have the freeze / crash issue.

Yea I noticed the same. I still have the freeze issue and this was the only way I found to avoid it (when a boss dies I promptly press command + m).

I'm going to try to create a fresh Config.WTF since my is pretty old and has a lot of configs I think aren't used anymore to see if it does any difference.

Using the command to play the videos worked nicely with no freezes at all.
I too am having this problem when LFR DS. It is not every cinematic, nor is it every time, but mostly before getting onto the airship. I do not believe that this occurred the very first time it appeared, but I may have ESC while it was running for the first time. Screen goes black and nothing happens. I wait 30-60 seconds then CMD-OPT-ESC and launch client again.

I checked setting as instructed here and applied Permission settings. When using the links provided the files all play x5 without delay or issue. I am normally running with ONLY Wow and Ventrillo up, with WoW in Fullscreen at 1920x1200 which is native for my MBP. Note that all modern MacBook Pros have dual video, so I really hope this is not an issue as it should have been taken into account LONG ago.

I will post my data as help as well, but will be using DBM to just kill the videos all together. This issue has wasted too much of my time. I play WoW to get away from troubleshooting and I'd rather not miss out on loot roles as well! Thanks Omegal!

Just a few additional notes to help with the process and to clarify the topic overall:

Reset the temp files:
1. Navigate to /Applications/World of Warcraft/
2. Delete the Cache folder.
3. Move Interface and WTF to the Desktop.
4. Run the
5. Launch WoW.
6. When it completes the "Applying non-critical updates", click Play and log in.

Everyone on the planet has Read & Write permission on World of Warcraft folder. I think it would help if the full name of World of Warcraft is used.. I had to use Spotlight to find it as it's name doesn't start with "R".

I do not have OpenGL in my Note that it is still recommended for some folks in this sticky post from May 2011 by MachKhan:

If the freezing persists, we'll need to check the md5 for the cinematics folder ONLY AFTER you attempted the above steps.
1. Open Terminal (/Applications/World of Warcraft)

Terminal is at /Applications/Utilities/

~My Data~
Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,3
Processor Name: Intel Core i7
Processor Speed: 2.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 4 GB
Boot ROM Version: MBP81.0047.B24
SMC Version (system): 1.70f5
AMD Radeon HD 6750M:

Chipset Model: AMD Radeon HD 6750M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6741
Revision ID: 0x0000
ROM Revision: 113-C0170L-573
gMux Version: 1.9.24
EFI Driver Version: 01.00.573
Color LCD:
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

Intel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 384 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
gMux Version: 1.9.24

System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 16:19

NO CURRENT Error.txt files.. Client freezes before one is created. My latest file is from 3 months ago. Crash is not reported to MacOS, no information found in logs.


FCP Uncompressed 422.component
Flip4Mac WMV Advanced.component
Flip4Mac WMV Export.component
Flip4Mac WMV Import.component
Google Camera Adapter 0.component
Google Camera Adapter 1.component



SET locale "enUS"
SET enterWorld "1"
SET hwDetect "0"
SET videoOptionsVersion "4"
SET graphicsQuality "3"
SET accountName ""
SET playIntroMovie "4"
SET mouseSpeed "0.89999997615814"
SET Gamma "1.000000"
SET readTOS "1"
SET readEULA "1"
SET showToolsUI "1"
SET accounttype "CT"
SET ChatMusicVolume "0.29999998211861"
SET ChatSoundVolume "0.39999997615814"
SET ChatAmbienceVolume "0.29999998211861"
SET VoiceActivationSensitivity "0.39999997615814"
SET Sound_MusicVolume "0.30000001192093"
SET Sound_AmbienceVolume "0.30000001192093"
SET terrainMipLevel "0"
SET farclip "1057"
SET particleDensity "60"
SET rippleDetail "1"
SET reflectionMode "0"
SET projectedTextures "1"
SET shadowTextureSize "2048"
SET textureFilteringMode "3"
SET realmName "Hydraxis"
SET gameTip "123"
SET repositionfrequency "0"
SET maxFPS "30"
SET preferredFullscreenMode "1"
SET Sound_MasterVolume "0.30000001192093"
SET weatherDensity "1"
SET uiScale "0.84999996423721"
SET useUiScale "1"
SET Sound_OutputDriverName "System Default"
SET Sound_EnableHardware "1"
SET g_accountUsesToken "1"
SET MovieRecordingAutoCompress "0"
SET maxFPSBk "25"
SET gxRefresh "60/1"
SET environmentDetail "50"
SET minimapTrackedInfo "136"
SET readScanning "-1"
SET readContest "-1"
SET readTerminationWithoutNotice "-1"
SET installType "Retail"
SET checkAddonVersion "0"
SET Sound_EnableAmbience "0"
SET MovieRecordingWidth "1024"
SET MovieRecordingFramerate "30"
SET iTunesTrackDisplay "1"
SET questLogCollapseFilter "-1"
SET advancedWorldMap "1"
SET Sound_SFXVolume "0.5"
SET Sound_EnableMusic "0"

MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act1_1280.avi) = 79ce0cbef2e72c216e58bd307ccc8482
MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act1_800.avi) = d9dd85a8631b560946d7de2e8788bf1c
MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act2_1280.avi) = c144fa5d5f5cefe12ffd8346a61df7bb
MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act2_800.avi) = a93e0dcaa792d6e2bf485376e2dc7a7c
MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act3_1280.avi) = cca5e324dc41e74659d62be2678baab4
MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act3_800.avi) = b7da95a4959dce40f40b38a1e5a3f6f0
MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act4_1280.avi) = 207493e5594c8e2d7aa916ddb8c700fa
MD5 (/Applications/World of Warcraft/Data/enUS/INTERFACE/CINEMATICS/DSI_Act4_800.avi) = 07a94b403cf824f44f236a00ba580d27

Same has happened to me, twice now, on the death of Deathwing cinematic. First time was last night (first time killing him, so I wanted to watch it) and it froze at the very end when it starts to fade out. This time I decided to hit esc, and it froze right away.

Both times I had to force quit and restart WoW. And both times I missed out on the loot. I even sent in a ticket, and they basically said "sucks to be you".

This is an issue that needs to be addressed. Both times I missed out on that damned sword I need.
If you are using AddOns, please read Omegal's post.

Klint P
Mac Tech Support for Blizzard Entertainment || Mon - Fri 1:45pm - 10:45pm CST
If you can't find it here, contact a rep direct : <---- Rate my Blue post here...
The important thing is not to stop questioning. Curiosity has its own reason for existing.
Yeah, or just use the /script posted in another post and put it a macro, just don't forget to hit it before you reach ultraxion.
Mac Tech Support MVP
Addon Author
This is my I've had the same install since 2008.

Can you just tell me what to chop out instead of creating a new one and having to fix my entire UI and nameplates again?

edit: I removed the glow and death lines from the and I was able to play the movies in Org without crashing, but I just crashed on Ultraxion on my hunter.

SET locale "enUS"
SET coresDetected "8"
SET hwDetect "0"
SET gxVSync "0"
SET videoOptionsVersion "4"
SET preferredFullscreenMode "2"
SET textureFilteringMode "2"
SET movie "0"
SET mouseSpeed "0.85000002384186"
SET Gamma "1.200000"
SET readTOS "1"
SET readEULA "1"
SET showToolsUI "1"
SET Sound_VoiceChatInputDriverName "System Default"
SET Sound_VoiceChatOutputDriverName "System Default"
SET Sound_OutputDriverName "System Default"
SET ChatMusicVolume "0.29999998211861"
SET ChatSoundVolume "0.39999997615814"
SET ChatAmbienceVolume "0.29999998211861"
SET Sound_MusicVolume "0"
SET Sound_AmbienceVolume "0"
SET farclip "727"
SET groundEffectDensity "64"
SET gameTip "123"
SET VoiceActivationSensitivity "0.39999997615814"
SET shadowLevel "0"
SET groundEffectDist "160"
SET ffxDeath "0"
SET readScanning "-1"
SET readContest "-1"
SET readTerminationWithoutNotice "-1"
SET installType "Retail"
SET OutboundChatVolume "1"
SET Sound_MasterVolume "1"
SET Sound_SFXVolume "1"
SET InboundChatVolume "1"
SET accounttype "CT"
SET projectedTextures "1"
SET componentTextureLevel "9"
SET screenshotFormat "png"
SET screenshotQuality "10"
SET gxWindow "1"
SET particleDensity "80"
SET specular "1"
SET iTunesRemoteFeedback "0"
SET ffxGlow "off"
SET realmName "Cho'gall"
SET playIntroMovie "4"
SET terrainMipLevel "0"
SET rippleDetail "1"
SET reflectionMode "0"
SET shadowTextureSize "2048"
SET showItemLevel "1"
SET ShowAllSpellRanks "0"
SET equipmentManager "1"
SET questLogCollapseFilter "-1"
SET nameplateAllowOverlap "0"
SET previewTalents "1"
SET uiScale "0.89999997615814"
SET showRaidRange "1"
SET bloatTest "1"
SET bloatnameplates "1"
SET spreadnameplates "0"
SET MovieRecordingWidth "800"
SET waterDetail "2"
SET Sound_NumChannels "32"
SET enterWorld "1"
SET useUiScale "1"
SET Sound_EnableMusic "0"
SET maxFPS "70"
SET repositionfrequency "0"
SET guildRecruitmentChannel "0"
SET minimapTrackedInfo "520"
SET g_accountUsesToken "1"
SET checkAddonVersion "0"
SET gxMaximize "1"
SET MovieRecordingGUI "0"
SET lastCharacterIndex "2"
SET ffxGlow "off" is useless, it isn't even a valid arg, it should be 1 or 0
few other ones i'm not sure of, as i can't rememeber if TOS or EULA is current one in use but i don't think both are in use. and some of those other options i'm not sure about either without looking them up. i don't think thee is anything there causing your problem with movie playback though
Mac Tech Support MVP
Addon Author
Can I put the ffxDeath back in? I never liked the death effects and I don't know why it isn't still in the options when it still responds to that command. I checked the md5 sums on the movies and they match what was given before, and I'm still crashing, so no idea what else it could be.
I've been having the same problem regularly since 4.3 (only in LFR, though, iot seems). The only way out is to restart the whole computer than log back into the game... and hope I'm still in the raid by the time I get back.

Fortunately, I just found this post which points out the new feature to disable the clips in DBM, which I've just turned on now.
So I have also had troubles with the videos after Ultraxion, Spine and Madness. I also had "SET gxApi OpenGL", and as of now removed it. I tested the scripts Omegal suggested for movie debugging before and after I had this in my, and wanted to confirm the problem persisted when I had this in my WTF file and no longer happens when I don't have opengl in my I can't test in a raid situation since I full cleared both LFR and normal, so I will update this post on tuesday when I do LFR and wednesday when I do our actual raid.

One question I would like answered is: If SET gxApi "OpenGL" was truly the problem, then I would like to know why this caused crashes to only sometimes (well, most of the time) happen as opposed to all the time. A little fix I tried to do was spam escape, which would cancel the cinematic, but sometimes I wouldn't even get the chance and it would auto-crash. If possible, a slightly dumbed down explanation would be great (I am not an expert as some people on this thread have proven to be, but im not an idiot).
I've been having the same problem regularly since 4.3 (only in LFR, though, iot seems). The only way out is to restart the whole computer than log back into the game... and hope I'm still in the raid by the time I get back.

an FYI for future, command-option-escape is the mac equiv of control alt delete. This will quit a frozon app without restarting computer usually, it's not the OS that's crashed just the app so all you have to do is kill source of problem

12/31/2011 11:55 PMPosted by Redgreen
Fortunately, I just found this post which points out the new feature to disable the clips in DBM, which I've just turned on now.

heh yeah people are digging it, even not withstanding the crash, the videos are cool first time or two.. 10 alts later the users are happy to be able to disable them :)
Just found this forum and thread and glad its not just me. I'd been kicked from a few lfr's this week because of this bleeping hang/crash on the cinematic transitions - mostly between the ship and the spine.

I was able to complete lfr's the previous couple of weeks without any issues. Just this week I gave up trying to finish it because I couldn't get past the crashes - and , yes, if the boss goes down while you are rebooting you get saved to it, lovely.

Anyway, something changed recently that maybe Blizzard can acknowledge and patch for everyone before this widespread issue becomes just another checkbox in the "Why cancel WOW" column.

I'll read through all of the posts and suggestions here when I get home and hopefully I will be able to complete lfr's this week !


We're still investigating this. The freezing is different from the crashes and we're still investigating both.
Mac Tech Support for Baaaaahlizzard Entertainment || Sunday to Thursday 11:00 am - 8:00 pm CST ---- Rate my Baaaaalue Posts. How's this sheep doing?
The Mechanical sheep formerly known as as TonyM!
If at first you don't succeed... call it Version 1.0..
I am having this issue too. My screen freezes when the movie starts after the first boss.
(Have MacBook Pro OS X 10.6.8)
[quote="38048486404"] If I switch quickly to "windowed" mode before the cinematics start, then I don't have the freeze / crash issue.

Yes -- I have never experienced a video "freeze" requiring a force quit when running in "windowed" mode. It only happens when running full screen.

In full screen, that first Deathwing kill was so anti-climactic when my WoW client froze, no video then missed the loot roll. :(

System Version: Mac OS X 10.6.8 (10K549)
Model Identifier: MacPro3,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number Of Processors: 2
Total Number Of Cores: 8
L2 Cache (per processor): 12 MB
Memory: 6 GB

Chipset Model: ATI Radeon HD 5770
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
ROM Revision: 113-C0160C-155
EFI Driver Version: 01.00.436

Resolution: 1920 x 1200 @ 60 Hz

Has anybody tested this out in the PTR and see if this still happens, like Padim suggested?
Mac Tech Support for Baaaaahlizzard Entertainment
Not finding what you need here? Contact a rep direct!

So, Thrall, Jaina, and Kerrigan are all sitting around playing poker…
Still having this issue myself.
Mac Pro

System OSX Lion 10.7.2(11C74)
Memory 4GB 800MHz DDR2 FB-DIMM
Graphics NVIDIA GeForce 8800GT 512MB
Model Identifier MacPro3,1
Processor Name Quad-Core Intel Xeon

Processor Speed 3.2GHz
Number of Processors 2
Total Number of Cores 8
L2 Cache (per Processor) 12MB
Bus Speed 1.6GHz
Boot Rom MP31.006C.BO5
SMC Version 1.25f4

Join the Conversation

Return to Forum