Did not receive the Charger Mount

Customer Support
I signed up about 2 months ago but did not receive the mount in the mail.
Same with me, what is going on? I even try and go back to do it again perhaps I misclicked but it says im eneligable
Do you have 2 or more accounts? Are you sure you signed up on the account in question?

Also Icyhot, did you just sign up within the last 72 hours? It takes up to 72 hours for the mount to show up (from when you sign up)
No I signed up a month ago :/ And yes I do have another account but it has been inactive for quite some time now, my wife also has an account as does my son but she got her mount.
11/29/2011 01:07 PMPosted by Ïcyhot
No I signed up a month ago :/ And yes I do have another account but it has been inactive for quite some time now, my wife also has an account as does my son but she got her mount.


You may want to check to make sure it wasn't applied to the inactive account. If that isn't the case and you indeed signed up a month ago, you may want to try calling the billing department.
11/29/2011 01:03 PMPosted by Velosis
I signed up about 2 months ago but did not receive the mount in the mail.


While I see a few pets purchased around 10/25 - I'm not seeing an Annual Pass, Velosis.
11/29/2011 01:04 PMPosted by Ïcyhot
Same with me, what is going on? I even try and go back to do it again perhaps I misclicked but it says im eneligable


Not seeing an Annual Pass on the account you are posting under, Icy.
Really? Why am I eneligble then, QQ ugh
Does it really take 72 hours? I just picked it up a few minutes ago and haven't gotten a mount. Orlyia could you confirm all is well with me? (only have one account).
I signed up I believe a month ago and I didnt receive a mount. My account shows that I can pre download Diablo also. Help please.
11/29/2011 01:13 PMPosted by Ramlin
Does it really take 72 hours? I just picked it up a few minutes ago and haven't gotten a mount. Orlyia could you confirm all is well with me? (only have one account).


Given this is brand new, all I can really pass along is what we've been told.

72 hours is the timeframe we were told on new signups, now....whether these may process faster as some things do, that I can't say.
11/29/2011 01:13 PMPosted by Ramlin
Does it really take 72 hours? I just picked it up a few minutes ago and haven't gotten a mount. Orlyia could you confirm all is well with me? (only have one account).


Yes:

http://us.battle.net/wow/en/forum/topic/3657435854#4
I have read all the requirements and I meet all of them :(
11/29/2011 01:15 PMPosted by Ïcyhot
I have read all the requirements and I meet all of them :(


Then you will want to contact Billing an inquire. If you were ever compromised and financial irregularities occurred (which btw, isn't unusual under those circumstances) that could be one cause Billing can investigate and possibly assist.
Okay great, My account has been compromised before so I will do that. Thank you for your time! :)
I just signed up earlier today. No mount yet...I guess it takes a while to process?
Any clue why my account hasn't had the mount awarded Orlyia? As soon as I saw the preview for the mount I signed up for it. Havent canceled or anything.
11/29/2011 01:20 PMPosted by Supdoods
I just signed up earlier today. No mount yet...I guess it takes a while to process?


As the Panda said, it can take up to 72 hours...

Join the Conversation

Return to Forum