"Blood and Thunder!" quest is stuck...

Bug Report
1 2 3 8 Next
This quest is broken and no further progress can be made in Vashj'ir on my character.

The Horde side Vashj'ir quest "Blood and Thunder!" is supposed to be finished when a "friendly" Naga abducts the player. After reading all of the comments on WoWhead, I can see that this has been a problematic quest before, but the last two comments both dated to Patch 4.3 mentioned waiting for 2 hours and still not being abducted. I'm not waiting 2 hours to find out that I wasted 2 hours.
I know its not ideal but dropping and reaquiring the quest until it 'works' has been helpful on an alt.
11/30/2011 06:42 AMPosted by Sunfury
I know its not ideal but dropping and reaquiring the quest until it 'works' has been helpful on an alt.

In Patch 4.3? I've dropped and tried it again twice. One of the WoWhead comments said that a GM suggested the same thing but when the player did it he still waited 2 hours and it didn't work.

I tried everything every single comment suggested.
Been stuck for approximately 90 mins at this point, put in a ticket - 21 hour average wait for the ticket. Makes me wonder why i'm paying for this.
Sorry wrong alt posting that, no matter though I guess. I have seen a long list of complaints on wowhead about this quest.
My Wife is having the same problem. Last night I tried walking her through the quest because the 2nd phase wasn't hitting, and I noticed that the guards' health isn't dropping at all. The 2nd phase is activated when their health gets low, and then Nazgrim tells you to escape because you're being overrun. So right now, you can kill all the naga you want, and nothing is ever going to happen because apparently 4.3 gave the guards the invincible buff.

At least, that's what I observed. Ticket was submitted, still hours to go in ticket queue.
Alliance quest "call of duty" for getting to vashj'ir is also broken. Ship doesn't even appear.
Now this is interesting - abandoned the quest, thought I could re-acquire and try again -wrong!
The NPCs wont stop fighting, so there is no-one to get the quest from, plus it would not let me log out or exit the game. Had to kill the wow window to get out.

update, was able to get the quest from the battle area. I can confirm that the guard health is not declining at all.
11/30/2011 08:53 AMPosted by Cenaria
Alliance quest "call of duty" for getting to vashj'ir is also broken. Ship doesn't even appear.

Actually, you can progress "Call of Duty" just by flying out to the Briny Cutter (I did this on the PTR)

However, the Alliance version of "Blood and Thunder!" ("All or Nothing") is also broken in exactly the same way.
11/30/2011 10:06 AMPosted by Boristus
the Alliance version of "Blood and Thunder!" ("All or Nothing") is also broken in exactly the same way.

At least we can't complain about faction imbalances. (:
Tried it just now. Felt like finally completing Vashj'ir for once on at least one of my alts (after at least 6 85s). It is stuck at the endless waves of Naga coming in.

Issue of Note:

Erunak not doing anything nor being attacked by naga. I will assume the trigger for the next "phase" was for him to attain a certain kill count or just... participate in any way. Since he does not do a darn thing, maybe that could be it. In any case, I remember Erunak doing stuff.

To Blizzard:

Do NOT disregard this issue! This is an entire zone in which players cannot quest. With the reduction of WOTLK experience requirements you can bet there will be many many more 80 alts trying out Vashj'ir as Northrend can be done in 5 hours.

Tried so far:
- Abandoning and retaking (5 times)
- Abandoning, zoning out, zoning in, retaking (1 time)
- Abandoning, clearing out all naga (lol blood DK), retaking (3 times)
- Waiting (endlessly)

Nothing works.
ive been here 2 days now waiting. ticketed a gm yesterday and got a reply. he said to try dropping quest till it works, which i did. try zoning out and coming back, which i did. now im at least 5 hours on this quest, with no results. oh gm also noted that because of all the phasing in the zone he wasnt allowed to touch or reset any of the npc's.

things to note:

like stated in the previous post, Erunak is not doing anything. when i previously completed this quest, he was actively fighting against the naga. there reached a point where he called out "we are beaten" then i was able to complete the quest.

edit: also forgot to mention 2 of the naga are getting stuck in the hull of the boat, one of them actually emotes like he is kidnapping you. but he attacks you instead of actually kidnappping you. after you kill him his respawn is about 7 min then same thing all over again.

The customer support forum seems to be a better place to track this issue as there are more official statements over there.

This looks like a known issue, and the answer given may not solve your problems but at least this other thread should help you track its progress.

Also having this problem. GM told me everything was fine with the quest. No matter what I am unable to get "abducted" or advance the quest in any way, even after hours of waiting. This is becoming quite frustrating when the GMs won't even listen and I'm unable to advance my character in Cataclysm at all.
I too am having a problem with it, I had hoped for easy breezy up to 85 and try out the dungeons I haven't gotten to experience yet and content I paid for in an expansion pack that I now can't enjoy. Thank you blizzard you have showed me I should've spent my hard earned money elsewhere such as with Trion or Sony.
I dropped the quest after not being able to begin the abduction sequence. I can't re-acquire it. The Immortal Coil didn't reset and there is no quest giver. :(
EDIT: Also, my Cache is empty.
EDIT: I have emptied my (already empty) Cache folder twice. Abandoned and reacquired the quest four times. Logged out successfully once, Alt-F4 exited three times (can not log out while in combat). Still no progression.
My wife and I are at this quest too and no health is going down on any of the NPC's.
as of 11 p.m. eastern, it is still bugged. the npc health stops dropping at 26292 hp. all i want is the mount for herbing :(
Good and bad news, folks.

Original post by Vrakthris:

Vashj'ir Quests:
We are aware of an issue with several Vashj'ir quests, including Call of Duty, All or Nothing, and Blood and Thunder!. Issues associated with these quests are being looked into and we hope to have resolution for them as quickly as possible. Unfortunately, we have no workaround.

Fix please. Leveled 5 characters, my 6th is unlucky enough to be stuck here with the rest of the folk above. Makes me want to break something but apparently this quest is broken enough as it is.

Join the Conversation

Return to Forum