"Blood and Thunder!" quest is stuck...

Bug Report
Prev 1 2 3 4 8 Next
I'm stuck also. There is another player trying this at the same time and seems to be stuck also. I've abandoned and restarted this quest several times.
12/01/2011 03:13 PMPosted by Drtrae
This thread needs locked before people start raging. Everyone knows about the bug, and Blizzard has stated that they're working on it. Now stop the QQ and Blizzard hate, and go to Hyjal.

For a bit I was interested in doing a Herald of the Titans run, so my character cleared Hyjal with XP off. I ran into the Vashj'ir problem when I decided to start leveling again.

So, for me - the guy that started the thread - it was initially about being blocked from doing any further Cataclysm questing and hoping for a quick solution. I wanted to keep the immersion going... instead I did the same two dungeons again and again and again. Some people like that. I would have preferred the underwater adventure.

Don't you try to lock mah thread, boy.
The alliance counterpart to this "All or Nothing" was bugged as well....I just logged on...looks like about 40MB mini-patch downloaded. After that happened, I went to Vashj'ir, tried again, and it finally worked! Hopefully you all have the same luck.
Obviously, this isn't a priority. It sounds like they screwed with the NPC dodge and parry figures, because Nazgrim never gets below 90% damage, and the shaman never even engages the fight.

GG Blizz, Fix it already or credit my account for the days I have waited for this issue to be resolved. And no, I won't go to Hyjal just because Blizzard cares more about in game pets than fixing a quest that keeps you from progressing in a zone.

Call me a whiner all you want, it's the damn principal of the thing. Even CCP listens to their gamers more than Blizzard for effs sake.
I had the same issue when I came here... It bugged for me and refused to progress.

I put in a ticket, which said it would be over 3 days waiting on the ticket. After 2-3 hours, a GM contacted me, asked me to log over to a different alt, and they could progress it for me.

When I logged back over to see the progress, I just had to swim over and turn in the quest. All good now!
Quest keeps resetting.
Been on this quest all day. 2 hours then switched toons for awhile and checked back every now and then. having the same problems......nothing i have tried has fixed it.....opened a ticket hours ago and the wait time on my ticket hasn't even changed.......hopefully it gets fixed soon cuz from what I have been told Mount Hyjal quests are acting up too so where now to quest at........
I haven't heard of any issues with the Hyjal quests, Erihpas. They are working on a fix and until it is deployed you can't complete the quest without GM assistance.

Original post by Vrakthris:

Vashj'ir Quests:
We are aware of an issue with several Vashj'ir quests, including Call of Duty, All or Nothing, and Blood and Thunder!. Issues associated with these quests are being looked into and we hope to have resolution for them as quickly as possible. Unfortunately, we have no workaround.

Yeah ran into this issue too... GM said they are working on it.
Been doing this quest for about three days... nothing's happening. It's patch 4.3 this never happened with my hunter T.T
I'm having the same problem, a GM suggested I try again and stick to the middle of the fight, as if you swim around killing Naga it resets, but it still didn't work. I was told that they have the issue with the game developers and are working on it, so it's just a matter of waiting till it's fixed.
I have seen countless posts from this forum and on wowhead, where a GM simply advanced the quest. The only other time I had a problem quest like this, a GM advanced the quest. I have an alt there, for 2 days trying to complete this quest. I do not want to lvl him, I want to herb Vash - and that will be kinda hard to do w/o the seahorse. I spoke to a GM who suggested clearing my UI by deleting WTF and Cache folders. Why wont blizz just fix this quest, its only been broke for 10 months according to the wowhead posts.

Please please please Blizz, fix this quest. Or just advance it for me, I wont tell I promise.
Same here, im trying to quest vash'jir and im stuck here with nothing happening. sorry to inconvenience you guys, but i would like to finish off vash
ridiculous that blizzard hasn't fixed this quest yet, you'd think fixing a quest that completely breaks an entire cataclysm zone would be a fairly big priority for them. I want my god damn transmog robe.

opened a GM ticket 4 days ago too and still haven't gotten any kind of response.
Yeah this is getting annoying. They could at least give us an ETA of when it would be fixed.
This is day two trying to finish this quest... I have not heard any message of surrender or seen any Naga to abduct me.... So, What do I do from here?
Just got a ticket to report my problem with this quest... Average wait time, 4 days, 8 hours. WTF! I am really getting frustrated with this!

I put in a ticket 2 days ago to have the quest manually moved forward for me. 6 hours ago I logged out in Orgrimmar.

I just logged back in and my character was parked in Vashj'ir in front of a yellow question mark.


cant finish this quest on my druid, spent like over an hour killing naga - didnt die because bears self healing is ridiculous but nothing happened... what a waste of time, opened a ticket hopefully blizzard does something about it.
my down syndrome cousin can program better, poor effort. just wipe it

Join the Conversation

Return to Forum