Slow loading screen since 4.3 patch download?

Technical Support
I'm having an excessive loading screen issue, it'll get to like 95%, then take another minute to reach 100% (at which point guildies can see me online), then another 15 seconds before I can see the game world and move.

I recently added another hard drive, which I installed the PTR client on and never had the problem there. I also tried to download another copy of the game client to the other drive to try to get a fresh start and maybe fix this problem. However I haven't gotten that working yet.

I'll be uninstalling the game on the old hard drive now, and working on getting the new install up, and I'll get back with an update then.
So am I, its killing me..

95% then stops
Mine has been doing this too at least I'm not the only one.
Same thing's happening for me except it's taking more like 1+ minute to load
Yup, me as well. Even since 2-3 weeks before 4.3 came out, when i would assume when blizzard has given a little update to prepare people for that. My loading bar for everything, bg's instances, raids and zone switching. It's been pretty awful. Also recently wiped my computer clean reload windows on the computer just before 4.3. Really don't wanna go about doing that again, having the prt as well. I just hope blizzard catches on soon and maybe find out what is causing this issue. As i'll have to agree with Tally, when i was on the PTR i never had such loading issues. Ended up copying my main over and play on that till the 4.3 release in hope of the loading to be fixed. Still nothing tho.
I try to make a character on an RP server, and it only reaches 5%, I wait an hour, NOTHING! I'm sick of Moongaurd, seriously...
I too am having the issue where my loading screen bar hits 95% and halts for seems to be from about 30 seconds to a minute, have tried without all addons and same thing exists
It's all loading screens, including startup, dungeons, battlegrounds, zoning, etc. It's really annoying, since I used to have <5sec loading screens.
same problem this sucks!
bump again.....
Same issue...and getting worse daily.
bump again
Swagcapped, have you removed the Interface, Cache, and WTF folders from the World of Warcraft folder? That will return everything back to defaults, and might help.
Support Information
If the Forum isn't helping, contact a Support Rep directly:
'There's an old saying about those who forget history. I don't remember it, but it's good.'
yeah i have like 5 times even did the repair everything nothin works :(
Same here and getting worse every day :(
Same here, been happening for a while but got worse when 4.3 hit.
Yea, same issue here.

Join the Conversation

Return to Forum