WoW Installer (WoW-4.0.0-WOW-enUS-Installer)

Technical Support
The World of Warcraft Installer simply does not install the game client.

I run the program as an administrator, click Install, accept the EULA, select my language (English [US]), and click OK with the default installation location of C:\Program Files (x86)\World of Warcraft\ and the Create shortcut on desktop option checked.

At 2%, without fail, I always get this message:

The installer was unable to read the file "World of Warcraft\Wow.exe". This error may be caused by problems with the media or drive at <unknown> --for example, a scratched or dirty CD-ROM/DVD-ROM, hard drive corruption, or a networking problem while downloading the installer. (The error code was 0.) : DecompressJob::Execute()

I have tried everything I've found from Google, which includes all of Blizzard's own technical support pages.

Here's my hardware:

Windows 7 64-bit
Intel Core i5 760 @ 2.8 GHz
4.0 GB DDR3 1600 MHz RAM
NVIDIA GeForce 280 (1 GB of video memory)
1 TB SATA hard drive
Creative X-Fi Audio Processor

Relevant software:

Microsoft Security Essentials
Spybot - Search & Destroy
Google Chrome

Now, I will only ask for one thing here - I ask for help in installing the game client, and in doing so I request that you do not waste my time by asking me to defrag my hard drive, making sure drivers are up to date, disabling my antivirus, running chkdsk, and etc. These things have already been done (and would not affect the download or installation of a program anyway).

I would also like to note that I did successfully install the EU client, but could not log in because of the regional difference. After deleting all WoW references from disk (including the registry) and properly downloading the US version of the Installer again, it fails at 2% with the warning I pasted above.
Downloading the install file from

worked just fine. To the best of my knowledge, the link points to an older setup file, which works, and automatically updates itself. Then it downloads the client with no fuss.

Since this older version works, as does the current EU version, I am left thinking that the latest US client is flawed.
Thank you! The current installer is definitely corrupt.
Thanks Celothus. The link you supplied from mediafire worked for me as well. I just completed a custom build of my system and I needed to reinstall WoW. The current link from Blizz is not working. I received the same corrupted error everyone else got.
Hi all,

I'm having a similar issue. I'd download the game client installer from, the launcher starts downloading updated patch tools, it'd download game data up to SETUP (red) then tell me my game is damaged and I need to run repair.

I run repair, it completes, then run the launcher again and the cycle repeats.

The Mediafire link helps, thanks Celothus. Hope Blizz would investigate and fix this rather than have people depend on installers from non-official channels.

I also face the same issue as Sylinfel, and mediafire link also help me. Thanks Celothus for giving such a great help.

I hope everyone having same problem can see this topic
You do realize that this thread is from 2011? We're now onto Patch 4.3.2.
I downloaded this link and it just starts up and takes me right to my optimizer...then it says...UPDATER TIMED OUT.....FML

Join the Conversation

Return to Forum