quest -Return Fire

can any one tell me how to work the astranaar throwers i cant finsh this because i cant seem to aim at any thing
It's been some time since I did this quest but have you tried aiming by holding down your right mouse button and moving it? If it doesn't work, get out of the thrower and then type /reload or exit the game and then go back in. Also, check to make sure you don't have any addons active that might cause trouble with your interface.
thanks i will try it
I'm so glad you two asked and answered this question! I had no idea, this is the first time in the game I encountered shooting something and there was no instruction, at all, on how to do it. I tried everything I could think of before I decided to look on here.
Oh god thank you, I've abandoned this quest like 5 times because i thought it was acting stupid, it was just me :P
I also want to thank you for asking about this because I was just about ready to give up when I decided to look in the forums to see if anyone had any advice on how to do it.
Thanks for the tips, stuck on it now
still cant figure it out
So I've got a Mac and I tried right clicking and everything but I still can't get the throwers to aim. Any advice?
Thanks for the tip! I reloaded and abandon the quest twice before looking here.
I still cant figure it out. And I'm on A DELL laptop. Its drving me mad
Read the forum notes and I just tried the right click and aim. I have a Mac and it works. Shooting the little buggers down now.
I read the comments and still unable to aim :(
that worked! also on Mac :-) phew

Join the Conversation

Return to Forum