having problems connecting the us.battle.net

Website Bug Report

I and one of my friends are having problems connecting the us.battle.net website in this couple of weeks. We both were able to access the website without any problem before but we cannot access it now. I seldomly have connection to the website and my friend cannot access at all now. We've deleted cashe and temporary files of the website browsers and tried several browsers, but this did not help.

We have contacted the internet service provider companies (we are contracted to a different company), but they both said that no change on the settings were made.

When trying accessing the website, I get the below error messages.
(however we use non-English browsers so the words might not be the same. Sorry for the inconvenience.)

On Firefox: Not connected properly
On Internet Explorer: Internet Explorer cannot display the webpage

On Firefox: The connection was reset
On Internet Explorer: Internet Explorer cannot display the webpage

Hope you could help us. Thank you in advance.
I'm actually having the same problem. I normally play in Tokyo, Japan.

Tokyo, ISP = Not Ok
Anywhere in Japan, 3G = Ok
Osaka, ISP (ISP probably different from Tokyo but I don't know for sure, it was a company rented apartment) = Ok

I'm now on holidays in Malaysia and I have no problems accessing us.battle.net, which explains how I can post here.

Much appreciated if Blizzard could clarify and solve this issue.
Your ISP is blocking your connection. There's not much Blizzard can do about that.
I already talked to my ISP. They assure me it's not their side.
12/30/2011 06:06 PMPosted by Razek
I already talked to my ISP. They assure me it's not their side.

That doesn't mean much of anything, especially if you just talked to the first person who answered the phone; they are front line technical support people and don't usually have anything to do with actually sorting out issues with the ISP's own network or third party networks.

That said, if you want assistance from Blizzard with sorting out your ISP, I suggest you post in the Technical Support Forum here.
I actually did a network trace. My PC will try to establish a connection towards us.battle.net but the website seems to reject my connection and send out TCP RST. I think my ISP is giving me the correct info when they mention that the problem seems to be caused by an IP filter on us.battle.net.

Thanks for your suggestion. As I'm having a website issue and not a WoW issue, I'd thought that this is the correct forum.
Thank you Raimondas for your suggestion. When we posted a ticket to Blizzard, they said to post the issue here. Our ISP also said that they have not changed their regulations or whatever you call them... Same with Razek, we tried trace route but could not get connection to the us.battle.net website.
Any updates on this, Blizzard? If my source IP is 118.x.x.x, 122.x.x.x and 123.x.x.x I can't reach us.battle.net website. I do not get re-directed, I just get timeout.

Firefox message is "Unable to connect" and "Firefox can't establish a connection to the serverat us.battle.net".

Internet Explorer message is "Internet Explorer cannot displaythe page".

I have no problems logging in and playing WoW. Only the website is giving me problems. I'm accessing this forum using 3G on my iPad. I can't access this forum if I use my fixed Internet connection. I checked with my ISP and they say Blizzard is setting an IP filter preventing me to access the website and recommended that I talk to Blizzard. I raised a ticket, re-opened it 3 times and called customer support. Customer support recommends posting here to get some attention.

In summary, an update and a fix for this issue is MUCH appreciated.
I'm also from Tokyo, Japan and having the same exact problem as Razek.

Connected normally through my computer and I cannot view the websites

However using the same computer with a proxy it works fine (how I'm writing this now). Also my phone from a 3G network is also fine.

Thankfully there's no problem connecting to the game servers.
If you're having this issue, can you post the results from running traceroute while connected to the offending ISP?

1. Click the Start orb.
2. Type cmd in the run/search box and press Enter.
3. In the command prompt window, type in:

tracert us.battle.net

4. Paste the results here. Copy and paste is a little weird from the command prompt window, so watch carefully what you do.

Mac users should open Applications > Utilities > Terminal, and type the following command in the Terminal window:

traceroute us.battle.net
I'm not too knowledgeable about how the internet is all connected, but isn't it also a little weird that eu and kr realms also don't work?

Tracing route to us.battle.net []
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms buffalo.setup []
2 5 ms 5 ms 4 ms
3 5 ms 5 ms 5 ms
4 7 ms 6 ms 6 ms
5 5 ms 5 ms 5 ms
6 5 ms 5 ms 5 ms
7 14 ms 14 ms 13 ms ae-5.r21.tokyjp01.jp.bb.gin.ntt.net [129.250.11.
8 117 ms 110 ms 111 ms as-0.r21.lsanca03.us.bb.gin.ntt.net [
9 117 ms 111 ms 126 ms ae-2.r07.snjsca04.us.bb.gin.ntt.net [
10 121 ms 120 ms 120 ms ae-0.att.snjsca04.us.bb.gin.ntt.net [
11 114 ms 128 ms 124 ms cr2.la2ca.ip.att.net []
12 123 ms 127 ms 119 ms cr1.la2ca.ip.att.net []
13 124 ms 124 ms 117 ms gar20.la2ca.ip.att.net []
14 127 ms 125 ms 127 ms mdf001c7613r0004-gig-10-1.lax1.attens.net [12.12
15 127 ms 127 ms 132 ms mdf001c7613r0004-gig-10-1.lax1.attens.net [12.12
16 reports: Destination net unreachable.

Trace complete.

edit: did a tracert from a windows machine as it's easier to read
That looks about the same as my traceroute and I'm here in the US having no trouble at all connecting to the website.

(Oh, and I find the Mac/Unix version much easier to deal with :)

I find it quite unlikely that Blizzard would have just banned a whole IP address range outright, especially one as large as a whole country (and 122. covers several countries). I suppose it's possible though.
I'm able to change my IP through my router and what Razek said seems to be true. Changing no network settings and both my windows and linux machine cannot/can view the webpage based on my IP.

Currently I have no problems with a 114

01/07/2012 09:26 AMPosted by Razek
Any updates on this, Blizzard? If my source IP is 118.x.x.x, 122.x.x.x and 123.x.x.x I can't reach us.battle.net website. I do not get re-directed, I just get timeout.

Is there a solution to this problem?

I'm also in Japan and I'm having the same problem.
I can't connect to http://us.battle.net, as well as running Wow using Launcher.exe results in an error.

I can login to Wow by running Wow.exe but I will not get the latest patch because Launcher and Downloader has an error.

This is my tracert - http://i1084.photobucket.com/albums/j405/ticklesme/tracert.png

I've been experiencing the same issue as of about a two weeks ago. My browser times out when connecting to any battle.net website.

I have no problem running WoW or Diablo but can't access my account settings, forums or reinstall any of the games I've purchased.

My provider is NTT here in Tokyo. I have no problems accessing other sites and can reach battle.net via VPN or a proxy.
According to my ISP the domain is not being blocked and I've had no problem loading the site for the past three years.

I'm not sure what had changed but I get the same error connecting from multiple computers, an iPad or an iPhone.

Any advice would be greatly appreciated.
Dear Blizzard,

This is a serious problem affecting your playerbase. You're not getting many reports about this because it's friggin' impossible to contact you. We CAN'T connect to your website!

I'm typing this on my iPad using my mobile network. Using my home Internet connection in Japan which is provided by OCN, I won't be able to access this forum and type this message.

I'd like to repeat. There are many others affected by this issue.



Please fix this issue. It's your end, not ours.
Having the same problem here in Taipei. Can log into my games (WoW and D3), but can't connect to the us.battle.net or eu.battle.net websites. Was working fine the last time I had visited the site a month or two ago, but I've been trying for about a week now with no luck. VPN got me through so I could post my complaint.

tw.battle.net works fine without VPN but that's not helpful for me, seeing as I'm an American visitor in Taiwan and I can't read Chinese... :P
Yeah, still having problems out here in Japan. Able to access the site now, but can't get past that wonky new (?) Captcha deal on the bottom. Can logon from my network at work, though.

What the whaaaaaaaaaat...
Has a fix been mentioned? I have a friend living in Tokyo that really wants to transfer toons to another realm. Blizz is losing money not addressing this.

Join the Conversation

Return to Forum