World of Warcraft *4.3.4* 64 bit client

Technical Support
Prev 1 49 50 51 55 Next
2x Crossfire AMD 7970HD's - newest CCC available . 12.4 beta 2012.0315.1621.27344
Win 7 Ultimate 64 bit - all updates up to date

When I crank the water effect up to ultra, it stutters, so I set them setting down to high, clears that stutter, now the opposite happens to the shadows, shadows on High, they go like a flashing light show, crank them up to ultra, they work fine.

I may be mistaken, but you're complaining about video issues on an in development game client while using a beta video driver. Try using the latest release drivers and see if the issue persists. Newest drivers aren't always better, especially if they are still flagged as beta.
I don't know what happened but, when I played in 32 bit my fps were from 35-48 in orgrimar, but when I installed 64 bit (supposed to improve my speed or something like that) I just reached 25-35 fps, my cpu perfomance decreased wtf? did I do something wrong?
I have 6gb ram, OS win 7 ultimate 64, ATI hd 5450 Intel Core i3...
I installed it according to the guide...
Yes. I am on a MacBookPro 10.6.8. Have you found out why you have had problems?
hi i have no idea where my account has gone. I did some patch thing and now it says ive restarted my account and i have to make a new guy. I really want my old one back please!
Downloaded it a few mins ago and so far experiencing 0 problems. Not a huge gain but then again I'm using a pretty sick cpu to begin with.

i5 2500k@5ghz@1.42 vore
MsiZ68a-GD55 Military Class II board
Evga 470GTX@775/1552/1705Mhz clocks
Hyper 212 cooler
Corsair 650 watt psu
G-skill 1600mhz Ram 2x4gig
Intel SSD 120gb 3.0
Antec 300 case
Samsung XL2370 1920x1080 (native)
How do I switch it from 64 to 32.

I right click my Wow icon on my desktop that says WOW-64 under it, I select run as admin now I get my login screen where I can enter my account and password. THERE IS NO BOX TO SELECT 32 bit.

If i select the options bar on the bottom right hand corner theres no preferences tab, and no box for 32 bit.

If I try to login I get an error saying " there is a problem logging in"

version from the bottom left corner is 4.3.3 x64

What am I doing wrong?
How do I switch it from 64 to 32.

I right click my Wow icon on my desktop that says WOW-64 under it, I select run as admin now I get my login screen where I can enter my account and password. THERE IS NO BOX TO SELECT 32 bit.

First, please verify that you have the 64-bit client installed correctly. Those direction were listed in the same post that allowed you to download the client. Assuming that you did follow those directions properly, you should not have any login issues.

Now, as for switching back to the 32-bit client, the previously mentioned forum post should also be telling you to check the Game Preferences under the Options menu in the Launcher application.
I've noticed 0% change from using 32 bit to 64 bit. :(
was there any recent changes to the client cause for some reason my 32bit client works fine but my 64bit crashes when it starts up and i have no clue whats wrong with it haven't changed anything even uninstalled and reinstalled twice and it still crashes if it wasn't a difference between the 2 i wouldn't care but since the 64 runs better i would really like to fix it
If I ever have google chrome open, I get a WoW error upon launching the game. Only ever does this happen if I have google chrome open though. I have yet to have this issue with any other program.
This is an excellent little upgrade. I'm getting roughly 10+ FPS more. Raids are running "better" but they're still rubbish. 17fps in Raids at my usual settings (all Ultra), 60fps everywhere else. Probably the best I'm going to get out of my processor though.

AMD Phenom X4 9550 BE
GeForce 9800GTX+
Windows 7 Ultimate x64
loving the wow 64 bit client its freaking awesome.
only noticed 2 things that need attention.
when graphics are set beyond ultra with console commands the water bugs out a bit in 64 bit and does not in the default client.
the other thing is no matter how hard i try i cant get eax to work with 64 bit.
4/11 15:11:37.958 - Setting Software Format (44100, 2, 2).
4/11 15:11:37.958 - Requested 64 channels.
4/11 15:11:37.958 - Initializing Hardware Channels
4/11 15:11:37.958 - Sound Driver Reports: 0 Hardware Channels Available.

this could be caused by my inability to set wow-64.exe to windows xp sp3 compatibility mode.
Just installed the x64 client. Feels like whole new game! Was a much needed feature.
Awesome work Blizzard!
I am thinking Blizzard should initiate a Beta testing for a 64bit Pandaria:))) Is there such a thing that exists?? Maybe we should volunteer.... ANyone else interested????
Been having graphical issues with WoW since re-install for Cata, graphical tearing and vanishing textures etc (weird things too like characters hair floating above their head). Display driver crashes you name it. Only happens with WoW, no other games ME3 runs perfectly, Crysis 2, tried pretty much everything in my Steam library, no issues, anything you can name my hardware runs on maxed settings without a sweat, even the supposedly intensive Metro2033...

Yet only WoW turns up these problems, tried rolling back drivers, re-installing drivers, changing settings(works for a little while then the issues creep back), now running the 64bit client, no joy.
Current hardware:
i7 950@3.07GHz
12Gb RAM
2x nVidia 580GTX (obviously only 1 is actually doing any work) 296.10 drivers
Win7 Ult. 64bit
The hardware is more than up to running WoW.
At the point of quitting. Any ideas?
Is there an easy way to do a fresh install with the 64-bit version?

Join the Conversation

Return to Forum