World of Warcraft *4.3.4* 64 bit client

Technical Support
Prev 1 5 6 7 55 Next
Got and put the client in the wow folder and ran it, runs very nice but I noticed that Wow64 Now seems to only use one of my video cards, and I run two Nvidia's 480's SLI (EVGA) and looking at my G19 LCD screen only one is actually under load now, when ussally its two (I am using EVGA precision to monitor the GPU's in my LCD screen)

Wow is set to Dx11, everything else is fine, all nvidia drivers are updated, is there something that I might be missing, or need to change?


Looks like we're going to require new profiles from nvidia, which considering this isn't even an official executable might not happen for a while. I've been trying for a while now to modify the SLI profile and hack in SLI functionality but to no avail. If anyone has working setting_id and hex values for SLI on the 64 bit exe please let us know.
64 bit client works very badly with fraps.

If you have fraps recording and try to switch from full screen to window or window to full screen. Wow starts to flicker or crashes. Very nasty.

So be sure you stop recording before you switch modes.
Just for the record here is what was in the 32 bit version but removed in the 64 bit one (Mac specific and is limited to the names of files exposed in the binary itself but should give a vague overview of the changes)

You can extrapolate from it that file I/O, object allocation, openGL, and Divx were significantly changed.

/../../../Storm/Source/SStr.cpp",
/../Glue/../WowSvcs/WowSvcsClientServices.h",
/../Net/NetInternal.h",
/../ObjectAlloc/IObjectAlloc.h",
/../../../Engine/Source/Base/CDataStore.h",
/../../../Engine/Source/Base/Status.h",
/../../../Engine/Source/Services/AsyncFileRead.cpp(645)",
/../../../Engine/Source/Services/AsyncFileRead.cpp(237)",
/../../../Engine/Source/Gx/CGxDeviceOpenGL/CGxDeviceOpenGl.cpp",
/../../../Engine/Source/Gx/CGxDeviceOpenGL/CGxOglShader.cpp",
/../Object/ObjectClient/Player_C.h",
/../../../Engine/Source/SoundEngine/fmodex/src/fmod_memory.cpp",
/../../../Engine/Source/SoundEngine/fmodex/mac/src/fmod_os_cdda.cpp",
/../Ui/UILCD/LCD.CPP",
/../Ui/UILCD/LCDLoad.cpp",
/../../../Engine/Source/lgLCDMac/EZ_LCD.mm",
/../../../Engine/Source/lgLCDMac/EZ_LCD_Page.mm",
/../../../Engine/Source/DivxDecoder/DivxDecoder.cpp"
Correction on what I said earlier, forcing AFR1 or AFR2 mode seems to enable SLI, but ideally new nvidia drivers will implement proper SLI profiles at some point.
Upgraded to the 64-bit client. Works great for me, except for one, very strange, issue.

My addon memory usage jumped about 33% in total with most addons jumping in the 25-40% range individually. Given that some people are complaining about addon settings behaving strangely, I think you might want to check how addons, in general, are working with the 64-bit client. It sure sounds as if something is up.

EDIT
No doubt there's a 5-10 FPS increase, though, as something positive!
64 bit client works very badly with fraps.

If you have fraps recording and try to switch from full screen to window or window to full screen. Wow starts to flicker or crashes. Very nasty.

So be sure you stop recording before you switch modes.


Why would you do that? i have a feeling thats more to do with the fact that your changing the screen modes then 64bit as i just tested recording and it runs fine.

As for 64bit its looking like something of a 5-15 FPS increase.
02/01/2012 11:19 AMPosted by Pbad
Correction on what I said earlier, forcing AFR1 or AFR2 mode seems to enable SLI, but ideally new nvidia drivers will implement proper SLI profiles at some point.


This got SLi working on my end, i'll keep looking about to see if there's any other better way to get them working, cause i've never used AFR1 or AFR2 modes.
Still cant log in... Checked all settings, says x64. I can log in when I open the 32 bit version but still no luck with the 64 bit. I get the pop up... "there was an error logging in. Please try again later." Etc... I have been trying for the last 2 hours. I am also running WOW on a separate SSD HD.. Wow is the only thing running on there.. but I did make sure that the update was unzipped into the right folder



EDIT: I do have an authenticator.
Works now...also had to move folder to program files...as opposed to x86
I am not seeing a "Preference" option in the options window... which means i cannot switch between clients it seems...

edit: Never mind i just checked the launcher itself and found it...
has anyone seen any noticeable improvement in FPS during raid settings? I am running a phenom quad core with 6 gig of ram and a gtx 460 gpu yet i was getting pretty poor frame rates during stacks phases in 25 man raiding...

anyone had a chance to test this yet in a graphically intense environment yet?


I did LFR a couple of times, and I can certainly say it's a very noticeable performance increase 10+ fps. So it's not a placebo thing.


OMG! I just got to actually see the effect from Morchok's Earthen Vortex for the first time ever! I'm running an AM2 Hex-core (2.8GHz) with 6GB of DDR3 RAM. My FPS has always plummeted as he casted it, and I "jumped" to right on top of him. Haven't noticed any bugs since I was able to log in this morning, but I'm stoked the game can finally take advantage of the hardware in my system! ^_^ Thanks, Blizz!!!
02/01/2012 11:31 AMPosted by Gotnorice
Correction on what I said earlier, forcing AFR1 or AFR2 mode seems to enable SLI, but ideally new nvidia drivers will implement proper SLI profiles at some point.


Have you tried simply renaming the "Wow-64.exe" to "Wow.exe"? That certainly helped with crossfire.


If you do that, I can almost guarantee that you will have patching problems if you don't revert before hand, and the repair tool may freak out as well.

Be prepared to reinstall if something bad happens.
I am not seeing a "Preference" option in the options window... which means i cannot switch between clients it seems...

edit: Never mind i just checked the launcher itself and found it...


yeah, we all mentioned several times, it's in the launcher options.
02/01/2012 11:49 AMPosted by Ukiebe


Have you tried simply renaming the "Wow-64.exe" to "Wow.exe"? That certainly helped with crossfire.


If you do that, I can almost guarantee that you will have patching problems if you don't revert before hand, and the repair tool may freak out as well.

Be prepared to reinstall if something bad happens.


^^^ That is exactly why I did not rename anything, and I'm running fine. People just need to learn how to extract and place files in proper folders, or on another hand, if you have no idea how to do stuff like this, then don't do it.
Definitely think the x64 client is a homerun!

In addition to the improved over-all smoothness of the game, I have noticed a slightly better ui responsiveness when clicking action bars via mouse-clicks.
My Steelseries Zboard does NOT recognize Wow 64bit client atm. Submitted ticket to Steelseries as it may require a new driver.
I just got into an AV, I alt tabbed to look at the Tech Forums to see any news about 64 bit, I saw it was released, I screamed like a little girl, I looked at a wall in AV, was getting 170 FPS, I force close the game, I download the client, run it, load in again, looking at the same wall I'm getting 205 FPS.

Great FPS boost and the game looks slightly better as well! The shadows look darker than before or something, the game runs a lot smoother.

Thanks Blizzard, love your faces =)
Hi there blizz. Thought id let you know everythign was running fine. then i tried to hearth from deepholme to Org and the 64 bit client crashed. when i try to log back in it tells me there is a problem with trying to log in. Plz try back later.

Join the Conversation

Return to Forum