World of Warcraft *4.3.4* 64 bit client

Technical Support
Prev 1 6 7 8 55 Next
Hooray for 64 bit! All is working well on my end, I'll post back if I have any issues. Thank you very much!
It keeps telling me "There was an error logging in. Please try again later." What does that mean?
So far it's working swimmingly on my MacBook Pro (2010 model)

The interface lag is very much so reduced. Awesome!
K i found a bug, Go to Options then Advanced and in Max Foreground Fps seems to be broke a little i can't seem to set it at 70fps. It's Between 50fps and 100fps only. Please look into it.
So this only works with the american client? It can't "validate game version" on the EU client installation.
02/01/2012 12:31 PMPosted by Taroo
It's Between 50fps and 100fps only. Please look into it.


Do you have vsync enabled? Mac or PC? It's working on my Mac but your vsync may interfere with it as well.
I cannot alt tab with the 64bit client. I get a critical error message every time. I have a PC, running windows 7. I noticed tabbing out took a few seconds to load, when before it was instantaneous. Tried running in 32 bit again, still get a critical error message when I try to tab back in.
Using PC Windows 7. Yeah vsync works i get 60fps with it on , but Max Foreground Fps seems to be broke between - 50fps and 100 fps cause cant get anything in between those too.
everything is cloudy for me even on ultra settings, revert it back to 32bit and its clear as day
02/01/2012 12:37 PMPosted by Taroo
Using PC Windows 7. Yeah vsync works i get 60fps with it on , but Max Foreground Fps seems to be broke between - 50fps and 100 fps cause cant get anything in between those too.


Try turning vsync off and see if it works... it may be that it's syncing your FPS to your refresh rate and limiting how maxfps works.
MBP 2010 here.

FPS dropped, addon usage went up by almost 13Mb, screen stutter got terribad.

On the other hand, it uses less CPU and less RAM than the 32bit client and it's indeed faster on loading everything.

Overall, it works, but I'm sticking with the 32bit until graphical issues has been solved for all machines (my Mac uses integrated video. If WoW 64 is using less RAM, I should have increased video performance, not decreased, in theory. I know theory does not always work on the real world).

I do see potential on this client, though.
nvm im retarded, had to fix my res
*sniff* I love you guys. Thanks so much for the 64bit. <3<3<3 Running beautifully. *dorky grins*
02/01/2012 12:36 PMPosted by Influence
I cannot alt tab with the 64bit client. I get a critical error message every time. I have a PC, running windows 7.


I alt tab fine
Nevermind, it's working now.
Can't get the keybinds on my wow mouse to work with the 64 bit client. Linked the steelseries software to the new exe, but still nothing. The keybinds work fine in 32 bit.
My addon memory usage jumped about 33% in total with most addons jumping in the 25-40% range individually. Given that some people are complaining about addon settings behaving strangely, I think you might want to check how addons, in general, are working with the 64-bit client. It sure sounds as if something is up.

EDIT
No doubt there's a 5-10 FPS increase, though, as something positive!

The addon memory usage is a good thing. Now your addons have more RAM to use, no longer constrained by 32 bit address space.
i dont see any options> game preference... so yeah what? wow directory...i take it you mean wow folder so...its there...
Just wondering if I needed to delete anything, I downloaded the three files for the 64-bit client into my wow folder opened launcher as admin, now its seems to be stuck on 1% unlike before when it would go straight to about 5% and hang. I do have a fast cable modem so Im sure thats not it.

Join the Conversation

Return to Forum