I can't buy anything from the blizzard store.

Website Bug Report
When i try to buy anything from the blizzard store (clicking the checkout button), it refreshes me back to the blizzard store home page with the items still in my cart. Suggestions? (I have a ticket open about it)
Same problem.
having a similar issue trying to get the new mount, its saying my CC info is incorrect, even though I've purchased 2 things in the past year with the same card and it pays for 2 accounts monthly... I see another thread about another person complaining about not being able to purchase due to info issues.

also, the phone number provided on the website for issues with the store offers absolutely no options for support with the store.
Same problem as Chromatice.
eh, finally went through, but now it wont let me redeem the code. yay
Same issue here!!!
There has been an error processing your request.
Please verify that the information you entered matches what appears on your credit card.

All my information is correct, I have enough money in it, other cards also do not work, used the same information last time I used this.
02/16/2012 09:09 AMPosted by Orlyia
This is once again being investigated by our techs. Terribly sorry folks. It had indeed been resolved - for awhile

For issues with making a purchase on the store, Billing can sort you out and help with making your payment if you give them a call.

Still not working. I even bought something from steam with the same card and the same price and it WORKED. It's blizzards side, and I'm not waiting in a 3 hour queue.
I'm having the same issue as Spandexmufin. every time i click continue/checkout button it refreshes to the home page.
Day 5 of it not working same problem as listed above please help
This may not apply to everyone, but IF you do have a smartphone, you can successfully check out using it. I was just able to on mine. That may be able to help a few of you guys.
I'm having the same problem :( I click check out, then I'm right back at the blizzard store.

EDIT: I did as the above poster said and tried again on my iPhone, and it worked :D yay
Same problem, you would think a issue with blizzard taking our money would be on top of there list to fix... trying the smart phone idea.......didnt work
same issue here, havnt been able to try and purchase new pet and all details are definitly correct
I tried via the iPad, same error. Smartphone is next.
I had to call in to get it to work. It may be a problem with Verisign.
Been trying to buy some things all night, all I get is a message saying they cannot process my transaction. I tried several computers and even my phone. I give up.
This is the second time I have had trouble with the blizzard store! Don't you want my money?!
just tried to hit check out for HOA pet and it just refreshed the pet page....nothing i do wil let me check out

Join the Conversation

Return to Forum