Where are addon settings stored?

UI and Macro
I've had an issue where my interface and macro settings haven't been saving when I exit WoW. It was recommended that I delete my WTF folder, however after doing so and reconfiguring my UI and addons, the issue persisted.

I put in a ticket and the GM recommended that I run the game as Administrator. This worked, however again cleared every addon setting to default.

If I open the game without running as administrator, my settings UI settings are intact, but not any of the most recent interface changes I've made running as administrator.

I figured that I would need to run as administrator from now on in order to preserve all of my settings, so I created profiles in all of my addons that allow me to, so that I could use these settings when running as administrator.

However, the profiles are not available.

Its as if I'm running two completely separate versions of the game. My setting changes from run as admin do not carry over, and I don't know how to carry my non-admin settings to the admin version.

Anyone have any ideas, or should I start from scratch, configure everything as admin and always open the game like this? Are addon settings stored somewhere that I could physically backup or transfer the files?
Are you running Windows Vista/7 with WoW in the Program Files folder? The Program Files directory is protected, so Windows redirects any attempt to write to it to the VirtualStore directory.

Moving WoW out of the Program Files should resolve this.

If WoW isn't in Program Files, make sure that the WTF folder isn't set to read-only.
I'm running Windows 7.
I moved the World of Warcraft folder to the root of my C:/ drive. I made sure the entire directory was not 'read only' and I launched WoW without choosing "Run as Administrator" after moving it.

However, once I got in game, everything looked exactly as I did when choosing "Run as Administrator" before, which means all of my addon settings are gone and profiles unavailable. Are these settigns and profiles still stored anywhere where I can restore them?
Copy/paste this path into the address bar of a Windows Explorer window:%userprofile%\AppData\Local\VirtualStore

There will probably be a WoW folder with your up-to-date WTF folder in it.
There certainly was WTF folder in there, and I replaced my WTF folder with it.

I opened the game and all of my UI is back to normal. However, the original problem is back. Could I be getting the same write-access issues in my C:/ root, or should this location be safe? Is there any way I need to be removing "Read Only" settings other than selecting the directory properties, and unslecting the box, and choosing "Apply changes to this folder, subfolders and files"?

When I select this option, I get a dialogue box that shows it updating for all of the files in the directory, however if I return to the properties of the folder after, the icon still shows the partial checkmark.
I'm not sure what to do if the properties window doesn't apply the changes properly. You may have to ask Google.
Yeah you're getting the read only issue and just unchecking the box won't be enough. Here's relevant threads:

Join the Conversation

Return to Forum