Steelseries WoW Legendary Mouse not working

Mac Technical Support
The mouse software is not finding my toons on the armory and will not change the settings on the mouse at all, has anyone else had this issue and got a resolution. I opened a ticket with steelseries and it has been weeks with horrific responses for something that should be an easy answer. I had one but just got a new Mac and I LOVE it, but my "Mac Compatable" mouse isn't working right. I got the keybinds all set now but it doesn't work the same as with the software aka if I am over a menu button when I hit any mouse key it registers as a normal mouse click on that button and not the correct one it should hit.
The other thread that referred to this issue was locked without any sort of answer. I am also having the same problem- the driver for the SteelSeries Legendary Mouse odes not work. It will not connect to the armory and will not accept any settings. I don't have a PC to plug in and change the settings then revert to my mac.

SteelSeries claims this mouse is compatible with both OSs but, to my knowledge, it's not. Oh sure, it'll work technically but people using Mac OSX will not have the support and/or any use of the driver to set keys, change color or save profiles.

No answer from SteelSeries and no other information except a locked down forum thread that did not provide any useful information.

SteelSeries as a company provides very little to absolutely no mac support. You've been warned- whether you decide to invest or not is up to you.
I did get an answer from Steelseries on similar problems last summer. It took them just over six weeks to answer, but when they finally did, I was able to get the mouse working. The solution was rather complicated, you would never be able to solve it on your own, and involved, among other things, installing drivers that were not, at least at that time, available on their website or anyplace else that I know of. Also some complicated changes of settings in windows. I had a couple of professionals work on the problem for an afternoon, and they gave up.

In my view this mouse is by far the best design available, and I own at least a half-dozen fancy gaming mice. Fourteen or so buttons arranged where you can reasonably get to them while still using the mouse for steering is good. Shame about the horrendous customer service though. As far as what is going on with this company not answering questions, I'd say in any company, dealing with any sort of customer service is the lowest niche in the corporate food chain, nobody wants to do it, so whoever is unfortunate enough to be given the job does it whatever way they like.

Besides getting it to work, the one deficiency in it is not being able to program the buttons to simulate mod buttons. Ctrl, Alt, Shift. At least no simple way. Complex solutions do exist. I finally gave up on that and got foot pedals from Fentek, and am very happy with that. solution
03/16/2012 09:00 AMPosted by Memphispally
I did get an answer from Steelseries on similar problems last summer. It took them just over six weeks to answer, but when they finally did, I was able to get the mouse working.

So what was the resolution? Can you please paste it here as I just got the mouse today and am unable to program it, get information from the armory or even use both mouse buttons to move. The advertised defaults aren't working.

Would greatly appreciate you posting the info on here as I don't want to have to wait for two months to use this mouse.

I just got the "legendary" mouse this week - now I know that what makes it legendary is its fail. I am having the exact same problem that the other Mac users are having - not syncing my toons with the armory, etc., etc. I am really upset because I looked at a lot of reviews of mice and this seemed to be the best one. And since they worked with Blizzard on it, I expected it to meet my needs. Now, reading these posts (and the ones on the aforementioned locked thread), it looks like we are all just left swinging in the breeze. If anyone has found a way to make this mouse work with a Mac, please share. I have a feeling it will be going back in the box, though.
I just got this mouse after realizing that the original MMO mouse was not mac compatible. I am having the exact same problem as all of the other mac users. I'm planning on calling blizzard and or steelseries tomorrow to hopefully get an answer. I've been dying to get my hands on this mouse for months now and now that I have it, I don't want to give it up. It is the PERFECT size for my hands and the buttons are in all the right places. It would just be nice to be able to use the software and not have to go through the hassle of binding keys in game when I can see what buttons they are in the software. They finally got us a mouse that's "mac compatible" but it's not mac compatible at all.

But anyway, that's my rant, if I find out anything tomorrow I'll let you guys know. :-)
You probably may want to contact SteelSeries first, as they are the manufacturers of the mouse. We have limited support for the mouse.

Can you elaborate on what the specific issue you're having? If it is a bug we can address, we'll be happy to work on it.
I'm pretty sure it's a problem on steelseries' end. The problem is in the software. The in game key bindings work just find so I'm pretty sure that everything's working on your guys's end.

Basically what's happening is this: in the software my characters do not show up from the armory. I have triple checked to make sure there was no way to manually do this.
It will display my name and my level as 217216364...or something to that effect. Also half of the buttons that you can bind in the software don't work in game and half do, and you can't switch between the profiles. The software is up to date and so are the drivers.

I've just encountered a new problem today where my settings will reset each time I unplug the mouse. I've already submitted a ticket to steel series. If they don't respond in a few hours I will probably call them.

Like I said, I don't think this is anything on blizzard's end of the line. I thought it might be until I enabled the in-game mode for the mouse and just did it through key bindings. But I'm positive now that it's on steelseries end. Thanks for your help though. :-)
Same Problem here! no luck so far finding a cure! colors won't change properly cant sync same run of the mill stuff! Did anyone have luck yet?
Same issue, yet to find a solution.
I've been dealing with Steelseris for sometime now regarding this issue. The simple fact of the matter is this mouse is NOT Mac compatible. It did all the things the above posters mentioned and everything Steelseris recommended failed. I bought a new PC system and Bamm. Not a single problem Hell, it even works better than I had expected. I informed Steelseris with this observation and they acknowledged there seems to be some serious compatibility issues with Macs. And my information would be passed on to the appropriate departments to find a solution. But lets face it This is a older product and with so many others on the market I doubt any serious time will be put into correcting it.
Just got the Legendary Mouse. No dice on getting half the buttons to work. So far Only 1,2,3,7, and 9 buttons work. I cant get my toons synced either. Wont save my profiles. Wont even save the "in-game mode". However, I can set the working buttons through the keybindings in the interface. If anyone comes up with a solution please post. Thanks
Just got the Legendary Mouse. No dice on getting half the buttons to work. So far Only 1,2,3,7, and 9 buttons work. I cant get my toons synced either. Wont save my profiles. Wont even save the "in-game mode". However, I can set the working buttons through the keybindings in the interface. If anyone comes up with a solution please post. Thanks

Exactly the same for me, the left/right click, the middle mouse button (scroll wheel) and the top two on the thumb side work. The rest don't. I thought it was my USB's and went through some tech support on that and reinstalling drivers, etc. I was able to get the buttons all working with no problem on a different computer. I'm thinking it has something to do with the mouse drivers and the way they interact with... something? I don't know really at all though.

Let me know if you ever find a solution and I'll do the same. I've got tickets open with Steelseries. I really like the mouse but if I can't get hte buttons working I'm gonna have to return it to Amazon relatively soon to make sure I make it in the return window. I think you have 30 days with Amazon. Thats where I got mine, obviously. I just can't justify keeping the mouse if I can't use the buttons, obviously.
I went through nearly three months of back-and-forth with SteelSeries support on a similar issue, and their ultimate solution was for me to RMA the Legendary Mouse to them and give me a Sensei in its place. Not really an ideal solution but since I had originally bought the Legendary because my old mouse was flat-out broken (and was therefore running that nearly three months trying to play the game with a WACOM TABLET AND STYLUS for pete's sake) I was tired of arguing.

For me, the issue was that I was running 10.6.8 that wasn't a "clean" install and the software would not properly install with permissions (you can see if this is the case for you by going into your Applications folder and looking at the WoW Legendary Mouse folder; see below). They were unable to produce my issue on their end—nor was _I_ able to reproduce the issue on _MY_ end, except with my live install (which presumably has some legacy code from some previous OS updates—a fresh 10.6 install and a fresh 10.6 -> 10.6.8 both installed the software without issue).

I wish I had seen this thread much sooner. The button layout of the Legendary looks (and felt) ALMOST perfect, but I could have saved myself so much heartache omg :(

Anyway this was the permissions error:
And this is what it should look like if it actually works:
Today my mouse stopped working and i was advised in game via a popup it was not detected and to check the box in the interface panel when it was connected. Every time I did the pop-up window would reappear. when i clicked okay on the pop-up window the mouse was removed from the interface check box i had checked. viscious little circle. I too had limited buttons but was enjoying at least that. Yesterday it worked fine today nothing? really. Gonna try verifying the disks etc but this thread is outright disheartening as the mouse packaging advertised it was mac compatible!
Just a PSA to anybody reading this thread. I bought the "Mac compatible" mouse tonight. I've spent about 4 hours all over the place trying to find answers. There are NONE to be found.

The simple truth is that SteelSeries has blatantly misrepresented this product. Legally I suppose the cursor on my screen moves and therefore it is "Mac compatible", however under no circumstances does this product perform as advertised on the Mac. Bungie is no help. SteelSeries is no help. So help yourself and return the product for a refund before it's too late for you.
What is the model number of the mouse?
Mine is having issues as well. Tuesday afternoon I got on and did LFR and some derping around, I didn't play at all yesterday. Today I logged on and was doing stuff around my garrison when I noticed my keybinds on my mouse are no longer working... I tried re installing the software but it didn't make a difference. I've never had the issue before... so I'm not quiet sure whats wrong...
Picked up the mouse today installed software and drivers and half the buttons do not work.
Same issue on my end. I didn't play last evening then today half the keys on the mouse wont respond.

Join the Conversation

Return to Forum