[Linux] For those with Launcher problems, read this

Technical Support
Especially applies to Linux users!

Assuming you've already updated to the latest Wine 1.4, with these commands:
sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.3

of course then you want to type "winecfg" into a terminal window and let it get the gecko, and check your update manager. you can then optionally run the terminal command "sudo apt-get autoremove" to get rid of obsolete references that were left behind.

yes, that last command says 1.3, but you will get 1.4

NOW THEN!!

pre-note: also applies if you're getting login error message "you have been disconnected from the server" or errors directing you to check that you typed your login name and password correctly, as these were the original two problems we experienced during today's patch.

The command launcher hangs up, the progress bar sits forever. Open your Task Manager and shut down process called "C:/Program Files" or some variation. I am not positive if the line represents a bookmark i have by that same name, or the location of programs within Wine.

Shutting down this process allowed the launcher to finish getting the updated tools (very quickly, i might add) and the proper patch launcher appears and begins the patch.

Hope this helps! I'll be checking back for responses or further questions.
Thanks that was pretty helpful. I was getting snagged on the updated tools part of the launcher and would freeze up. Looked for the process in task manager, mine was called wow 4.2.1 etc and I killed that and now i'm downloading without a problem :)
That first post worked on Linux Mint 12 LXDE.

This worked on Linux Mint 11 GNOME:
kill the process called wow.1.4.2. or somethingother like that. you'll see it in your running processes list, and will notice that it's state is to send the stop command. obviously it fails to stop.
Hey weeboo

:) glad we're moving forward again!

I think shutting down wow.4.2.1 at the hangup point will probably be the fix for all distros.

I noticed that launcher/tools update failure is pretty rampant on the tech support forums today, and am assuming it is not isolated to Linux, but that it extends to Windows as well.

Thanks and hope we dont forget this next patch!
(self-bump since people are still looking for solutions)
Thank you soo much. confirmed fix for Ubuntu 11.10

I was having the disconnected from the server issue caused from the system survey.
happy to help!
Updating to 1.3 [edit: actually 1.4] worked for me, as did the task killing trick.

Thanks a lot.
Shayele, run winecfg from terminal, click About, and please report if you're on 1.3 or 1.4. you might think you have the older when in fact the newer is what you got.
bump!

thanks to Crimsonmane for his info. Allowed me to get in game via deleting that Task Manager wow.4.2.1 program running :D
Killing the errant task worked for me on Fedora 16. :)
bump
03/29/2012 09:02 AMPosted by Caotica
bump


Did you have a question?
03/29/2012 10:52 AMPosted by Raimondas
bump


Did you have a question?


That was me, logged in under different account, periodically giving the thread a refresh.
03/27/2012 10:53 PMPosted by Crimsonmane
Shayele, run winecfg from terminal, click About, and please report if you're on 1.3 or 1.4. you might think you have the older when in fact the newer is what you got.


For sure it's 1.4.

Running Lubuntu, latest.
When I try it, after I kill the process the launcher returns a disconnect then exits.
bump, this isn't working anymore. any other ideas?
this applied to the crashes experienced the date of the original post. right now we're experiencing "disconnected from server" error when trying to log in. but it is not across-the-board in any way. my laptop behaves fine, the desktop will not log in to the game. i've tried 7 different kernels to rule that out, and several different desktop environments. i've done traceroute which make it obvious which hops have been causing the bad lag all week, but it made it through to the end.

also just ruling this out for you, davishton, to make sure you disable peer-to-peer in the launcher/downloader.
Just killed wow-4.3*** process from q4wine and magically the launcher finished its task.

Thanks dude
Killing the process worked like a charm! In Linux Mint, MENU then SYSTEM TOOLS then SYSTEM MONITOR and click on the PROCESSES tab. Scroll down, you will see the process. It gave a network error on connecting to the news server but is happily downloading the installation files.

Join the Conversation

Return to Forum